Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 03-30-2013, 05:59 AM
nycbmdriver nycbmdriver is offline
Registered User
Location: NYC
 
Join Date: Mar 2013
Posts: 1
Mein Auto: 01 X5,98 528I
Camshaft postion sensor

I changed my camshaft position sensor with a beck and arnley model the check engine light still on. Someone told me i have to only use dealer sensor is that true
Reply With Quote
Advertisement
  #2  
Old 03-30-2013, 06:45 AM
Zulu95's Avatar
Zulu95 Zulu95 is offline
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 847
Mein Auto: 2001 X5 3.0L
I have read on Xoutpost of people fitting non-OEM sensors and the problem coming back soon after. Did you reset the SEL with a scanner?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms