Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 03-30-2013, 04:20 PM
buster1015 buster1015 is offline
Registered User
Location: SoCal
 
Join Date: Mar 2013
Posts: 5
Mein Auto: 2001 X5 4.4l
GPS partially working but inaccurate

Background
I have a 2001 X5 4.4l and last week completed an oil change and reset the service indicator. Because I have an early 2001 it could not be reset using the dash buttons. Instead I used a jumper to reset at the 'Pacman' port under the hood. Everything functioned fine for two days including multiple uses of the Nav System.

Current Symptoms
I enter a destination address and map it. But, the direction arrow is not stable and spins slowly. My vehicle location displayed is very close to correct but sometimes shows on a nearby street. While driving my vehicle location will jump to a nearby street or show in the wrong direction. I have also noticed that when I turn on the vehicle the nav/radio screen takes longer to turn on than I remember. Seems like a good 30 seconds until it is on although the radio begins playing (if it was on before). This slow to turn on screen began the same day as the GPS issue. All other functions I've used are working.

Tests so Far
First thing I could think of to check was to go into the Nav Service Mode.
I looked at the Sensor Check menu which showed:
Wheel sensor: 0 when parked and increased proportional to driving speed
GPS satelite: 08 when parked and varied from 06 to 08 while driving
GPS status: Positioning known (at all times)
Gyro: always pointed in direction of vehicle travel
Direction: forward or backward and matched vehicle travel

GPS Tracking Info:
shows a list of 8 channels representing satelites
S/N varied but 5 channel's S/N were between 5 and 12
remaing 3 channels' S/N was 3 or 4

Thoughts
I don't want to just start replacing parts. Seems like some of the S/N values are a bit low. I'm thinking of checking the antenna cable or trying to temporarily swap in a know good antenna. After that I have no idea what to do next. Any advice is appreciated.
Reply With Quote
Advertisement
Reply

Bookmarks

Tags
gps, navigation


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms