Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 03-31-2013, 06:42 PM
bigrobtemp bigrobtemp is offline
Registered User
Location: Detroit
 
Join Date: Mar 2013
Posts: 9
Mein Auto: X-5 and 94 325i Convert.
Radio speker Problem--Please help

I have an 05 X5 that i just recently bought about a month ago. I have done some minor work (replaced tension strut, busted brake line) but the radio has me confused. When i picked up the car the right side speakers were working but muffled. I figured no problem thats an easy fix. Well it's an easy fix on a "normal car" but as i found out, this X5 is far from normal. So after digging out the spare and making sure all connections were good as far as corrosion and being plugged in, i still had the left side working normal and the right muffled. So were driving along this evening and all of the sudden the right side starts working, just rolling down the road. so it works for about an hour and we hit a rest stop and shut off the X. Get back in and start to leave and notice once again the ride is back to muffled? I have noise out of speakers so i assume the radio is sending the signal. I am lead to beleive the amp is faulty but now with them just coming on i have to kind of rule that out too? The plugs were all clean but maybe i missed something? It's very confusing that BMW would build a 50 thousand plus SUV and put such a complex and underperforming info system in it. I have the Nav, DSP, 12 speaker system. Any help at this point is greatly appreciated. One sided speaker system sucks. Thank you
Reply With Quote
Advertisement
  #2  
Old 04-01-2013, 02:40 AM
Estorma Estorma is offline
Registered User
Location: Scranton
 
Join Date: Dec 2012
Posts: 3
Mein Auto: BMW
Quote:
Originally Posted by bigrobtemp View Post
I have an 05 X5 that i just recently bought about a month ago. I have done some minor work (replaced tension strut, busted brake line) but the radio has me confused. When i picked up the car the right side speakers were working but muffled. I figured no problem thats an easy fix. Well it's an easy fix on a "normal car" but as i found out, this X5 is far from normal. So after digging out the spare and making sure all connections were good as far as corrosion and being plugged in, i still had the left side working normal and the right muffled. So were driving along this evening and all of the sudden the right side starts working, just rolling down the road. so it works for about an hour and we hit a rest stop and shut off the X. Get back in and start to leave and notice once again the ride is back to muffled? I have noise out of speakers so i assume the radio is sending the signal. I am lead to beleive the amp is faulty but now with them just coming on i have to kind of rule that out too? The plugs were all clean but maybe i missed something? It's very confusing that BMW would build a 50 thousand plus SUV and put such a complex and underperforming info system in it. I have the Nav, DSP, 12 speaker system. Any help at this point is greatly appreciated. One sided speaker system sucks. Thank you
it seems you did not missed anything and amp could be the cause of problem.. Very difficult to find the problem

Last edited by Estorma; 04-01-2013 at 11:25 PM.
Reply With Quote
  #3  
Old 04-19-2013, 08:04 AM
Utes Utes is offline
Registered User
Location: Canada
 
Join Date: Aug 2010
Posts: 5
Mein Auto: BMW X5 4.4i
Radio speker Problem--Please help

Hey I have the same problem. I found out I have a blown speaker in the right door.




Sent from BimmerApp mobile app
Reply With Quote
  #4  
Old 04-19-2013, 09:48 AM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
Radio speker Problem--Please help

Quote:
Originally Posted by bigrobtemp View Post
It's very confusing that BMW would build a 50 thousand plus SUV and put such a complex and underperforming info system in it.
Heh i just came from a 745 and that was 80k+ original msrp and the amp blows every other sunday on those cars. Seems as though it may be a common trend for bmw vehicles with the premium sound packages for their amps to bite the dust.
It is also very possible for just one side of the amp to go bad. Very time consuming to diagnose but if you have a buddy or neighbor with an x that has the dsp you could try to swap the amp and see if it goes away, or gamble on a used one that may not be working at all, or shotgun a new one and it isn't the problem and your speaker is no good.
If you can swap an amp you can determine if its the speaker or the amp. Is it all the speakers on that side? If not swap it with a speaker that sounds normal, if its still acting up its probably the amp.


Sent from BimmerApp mobile app
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i
Reply With Quote
  #5  
Old 04-19-2013, 05:54 PM
bigrobtemp bigrobtemp is offline
Registered User
Location: Detroit
 
Join Date: Mar 2013
Posts: 9
Mein Auto: X-5 and 94 325i Convert.
It's fixed. Sent BM53 to UK, came back fixed and now i have all speakers and a nice sound system. navi4cars@gmail.com, just look him up and see what he can do. I had a good experience with him.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms