Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 04-04-2013, 10:31 AM
bmw330i06 bmw330i06 is offline
Registered User
Location: Raleigh
 
Join Date: Apr 2013
Posts: 1
Mein Auto: bmw 2006 330i
Evap p0440 2006 330i sedan

Hello Everyone I need your help. I just Got my e90 about 30 days ago 69000 miles (no warranty) the car drove perfect for one week, after that it threw a code (p0440) which is evap went ahead and got new gas cap reseted the ses drove about 50 miles light came back same code, took it to my mechanic did a smoke test found the sensor near the gas tank letting the smoke out changed the sensor drove for about 270 miles Ses is back on same code at that time my mechanic told me that he had to change the purge valve sensor as well but he thought he would give it a try maybe we could have saved the money and that was what the BMW Dealer ship had told him when he went to pick the first sensor, now we put the purge valve and reset the code and right now i drove on it for 210 miles appro. but i have a feeling the evap is still there becuase of the way the car idles some times it is very steady and some times it fluctuate up and down very slightly even when i have it on cruise down the highway...any body can share their thougts or let me know if they had the issue, is the rpm normal like that or not.....Thank you all.
Reply With Quote
Advertisement
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms