Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 04-10-2013, 06:42 AM
kraz43series kraz43series is offline
Registered User
Location: new jersey
 
Join Date: Dec 2009
Posts: 63
Mein Auto: bmw 328i
328i couple overheating again so frustrated! Please help

Hey guys

So last week I'm driving home from work and the coolant light came on and the car shut down on me. Mines a 2007 by the way with 110K. So I get out of the car look underneathe and there's coolant everywhere on the ground and open the hood and it's smoking. Also it did that a few times before but never leaked where the light came on and I would just wait awhile add a little coolant and it would be fine. So I take it to my mechanic he replaced the water pump and electric fan. So the car seemed fine. Also before all that happened I failed to mention the car was driving like crap the last few months. I noticed loss of power while shifting through gears. Something just didnt feel right. So yesterday I'm driving home from work sitting in traffic it must've been our first 80 degree day this year and the coolant light comes on! I had the ac on also. So I pull over open the hood there was a little bit of white smoke comin out for about two seconds I saw and then nothing. Checked underneathe the car no coolant leaking. I waited about half hour started the car had a 30 minute drive home and got home fine. No warning lights temp gauge was at normal car ran good. But I hate when that light comes on. Something doesn't feel right. Do I bring it back to the mechanic today? I've had this car since jan 2010 and I've loved her ever since. I just want this mess to stop already
Thank you
Reply With Quote
Ads by Google
  #2  
Old 04-10-2013, 07:14 AM
GarySL's Avatar
GarySL GarySL is offline
Officially Welcomed to the 'Fest
Location: Humboldt County, CA
 
Join Date: Jan 2008
Posts: 5,599
Mein Auto: '08 335xi (E90)
Was the thermostat replaced?
__________________
'08 335xi (E90), 6MT, Arctic/Black, ZPP, ZSP (18"s), ZCW, CA, PDC, i-Pod
Ordered: March 7, 2008
Built: March 17, 2008
At port: March 19, 2008
Shipped on Graceful Leader: March 21, 2008
Arrived Port Hueneme: April 11, 2008
At dealer's: April 19, 2008
Delivered: April 21, 2008
Reply With Quote
  #3  
Old 04-10-2013, 09:35 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,009
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by kraz43series View Post
Hey guys

So last week I'm driving home from work and the coolant light came on and the car shut down on me. Mines a 2007 by the way with 110K. So I get out of the car look underneathe and there's coolant everywhere on the ground and open the hood and it's smoking. Also it did that a few times before but never leaked where the light came on and I would just wait awhile add a little coolant and it would be fine. So I take it to my mechanic he replaced the water pump and electric fan. So the car seemed fine. Also before all that happened I failed to mention the car was driving like crap the last few months. I noticed loss of power while shifting through gears. Something just didnt feel right. So yesterday I'm driving home from work sitting in traffic it must've been our first 80 degree day this year and the coolant light comes on! I had the ac on also. So I pull over open the hood there was a little bit of white smoke comin out for about two seconds I saw and then nothing. Checked underneathe the car no coolant leaking. I waited about half hour started the car had a 30 minute drive home and got home fine. No warning lights temp gauge was at normal car ran good. But I hate when that light comes on. Something doesn't feel right. Do I bring it back to the mechanic today? I've had this car since jan 2010 and I've loved her ever since. I just want this mess to stop already
Thank you

Oh, yeah.

And when you do, ask what OBDII reader he uses, and get a printed readout of all codes.

Post image here!
Reply With Quote
  #4  
Old 04-17-2013, 11:57 AM
BROOKSBC's Avatar
BROOKSBC BROOKSBC is offline
Officially Welcomed to the 'Fest
Location: Woodbridge, VA
 
Join Date: Apr 2009
Posts: 161
Mein Auto: 01 BMW 330i
Why did the mech replace the fan? Just curious because I have the same car with a similar issue. I was sitting a light and my yellow temp light came on and then the red one and I lost all power. Pushed the car to parking area got out and popped the hood. It appears I had some fluid loss from the purge valve area and a minor puddle under the car. And while I was or still am waiting for it too cool down I checked my fan and it don't come on. Fuse is good. Don't know what happened but it happened all at once with no indication.

Sent from my SAMSUNG-SGH-I747 using Bimmer App
Reply With Quote
  #5  
Old 04-17-2013, 12:30 PM
3star 3star is offline
Officially Welcomed to the 'Fest
Location: texas
 
Join Date: Mar 2013
Posts: 679
Mein Auto: 89 E30 Cabrio
Quote:
Originally Posted by kraz43series View Post
Hey guys

So last week I'm driving home from work and the coolant light came on and the car shut down on me. Mines a 2007 by the way with 110K. So I get out of the car look underneathe and there's coolant everywhere on the ground and open the hood and it's smoking. Also it did that a few times before but never leaked where the light came on and I would just wait awhile add a little coolant and it would be fine. So I take it to my mechanic he replaced the water pump and electric fan. So the car seemed fine. Also before all that happened I failed to mention the car was driving like crap the last few months. I noticed loss of power while shifting through gears. Something just didnt feel right. So yesterday I'm driving home from work sitting in traffic it must've been our first 80 degree day this year and the coolant light comes on! I had the ac on also. So I pull over open the hood there was a little bit of white smoke comin out for about two seconds I saw and then nothing. Checked underneathe the car no coolant leaking. I waited about half hour started the car had a 30 minute drive home and got home fine. No warning lights temp gauge was at normal car ran good. But I hate when that light comes on. Something doesn't feel right. Do I bring it back to the mechanic today? I've had this car since jan 2010 and I've loved her ever since. I just want this mess to stop already
Thank you

Couple things can cause this, the end tanks on the radiator are plastic, they sometimes crack and need to be replaced, there may also be a bad hose somewhere in the cooling system that can cause this. These can be ruled out quite easily by doing a cooling system pressure test, a good garage will have the tools to do this.

Another cause can be a cracked head gasket or cracked head.this will cause combustion pressures to enter the cooling system causing it to bubble over and the car release the pressure by dumping the coolant on the ground. This causes the engine to burn through coolant very quickly and if not topped up daily will lead to over heating. Depending on where the leak is the car may show other symptoms like white smoke or milky oil, but these symptoms usually show up when the head gasket has about had it.another symptom is the bloody engine bay symptom, where your entire engine looks covered with coolant.

You can test for a bad head gasket using a leak down test. The garage can do this.if its a cracked head the only way to test that is to remove the head and take it to a machine shop. Its very common for you to have a cracked head that only opens up when the engine is hot, then reseals itself thus passing the leakdown tests when the engine is cool or warm.leak down test should be done on a hot engine but from experience mechanics don't do that because working on a hot engine is dangerous and also the parts are very brittlle so its easier to break things.


Other possibilities include the head bolts stretching under load, this can happen if they weren't torqued properly, or you blew out a freeze plug. Very unlikely since that wouldn't make the car hold any coolant
Reply With Quote
  #6  
Old 04-17-2013, 12:34 PM
3star 3star is offline
Officially Welcomed to the 'Fest
Location: texas
 
Join Date: Mar 2013
Posts: 679
Mein Auto: 89 E30 Cabrio
Quote:
Originally Posted by BROOKSBC View Post
Why did the mech replace the fan? Just curious because I have the same car with a similar issue. I was sitting a light and my yellow temp light came on and then the red one and I lost all power. Pushed the car to parking area got out and popped the hood. It appears I had some fluid loss from the purge valve area and a minor puddle under the car. And while I was or still am waiting for it too cool down I checked my fan and it don't come on. Fuse is good. Don't know what happened but it happened all at once with no indication.

Sent from my SAMSUNG-SGH-I747 using Bimmer App
Every electric fan has a relay. Relays fail fairly awesome
Reply With Quote
  #7  
Old 04-17-2013, 12:57 PM
BROOKSBC's Avatar
BROOKSBC BROOKSBC is offline
Officially Welcomed to the 'Fest
Location: Woodbridge, VA
 
Join Date: Apr 2009
Posts: 161
Mein Auto: 01 BMW 330i
Quote:
Originally Posted by 3star View Post
Every electric fan has a relay. Relays fail fairly awesome
I let the car cool and attempted to drive it again. The fan came on and it was blowing extremely loud and high but the temp lights came back on anyway and I had to stop and let it cool again. Getting a tow truck now but still wtf?

Sent from my SAMSUNG-SGH-I747 using Bimmer App
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms