Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)

E63 / E64 6 Series (2003 - 2013)
The E63/E64 BMW 6 Series builds on BMW's sporty heritage with aggressive lines and an incredible motor to back the design up. Available in coupe and convertible trims with a standard 4.8 liter engine producing 360 horsepower and 360 lb-ft of torque, the 6-series is a popular choice that exceeds expectations.

Reply
 
Thread Tools Display Modes
  #1  
Old 04-15-2013, 03:26 PM
astroturf astroturf is offline
Registered User
Location: LA
 
Join Date: Apr 2013
Posts: 2
Mein Auto: 650i
2009 650i Sluggish acceleration

Hey guys - lately my 650i / auto / 2009 60k has been acting sluggish with acceleration. I can basically place the pedal full to the ground and it will ramp up - smoothly mind you - but no where as fast as it used to. I also notice a slight vibration when idle. Any ideas?
Reply With Quote
Advertisement
  #2  
Old 04-15-2013, 03:40 PM
07 E63650i's Avatar
07 E63650i 07 E63650i is offline
Living in Fast Forward
Location: Southern California, USA
 
Join Date: Jan 2013
Posts: 3,213
Mein Auto: 2007 BMW E63 650i
Quote:
Originally Posted by astroturf View Post
Hey guys - lately my 650i / auto / 2009 60k has been acting sluggish with acceleration. I can basically place the pedal full to the ground and it will ramp up - smoothly mind you - but no where as fast as it used to. I also notice a slight vibration when idle. Any ideas?
I have never had this kind of issue before, but the experts will chime in soon. I'm guessing that if you have an idle issue, you should check your CCV first. The throttle seems like the throttle body could be affected or I'm guessing that the drive-by wire could be affected.
__________________
Once a 6'er, always a 6'er.
Reply With Quote
  #3  
Old 04-15-2013, 04:25 PM
msa9167's Avatar
msa9167 msa9167 is offline
Officially Welcomed to the 'Fest
Location: Prospect Hts, Ill
 
Join Date: Feb 2008
Posts: 168
Mein Auto: 2009 BMW 650I
Any codes???
Reply With Quote
  #4  
Old 04-15-2013, 04:56 PM
astroturf astroturf is offline
Registered User
Location: LA
 
Join Date: Apr 2013
Posts: 2
Mein Auto: 650i
No codes - I don't have a reader. Anyone is LA area have one - willing to pay for a quick diagnostic....
Reply With Quote
  #5  
Old 04-15-2013, 06:36 PM
HerbP HerbP is offline
Officially Welcomed to the 'Fest
Location: Georgia
 
Join Date: Jul 2009
Posts: 2,683
Mein Auto: 2005 645Ci & 2007 750Li
There could be some hidden or part time codes not throwing the CEL light. The 1st thought would be a timing related issue, possibly from the Vanos solenoids. The 2nd thing would be a fuel related problem from partially clogged injectors, or fuel filter problem. It might be in your best interest to have BMW or an Indy pull your codes. This might cost 150.00 or less, but you will know what the problem is. At that point you could have anyone do the repair.

Good Luck!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms