Dice Duo - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 04-19-2013, 08:41 PM
sander112 sander112 is offline
Registered User
Location: Mississippi
 
Join Date: Aug 2012
Posts: 7
Mein Auto: 2007 BMW X3 3.0si
Dice Duo

I have installed the audiovox dice duo using sirius about 6 months ago and everything has worked great till about a month ago. I am getting a detached message with it now and its not working. I have disconnected the duo for about a week and it doesn't work after hooking it up a week later. I have disconnected the battery with no help either this is from the direction from audiovox. Has anyone has this problem and if so what did you do to correct it. I am to the point of attempting to see if they will repair/ replace it under warranty. I have searched the internet for this message and it seems no one has ever had this problem, which is hard to believe?
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:46 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001- VerticalScope Inc. All rights reserved.