Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 F25 (2011 - current)

X3 F25 (2011 - current)
The latest X3 brings some added style and some new features to the BMW SUV family. Talk about the new F25 now!

Reply
 
Thread Tools Display Modes
  #1  
Old 06-22-2013, 05:36 AM
ctlyankee ctlyankee is offline
Registered User
Location: Virginia
 
Join Date: Apr 2012
Posts: 21
Mein Auto: Acura TL
Oil Sensor accuracy????

Two months ago, while driving, a warning flashed that I should add a quart of oil ASAP. I had the oil changed only 10 weeks prior, so I doubted that it would need oil already. I pulled over and shut the engine off then restarted. At that point I ran the check oil level and it showed it was at the max. Yesterday the warning came on again, so I pulled over to check the level after I restarted it said the oil level was OK but only showed about 1/4 over the min. So I stopped at the dealership on my way home and they put a quart of oil in but the level still shows about 1/4 over min. After driving today I checked the level again and the level has not changed. I really wish it had the "old fashion" dipstick to check oil levels. I read a few other posts on this problem but I could not find a definitive outcome. How many others experienced this problem? BTW: The representative at the dealership stated it was not unusual for BMWs to need oil added between changes. - I find that somewhat disconcerting.
Reply With Quote
Ads by Google
  #2  
Old 06-22-2013, 06:58 AM
The X Men The X Men is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Mar 2012
Posts: 4,717
Mein Auto: 2012 535xi 2013 X3 35i
Sounds like you have a intermittent oil level sensor problem rather than a accuracy problem or an actual oil leak problem. If this problem occurs again, I would ask your dealer to check the actual amount of oil you have in the engine by draining and measuring the volume.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 F25 (2011 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms