Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 F25 (2011 - current)

X3 F25 (2011 - current)
The latest X3 brings some added style and some new features to the BMW SUV family. Talk about the new F25 now!

Reply
 
Thread Tools Display Modes
  #51  
Old 05-14-2013, 05:46 AM
Jimsan Jimsan is offline
Registered User
Location: Somers, NY
 
Join Date: Mar 2013
Posts: 71
Mein Auto: X3
I'm supposed to get an email or call when I'm ready to be hooked up. I have had the 2014 X3 since April 10th. Nothing. So I called again yesterday and they said after checking my record oh we can hook you up by tonight. This morning still not working, no services available. However I tried again and was finally able to send a Google map address to the car. I'll call them when they open later today.
Reply With Quote
  #52  
Old 05-14-2013, 07:54 AM
Drewsky's Avatar
Drewsky Drewsky is offline
Officially Welcomed to the 'Fest
Location: Tampa, FL
 
Join Date: Mar 2002
Posts: 331
Mein Auto: '14 X3 35i-M Space Grey
Quote:
Originally Posted by Jimsan View Post
I'm supposed to get an email or call when I'm ready to be hooked up. I have had the 2014 X3 since April 10th. Nothing. So I called again yesterday and they said after checking my record oh we can hook you up by tonight. This morning still not working, no services available. However I tried again and was finally able to send a Google map address to the car. I'll call them when they open later today.
Have you gone into connected drive following whatever changed last night and requested an update? That may fix it.
Reply With Quote
  #53  
Old 05-14-2013, 08:03 AM
Jimsan Jimsan is offline
Registered User
Location: Somers, NY
 
Join Date: Mar 2013
Posts: 71
Mein Auto: X3
Just talked to them and was told to press the button to verify all information and get set up. Did that. In my case not a single service is available. Called them back and was told this is a known problem. There is no date set by which it will be resolved. They will inform dealers and individual owners once it's working, she said. But I am able to send a google map address to my car.
Reply With Quote
  #54  
Old 05-14-2013, 08:05 AM
Jimsan Jimsan is offline
Registered User
Location: Somers, NY
 
Join Date: Mar 2013
Posts: 71
Mein Auto: X3
I just can't receive it.
Reply With Quote
  #55  
Old 05-16-2013, 07:18 PM
jlerner62 jlerner62 is offline
Registered User
Location: NY
 
Join Date: May 2013
Posts: 25
Mein Auto: 335i
I had this problem with my current 335. Turned out to be a goggle problem. Try it with this web address: http://maps.google.com/?ftr=0
Reply With Quote
  #56  
Old 05-16-2013, 07:35 PM
Jimsan Jimsan is offline
Registered User
Location: Somers, NY
 
Join Date: Mar 2013
Posts: 71
Mein Auto: X3
Jlern62, I have no services available, period. Today I got a call that I was finally hooked up! No it's still not working. The lady said the database was just loaded and it may take a while to reach my car. If it's not working tomorrow they will report it to the tech people. Funny the google map feature is important to me but also the iPhone apps would be nice to see working.
Reply With Quote
  #57  
Old 05-16-2013, 09:18 PM
scottjays scottjays is offline
Officially Welcomed to the 'Fest
Location: SoFla
 
Join Date: Feb 2010
Posts: 108
Mein Auto: 2014 BMW X3 35i M Sport
that google address didn't work for me. same "can't send message" I've been getting. It's strange, in my 2014, all services seems to work. or at least they show active. the news headlines work, weather, gas, etc. really unimpressive to have a 1 sentence news headline. wow. fail. all i really wanted to work was send google maps to car. they can have all the other unimpressive garbage.

I called to complain again to BMW Assist. same story. I also called BMW NA and really complained. I am wondering if this feature is not resolved soon, do I (we) have an legal action. I hate to be the moron who brings this up, dare say "class action"

Quote:
Originally Posted by jlerner62 View Post
I had this problem with my current 335. Turned out to be a goggle problem. Try it with this web address: http://maps.google.com/?ftr=0
__________________
2014 BMW X3 35i M Sport Carbon Black, Nevada Chestnut, Wave Wood. Driver Assistance, Premium, Technology, M Sport, Dynamic Handling, Premium Sound and Heated Front Seats.
Reply With Quote
  #58  
Old 05-17-2013, 02:09 PM
grebersole grebersole is offline
Registered User
Location: USA
 
Join Date: May 2013
Posts: 23
Mein Auto: 2014 X3 xDrive 35i
scottjays I was thinking the same thing or maybe a complaint with the Federal Trade commission for false advertising or bait and switch. Of course, I am not a lawyer so who knows if we have any options but to spend our money elsewhere the next time. It seems very unfair and may cause me to never buy the BMW brand again.
Reply With Quote
  #59  
Old 05-17-2013, 02:23 PM
sfiermon sfiermon is offline
Officially Welcomed to the 'Fest
Location: NH
 
Join Date: Apr 2011
Posts: 390
Mein Auto: 2014 x3 35i
Really? It's a tech option with a car. The 2014 models JUST came out and really the rest of the model lineup isn't until July. No offense here and I consider this a misstep from BMW...but did you buy the car to send google addresses to it or did you buy it because it drives awesome? If you bought based on tech alone, Ford has some nice tech in their cars these days.

The FTC or lawyer would laugh you out of their offices or just dismiss this as nonsense IMO. Don't waste your time as precious as it is with frivolity like this. BMW is addressing it...they know about it...they will fix it. If it takes until July, then that isn't the END OF THE WORLD is it? If you are concerned about anything monetarily, work something out with the dealer...BMW won't compensate or if they will...perhaps get something like extended maintenance or something.
Reply With Quote
  #60  
Old 05-17-2013, 02:35 PM
grebersole grebersole is offline
Registered User
Location: USA
 
Join Date: May 2013
Posts: 23
Mein Auto: 2014 X3 xDrive 35i
End of the world? No But when you pay for a service ( and there is a fee for this) and purchase a vehicle for $50k +, I expect it to be 100%
Reply With Quote
  #61  
Old 05-17-2013, 02:35 PM
sfiermon sfiermon is offline
Officially Welcomed to the 'Fest
Location: NH
 
Join Date: Apr 2011
Posts: 390
Mein Auto: 2014 x3 35i
Doesn't it come free for 10 years now?
Reply With Quote
  #62  
Old 05-17-2013, 02:43 PM
sfiermon sfiermon is offline
Officially Welcomed to the 'Fest
Location: NH
 
Join Date: Apr 2011
Posts: 390
Mein Auto: 2014 x3 35i
http://www.extremetech.com/extreme/1...st-decade-free
Reply With Quote
  #63  
Old 05-17-2013, 02:48 PM
grebersole grebersole is offline
Registered User
Location: USA
 
Join Date: May 2013
Posts: 23
Mein Auto: 2014 X3 xDrive 35i
Here is what the BMW Website site says:
BMW pays for the first year of the BMW Assist Safety Plan for 2006 and earlier models (credit card information required) and four years for 2007 and later models, effective from your vehicle's in-service date. After the BMW-paid term of service is over, the annual Safety Plan fee is $199 plus applicable taxes. You can extend service for your intended ownership or lease period during enrollment. The optional Convenience Plan costs $199 per year, plus applicable taxes. You must be a Safety Plan subscriber to enroll in the optional Convenience Plan.

The Unlock feature etc is for 10 years with the purchase of the technology package and BMW Online is included for 3 years in the technology package. I am guessing if you don't purchase the technology package in the car, some of these services a offered at an additional fee.

Last edited by grebersole; 05-17-2013 at 02:50 PM.
Reply With Quote
  #64  
Old 05-17-2013, 03:05 PM
scottjays scottjays is offline
Officially Welcomed to the 'Fest
Location: SoFla
 
Join Date: Feb 2010
Posts: 108
Mein Auto: 2014 BMW X3 35i M Sport
I agree with most of what you said. no question BUT still I was sold product that doesn't do what I was told or led to believe. Will it ever?, hopefully it will. I have no choice but to be patient and wait. I know there is no legal action available. but still why sell me a buggy product and then be so vague on a fix. I got very used to using the sending google maps feature from my X6. I used it every single day. my office would send me new locations as well. I was really expecting it to just work. I love my 14 MSport 35i the car is amazing. I am just super ticked that the one feature I was really expecting to use isn't working and there is NO fix in sight. I am not even sure it's BMW, all services show working in my car. Maybe it's a google problem.
If another part of the tech wasn't working, let say the Sat radio. I know it could be fixed, hardware swap. new ESN provided. database update to show VIN and new ESN. I love Sat Radio and wouldn't want to be without it for any length of time. period.
but because of this tech fringe area. I am left holding promises. Its BS and leaving a bad taste in my mouth. of course I could by Ford, some other Asian brands as well. and all the tech would most likely work, just work. so why is it so hard to expect my pricey German fine ass SAV not to just work. If it truly just updating a database, which is what the keep force feeding me, how flipping hard is it update it? really??

Quote:
Originally Posted by sfiermon View Post
Really? It's a tech option with a car. The 2014 models JUST came out and really the rest of the model lineup isn't until July. No offense here and I consider this a misstep from BMW...but did you buy the car to send google addresses to it or did you buy it because it drives awesome? If you bought based on tech alone, Ford has some nice tech in their cars these days.

The FTC or lawyer would laugh you out of their offices or just dismiss this as nonsense IMO. Don't waste your time as precious as it is with frivolity like this. BMW is addressing it...they know about it...they will fix it. If it takes until July, then that isn't the END OF THE WORLD is it? If you are concerned about anything monetarily, work something out with the dealer...BMW won't compensate or if they will...perhaps get something like extended maintenance or something.
__________________
2014 BMW X3 35i M Sport Carbon Black, Nevada Chestnut, Wave Wood. Driver Assistance, Premium, Technology, M Sport, Dynamic Handling, Premium Sound and Heated Front Seats.
Reply With Quote
  #65  
Old 05-17-2013, 03:26 PM
Jimsan Jimsan is offline
Registered User
Location: Somers, NY
 
Join Date: Mar 2013
Posts: 71
Mein Auto: X3
So I tried it this morning as they asked me to. Still no services work. This time the emergency button didn't work. I got a "call may be monitored for training purposes" and then silence. The screen eventually timed out. I called by cell and they said the would write up a ticket for the tech people to address.
Reply With Quote
  #66  
Old 05-17-2013, 06:42 PM
Drewsky's Avatar
Drewsky Drewsky is offline
Officially Welcomed to the 'Fest
Location: Tampa, FL
 
Join Date: Mar 2002
Posts: 331
Mein Auto: '14 X3 35i-M Space Grey
So am I the only one out of all of the '14 owners that all BMW services ARE working for??
Reply With Quote
  #67  
Old 05-17-2013, 08:13 PM
ironfan ironfan is offline
Officially Welcomed to the 'Fest
Location: CA
 
Join Date: Jan 2013
Posts: 174
Mein Auto: X3 28i
Does BMW Assist working in '14s??

Nope, mine works too


Sent from BimmerApp mobile app
__________________
2014 X3 28i - Deep Sea Blue Metallic - Black 'Nevada' Leather - Brushed Aluminum - Cold Weather - Driver Assistance with Top View - Lighting - Premium - Technology - Satin Aluminum Roof rails - Rear manual side window shades
Reply With Quote
  #68  
Old 05-18-2013, 09:29 AM
Toast. Toast. is offline
Registered User
Location: Cali
 
Join Date: Oct 2006
Posts: 70
Mein Auto: X3m, B8 Avant
Quote:
Originally Posted by Drewsky View Post
So am I the only one out of all of the '14 owners that all BMW services ARE working for??
On my '14 I get "Sorry, we were unable to send this message at this time. Please visit the help page."
Reply With Quote
  #69  
Old 05-18-2013, 09:52 AM
Jimsan Jimsan is offline
Registered User
Location: Somers, NY
 
Join Date: Mar 2013
Posts: 71
Mein Auto: X3
What was disturbing to me was that not only was the button not working but they couldn't locate the car. I guess in an emergency I could send them a map from my phone.

It will be nice I'm sure when they get it working.
Reply With Quote
  #70  
Old 05-18-2013, 11:26 AM
roadkillrob roadkillrob is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Aug 2006
Posts: 2,438
Mein Auto: 325CIC, 335CIC
Everything on my works except internet, can send from google maps, connect to bmw assist, all the apps work, weather, sports news etc, I have tested every function and the only thing that does not work is the internet browser on mine. I called them today about it and they said the browser function is an issue on all 2014's and won't be working until 2nd half of 2014, no better date than that.
__________________
2008 335i Vert Montego/Saddle/Grey Poplar
2014 X3 35i Space Grey/Chestnut/Fineline Wave
Reply With Quote
  #71  
Old 05-18-2013, 01:23 PM
ironfan ironfan is offline
Officially Welcomed to the 'Fest
Location: CA
 
Join Date: Jan 2013
Posts: 174
Mein Auto: X3 28i
Quote:
Originally Posted by roadkillrob View Post
Everything on my works except internet, can send from google maps, connect to bmw assist, all the apps work, weather, sports news etc, I have tested every function and the only thing that does not work is the internet browser on mine. I called them today about it and they said the browser function is an issue on all 2014's and won't be working until 2nd half of 2014, no better date than that.
yeh, when I said mine worked I forgot about the internet browser not working.
__________________
2014 X3 28i - Deep Sea Blue Metallic - Black 'Nevada' Leather - Brushed Aluminum - Cold Weather - Driver Assistance with Top View - Lighting - Premium - Technology - Satin Aluminum Roof rails - Rear manual side window shades
Reply With Quote
  #72  
Old 05-18-2013, 05:16 PM
Drewsky's Avatar
Drewsky Drewsky is offline
Officially Welcomed to the 'Fest
Location: Tampa, FL
 
Join Date: Mar 2002
Posts: 331
Mein Auto: '14 X3 35i-M Space Grey
Quote:
Originally Posted by roadkillrob View Post
Everything on my works except internet, can send from google maps, connect to bmw assist, all the apps work, weather, sports news etc, I have tested every function and the only thing that does not work is the internet browser on mine. I called them today about it and they said the browser function is an issue on all 2014's and won't be working until 2nd half of 2014, no better date than that.

That is SO weird, beccause mine works just fine. Has since May. That said, I would love to be able to modify the coding so the passenger can access the browser while I'm moving, OR (better still), make it a Wifi hotspot inside the vehicle. Alas, can't find the coding settings to make them work though.
Attached Thumbnails
Click image for larger version

Name:	2013-05-01 12.14.00.jpg
Views:	50
Size:	58.5 KB
ID:	377219  

Last edited by Drewsky; 05-18-2013 at 05:18 PM.
Reply With Quote
  #73  
Old 05-19-2013, 09:01 AM
Jimsan Jimsan is offline
Registered User
Location: Somers, NY
 
Join Date: Mar 2013
Posts: 71
Mein Auto: X3
Hooray! I received through MyInfo my first google map location sent from the Remote iPhone app. The Roadside app seems to be working also. But none of the services are selectable yet, all in blue. Some progress.
Reply With Quote
  #74  
Old 05-19-2013, 09:02 AM
haodang haodang is offline
Registered User
Location: Seattle, WA
 
Join Date: Mar 2013
Posts: 77
Mein Auto: NA
I took delivery of my car this past Wednesday. I pressed SOS and set up my email and passcode over the SOS connection. However, my BMW assist does not work: I cannot log into BMW assist through the "my bmw remote" app. It always said "authentication failed".

When I was trying to use Internet and it said "this vehicle not activated for internet, check contract status" (I forgot the exact words, something like this).

Does anybody else have the same experience? What should I do? Any suggestions? Thanks a lot!
Reply With Quote
  #75  
Old 05-19-2013, 06:06 PM
Drewsky's Avatar
Drewsky Drewsky is offline
Officially Welcomed to the 'Fest
Location: Tampa, FL
 
Join Date: Mar 2002
Posts: 331
Mein Auto: '14 X3 35i-M Space Grey
Quote:
Originally Posted by haodang View Post
I took delivery of my car this past Wednesday. I pressed SOS and set up my email and passcode over the SOS connection. However, my BMW assist does not work: I cannot log into BMW assist through the "my bmw remote" app. It always said "authentication failed".

When I was trying to use Internet and it said "this vehicle not activated for internet, check contract status" (I forgot the exact words, something like this).

Does anybody else have the same experience? What should I do? Any suggestions? Thanks a lot!
I did an update to bmw assist from the vehicle and everything magically started working. You can try this to see if it helps you:

ConnectedDrive --> Status --> Update
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 F25 (2011 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms