Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 03-18-2010, 11:35 AM
micliu micliu is offline
Registered User
Location: Minnesota
 
Join Date: Mar 2010
Posts: 2
Mein Auto: 04 X5, 08 A4, 06 GSXR 600
X5 Radio/Dash Buttons HELP!

So, recently my mom bought a used X5 and the radio buttons are all screwed up. All of the buttons seem to not do what they are labeled to do.

It's a 2004 X5 3.0i

Examples:

The button where it says AM or FM don't work, instead, change to a preset station, while buttons to the left or right change AM or FM instead.

Basically, if you press a bunch of buttons you eventually figure out that it works still, just none of the buttons are labeled correctly, as if the wires got crossed somewhere inside. Not really sure how this happened, Carfax gauranteed there's nothing wrong, but knowing Carfax it may not be true.

Should we be worried? Is this easily fixable?

We still have until tomorrow to return it with no questions asked.

Last edited by micliu; 03-18-2010 at 01:15 PM.
Reply With Quote
Advertisement
  #2  
Old 04-26-2013, 04:32 PM
RVWach RVWach is offline
Registered User
Location: Castle Rock, CO
 
Join Date: Apr 2013
Posts: 1
Mein Auto: 2002 BMW X5
I have the same problem with my 2002 X5 3.0i

I just bought a 2002 X5 and have the same issue with the radio buttons, including the fact that most of the station preset buttons have been working only intermittently.

Does anyone have an explanation or a fix for this?

I also have an AM issue--although clearly the tuner is receiving AM stations, I can't hear any of them. The FM is working fine. Do they have separate amplifiers?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms