Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 04-27-2013, 03:33 PM
iBeech iBeech is offline
Registered User
Location: Stoke
 
Join Date: Apr 2013
Posts: 30
Mein Auto: F20 116i
F20 BMW Live Success!

My car is an F20 M Sport with no extras except for tinted windows and extended dashboard display.

Managed to code up my car this morning to change BMW services to ConnectedDrive and enable BMW Live. I'm was able to connect via my iPhone, sign up, and use all the services successfully!





Only thing is sometimes when I leave the BMW live screen, if I go back I get a grey page. probably missed sone thing while coding. EDIT: after 24hr, this stopped happening, so probably needed a full reset.

I did not VO code the car for this feature. I specifically enabled a couple of features:

HU_ENTRY->3000 HMI->Funktionen->CONNECTED_DRIVE->aktiv
HU_ENTRY->3000 HMI->Funktionen->ONLINE_BROWSER_LIVE->aktiv

you may also need to enable these:
HU_ENTRY->3003 TELEFON_TELEMATIK_ONLINE, 50->Funktionen->DUN_PROFILE->aktiv
HU_ENTRY->3003 TELEFON_TELEMATIK_ONLINE, 50->Funktionen->PAN_PROFILE->aktiv

In order to use this feature, you need a mobile phone with bluetooth, and the ability to use its internet. For example, on my iPhone i must enable the 'Personal Hotspot' functionality in settings. If you cannot see this option, you likely need to pay your carrier for it.



Looking forward to more coding...
Attached Thumbnails
Click image for larger version

Name:	ImageUploadedByBimmerApp1367101833.996851.jpg
Views:	4498
Size:	54.5 KB
ID:	373367   Click image for larger version

Name:	ImageUploadedByBimmerApp1367101850.794377.jpg
Views:	4419
Size:	51.3 KB
ID:	373368   Click image for larger version

Name:	IMG_0001.PNG
Views:	4188
Size:	121.7 KB
ID:	373752  

Last edited by iBeech; 05-01-2013 at 03:08 AM.
Reply With Quote
Ads by Google
  #2  
Old 04-27-2013, 07:25 PM
theMpower theMpower is offline
Registered User
Location: Spain
 
Join Date: Feb 2013
Posts: 27
Mein Auto: F21 125d
To encode BMW Live I add "6AL" to the list FA and then codified HU_CIC module (or HU_ENTRY).
Reply With Quote
  #3  
Old 04-28-2013, 12:25 AM
iBeech iBeech is offline
Registered User
Location: Stoke
 
Join Date: Apr 2013
Posts: 30
Mein Auto: F20 116i
Quote:
Originally Posted by iBeech View Post
My car is an F20 M Sport with no extras except for tinted windows and extended dashboard display.

Managed to code up my car this morning to change BMW services to ConnectedDrive and enable BMW Live. I'm was able to connect via my iPhone, sign up, and use all the services successfully! Only thing is sometimes when I leave the BMW live screen, if I go back I get a grey page. probably missed sone thing while coding.

Looking forward to more coding... Will post the exact mods I did tomorrow

Attachment 373367
Attachment 373368


Sent from BimmerApp mobile app
Quote:
Originally Posted by theMpower View Post
To encode BMW Live I add "6AL" to the list FA and then codified HU_CIC module (or HU_ENTRY).
What does adding 6AL to the fa list add? I didn't do this?
Reply With Quote
  #4  
Old 04-28-2013, 01:11 AM
iBeech iBeech is offline
Registered User
Location: Stoke
 
Join Date: Apr 2013
Posts: 30
Mein Auto: F20 116i
F20 BMW Live Success!

Also, how do I add Vo codes?


Sent from BimmerApp mobile app
Reply With Quote
  #5  
Old 04-28-2013, 01:34 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,705
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by iBeech View Post
What does adding 6AL to the fa list add? I didn't do this?
6AL Is the Option Code for BMW Live. Adding it to the VO and VO Coding the Head Unit, and Combox if equipped with one, will make all the required FDL Code changes automatically.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #6  
Old 04-28-2013, 01:34 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,705
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by iBeech View Post
Also, how do I add Vo codes?


Sent from BimmerApp mobile app
http://www.bimmerfest.com/forums/att...6&d=1338725691
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #7  
Old 04-28-2013, 03:01 AM
iBeech iBeech is offline
Registered User
Location: Stoke
 
Join Date: Apr 2013
Posts: 30
Mein Auto: F20 116i
F20 BMW Live Success!

I've now read the tutorial and tried the Vo coding. However this makes my ConnectedDrive say BMW Services. So I removed the code and coded manually

I've now got 'Internet' but when loading it it just says loading, and never does anything. However BMW live works fine...


Sent from BimmerApp mobile app

Last edited by iBeech; 04-28-2013 at 10:51 AM.
Reply With Quote
  #8  
Old 04-28-2013, 05:02 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,705
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by iBeech View Post
I've now read the tutorial and tried the Vo coding. However this makes my ConnectedDrive say BMW Services. So I removed the code and coded manually

I've now got 'Internet' but when loading it it just says loading, and never does anything. However BMW love works fine...


Sent from BimmerApp mobile app
I never get any BMW Love...
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #9  
Old 04-28-2013, 10:51 AM
iBeech iBeech is offline
Registered User
Location: Stoke
 
Join Date: Apr 2013
Posts: 30
Mein Auto: F20 116i
Quote:
Originally Posted by shawnsheridan View Post
I never get any BMW Love...
hahaha
Reply With Quote
  #10  
Old 04-29-2013, 01:41 AM
resaran resaran is offline
Registered User
Location: turkey
 
Join Date: Jan 2013
Posts: 33
Mein Auto: bmw f30
Quote:
Originally Posted by iBeech View Post
I've now read the tutorial and tried the Vo coding. However this makes my ConnectedDrive say BMW Services. So I removed the code and coded manually

I've now got 'Internet' but when loading it it just says loading, and never does anything. However BMW live works fine...


Sent from BimmerApp mobile app

Hi,

Can you explain how did you code bmw live because i want to code it too.
Reply With Quote
  #11  
Old 04-29-2013, 02:53 AM
iBeech iBeech is offline
Registered User
Location: Stoke
 
Join Date: Apr 2013
Posts: 30
Mein Auto: F20 116i
Quote:
Originally Posted by resaran View Post
Hi,

Can you explain how did you code bmw live because i want to code it too.
I have edited the main article with what i coded, and some tips
Reply With Quote
  #12  
Old 04-29-2013, 08:09 AM
kon kon is offline
Registered User
Location: Singapore
 
Join Date: Jan 2013
Posts: 64
Mein Auto: BMW
"Connected Drive" menu is part of 6NR BMW Apps, having that menu says bmw services or connected drive doesn't affect the functionality. Fdl or VO code is individual preference, but VO code feature tends to stay even when the dealer reprogram the car, so you have less to restore if reprogramming happen at dealer... But this doesn't means it does not have its own downside
Reply With Quote
  #13  
Old 04-29-2013, 10:49 AM
iBeech iBeech is offline
Registered User
Location: Stoke
 
Join Date: Apr 2013
Posts: 30
Mein Auto: F20 116i
F20 BMW Live Success!

Dealer updated Is a great advantage to VO coding...

Thanks!


Sent from BimmerApp mobile app
Reply With Quote
  #14  
Old 04-30-2013, 09:19 AM
vithy vithy is offline
Registered User
Location: Toronto
 
Join Date: Apr 2013
Posts: 79
Mein Auto: F30 320i
iBeech, Do you have a combox in your car?
Reply With Quote
  #15  
Old 04-30-2013, 09:20 AM
iBeech iBeech is offline
Registered User
Location: Stoke
 
Join Date: Apr 2013
Posts: 30
Mein Auto: F20 116i
F20 BMW Live Success!

I do not


Sent from BimmerApp mobile app
Reply With Quote
  #16  
Old 04-30-2013, 09:22 AM
vithy vithy is offline
Registered User
Location: Toronto
 
Join Date: Apr 2013
Posts: 79
Mein Auto: F30 320i
Thanks, I'm going to go try this on mine now. Did you have to enable PAN or DUN on your iDrive?
Reply With Quote
  #17  
Old 04-30-2013, 09:23 AM
iBeech iBeech is offline
Registered User
Location: Stoke
 
Join Date: Apr 2013
Posts: 30
Mein Auto: F20 116i
F20 BMW Live Success!

Nope. Just make sure your phone can share the Internet


Sent from BimmerApp mobile app
Reply With Quote
  #18  
Old 04-30-2013, 09:23 AM
iBeech iBeech is offline
Registered User
Location: Stoke
 
Join Date: Apr 2013
Posts: 30
Mein Auto: F20 116i
F20 BMW Live Success!

It's annoying that after spending 25k, an option like this is simply disabled.


Sent from BimmerApp mobile app

Last edited by iBeech; 05-01-2013 at 03:03 AM.
Reply With Quote
  #19  
Old 04-30-2013, 09:24 AM
vithy vithy is offline
Registered User
Location: Toronto
 
Join Date: Apr 2013
Posts: 79
Mein Auto: F30 320i
Thanks, Agreed!!!
Reply With Quote
  #20  
Old 04-30-2013, 09:44 AM
vithy vithy is offline
Registered User
Location: Toronto
 
Join Date: Apr 2013
Posts: 79
Mein Auto: F30 320i
I'm assuming this is not country specific correct?
Reply With Quote
  #21  
Old 04-30-2013, 10:17 AM
ad78 ad78 is offline
Registered User
Location: Rocky Hill
 
Join Date: Jan 2011
Posts: 25
Mein Auto: X5 50i 2011 (dec build)
i added 6AL but i cannot connect to bmw live "service not available. Please try again later"

also i have iphone 5 hotspot activated
Reply With Quote
  #22  
Old 04-30-2013, 10:35 PM
vithy vithy is offline
Registered User
Location: Toronto
 
Join Date: Apr 2013
Posts: 79
Mein Auto: F30 320i
It worked for me. I had to enable DUN and PAN on 3003 to get it to work. It took a good 15min for it to update the live services or to show up under available services. Since I'm in Canada i had to first switch my location to London, England and then changed it to Toronto, Canada. Initially it only showed News and weather, after changing location and back all services remained. Funny thing is my Corporate Blackberry isn't working, however my personal Android device worked without any issues while tethering. I didn't have to enable Hotspot, however had to enable Bluetooth tethering option.
Reply With Quote
  #23  
Old 05-01-2013, 12:28 AM
ad78 ad78 is offline
Registered User
Location: Rocky Hill
 
Join Date: Jan 2011
Posts: 25
Mein Auto: X5 50i 2011 (dec build)
How did you enable DUN and PAN?
Reply With Quote
  #24  
Old 05-01-2013, 03:07 AM
iBeech iBeech is offline
Registered User
Location: Stoke
 
Join Date: Apr 2013
Posts: 30
Mein Auto: F20 116i
Quote:
Originally Posted by ad78 View Post
How did you enable DUN and PAN?
looks like mine were already activated. Here you go

HU_ENTRY->3003 TELEFON_TELEMATIK_ONLINE, 50->Funktionen->DUN_PROFILE->aktiv
HU_ENTRY->3003 TELEFON_TELEMATIK_ONLINE, 50->Funktionen->PAN_PROFILE->aktiv
Reply With Quote
  #25  
Old 05-01-2013, 04:59 AM
ad78 ad78 is offline
Registered User
Location: Rocky Hill
 
Join Date: Jan 2011
Posts: 25
Mein Auto: X5 50i 2011 (dec build)
Quote:
Originally Posted by iBeech View Post
looks like mine were already activated. Here you go

HU_ENTRY->3003 TELEFON_TELEMATIK_ONLINE, 50->Funktionen->DUN_PROFILE->aktiv
HU_ENTRY->3003 TELEFON_TELEMATIK_ONLINE, 50->Funktionen->PAN_PROFILE->aktiv

looks like mine has a different structure. here i saw DUN and PAN profile and i put them into active. now im not seeing anything. looks like nothing changed??
Attached Thumbnails
Click image for larger version

Name:	Capture.PNG
Views:	381
Size:	11.8 KB
ID:	374105  
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms