Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 05-05-2013, 05:07 PM
javed13 javed13 is offline
Registered User
Location: Bronx, NY
 
Join Date: Jan 2012
Posts: 9
Mein Auto: 2002 bmw x5 4.4
AC Cold for 20 minutes then then becomes warm

Hi guys, my ac is cold for 20 minutes and then becomes warm. if i shut off the ac and turn it back on after couple minutes, it becomes cold. what could be the problem?
Reply With Quote
Advertisement
  #2  
Old 05-05-2013, 05:57 PM
upallnight upallnight is offline
Officially Welcomed to the 'Fest
Location: Crook County
 
Join Date: Nov 2012
Posts: 520
Mein Auto: BMW, Lotus, Porsche
When it is warm check to see if the compressor is running. Could be that you have a blockage in the system and the pressure is building up that the high side pressure cutout is kicking in, or the lowside is low and the lowside pressure cutout is kicking in. The only way to determine the problem is to connect a set of gauges to the system and find out what the pressure readings are.
Reply With Quote
  #3  
Old 05-06-2013, 02:13 AM
flyace20 flyace20 is offline
Yippikayaaaay
Location: Australia
 
Join Date: Mar 2013
Posts: 54
Mein Auto: 2002 X5 4.4
I read a post on this forum about driving the car on open road and the system freezing up and not cooling.
Go to this thread, maybe you have the same problem. http://www.bimmerfest.com/forums/sho...d.php?t=463910
__________________
'02 BMW X5 LOVE THAT CAR
Reply With Quote
  #4  
Old 05-06-2013, 03:09 AM
thehinch thehinch is offline
Registered User
Location: Sydney
 
Join Date: Nov 2012
Posts: 5
Mein Auto: 2003 E53 X5
Air conditioning control module located under the dashboard
Reply With Quote
  #5  
Old 05-10-2013, 09:16 AM
BMWReeFeR BMWReeFeR is offline
Registered User
Location: Oklahoma
 
Join Date: Apr 2013
Posts: 4
Mein Auto: E53 X5
AC Cold for 20 minutes then then becomes warm

Ever figure this one out ace?


Sent from BimmerApp mobile app
Reply With Quote
  #6  
Old 05-11-2013, 05:01 AM
flyace20 flyace20 is offline
Yippikayaaaay
Location: Australia
 
Join Date: Mar 2013
Posts: 54
Mein Auto: 2002 X5 4.4
Next time it happens to me on the freeway I will test the theory by shutting off the Ac and allowing it to defrost. Then turn back on again in a few minutes, if it blows cold after this then it may well be that its true, the line is freezing up somewhere.
__________________
'02 BMW X5 LOVE THAT CAR
Reply With Quote
  #7  
Old 06-09-2014, 06:56 PM
SC-Caniac SC-Caniac is offline
Registered User
Location: Mount Pleasant, SC
 
Join Date: May 2013
Posts: 17
Mein Auto: 2013 550i M Sport
This is exactly what happens to my X5 50. Crank the fan on high and it sounds like its blowing really hard but no air (or very little) is coming out of the dash vents. The air is warm and humid. Turn it off for 15-20 minutes and it'll thaw out and work fine.....until it freezes up again.
Reply With Quote
  #8  
Old 06-09-2014, 07:10 PM
upallnight upallnight is offline
Officially Welcomed to the 'Fest
Location: Crook County
 
Join Date: Nov 2012
Posts: 520
Mein Auto: BMW, Lotus, Porsche
Quote:
Originally Posted by SC-Caniac View Post
This is exactly what happens to my X5 50. Crank the fan on high and it sounds like its blowing really hard but no air (or very little) is coming out of the dash vents. The air is warm and humid. Turn it off for 15-20 minutes and it'll thaw out and work fine.....until it freezes up again.
Sounds like you are low on refrigerant.
Reply With Quote
  #9  
Old 06-13-2014, 09:07 AM
Kwalk Kwalk is offline
Girl X
Location: Texas
 
Join Date: Jun 2014
Posts: 18
Mein Auto: BMW X5 4.4
Has anyone found a fix to this? I have 03 x5 4.4i and am having the same problem. Air blows great highway, but after a while the front vents stop, but back still works just fine. No matter how I adjust the settings it will not come back on. After I get out for a few minutes when I start the car back up, it works again. What could it be?
Reply With Quote
  #10  
Old 06-13-2014, 11:55 AM
upallnight upallnight is offline
Officially Welcomed to the 'Fest
Location: Crook County
 
Join Date: Nov 2012
Posts: 520
Mein Auto: BMW, Lotus, Porsche
See the guy reply #8 just above your post #9
Reply With Quote
  #11  
Old 06-13-2014, 04:18 PM
Kwalk Kwalk is offline
Girl X
Location: Texas
 
Join Date: Jun 2014
Posts: 18
Mein Auto: BMW X5 4.4
Thanks!
Reply With Quote
  #12  
Old 06-20-2014, 05:30 AM
upallnight upallnight is offline
Officially Welcomed to the 'Fest
Location: Crook County
 
Join Date: Nov 2012
Posts: 520
Mein Auto: BMW, Lotus, Porsche
Quote:
Originally Posted by Kwalk View Post
Thanks!

You're welcome!!!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms