Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 F25 (2011 - current)

X3 F25 (2011 - current)
The latest X3 brings some added style and some new features to the BMW SUV family. Talk about the new F25 now!

Reply
 
Thread Tools Display Modes
  #1  
Old 05-06-2013, 08:41 AM
Finnsane Finnsane is offline
Registered User
Location: Portland
 
Join Date: May 2013
Posts: 24
Mein Auto: 2011 x3 3.5i
Unhappy Electrical gremlins in my new X3

I just purchased a 2011 X3 with less then 17,000 miles.
The thing is beautiful and with the dynamic sport package it drives like a dream.
I took her out on a 500 mile round trip for work and found some gremlins in my electrical system.
While driving at freeway speeds I received a notice that the cruise control had failed. It knocked me out of cruise control and I could not turn it back on with the steering wheel buttons. I then noticed that I no longer can any buttons working on the steering wheel. I also had no power in the left signal indicator and my business computer button would not change indicators in the instrument cluster. At the same time my air conditioning stopped working.
It has happened several times since my trip last week. Anyone out there experienced this before? I'm scheduling a service this week at the dealer under warranty but would sure like to know if anyone else has had similar problems.
Thanks,
F
Reply With Quote
Advertisement
  #2  
Old 05-06-2013, 08:59 AM
The X Men The X Men is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Mar 2012
Posts: 5,284
Mein Auto: 2015 535xi 2013 X3 35i
I assume you bought the car used, did you check the maintenace history of car before you bought it, it could have been a reoccuring problem. If not, I would ask your dealer nicely to show you the maintence history of your car.
Reply With Quote
  #3  
Old 05-06-2013, 09:35 AM
TN_SUP TN_SUP is offline
Registered User
Location: Chattanooga
 
Join Date: Mar 2012
Posts: 23
Mein Auto: 2011 X3 28
The dealer told me there are about 30 computers in the 2011 X3. My turn signals wouldn't cancel and they found a fault in a computer and had to replace it. Got the latest software too, car drives much better. I'd bet they need to replace a computer or two...
Reply With Quote
  #4  
Old 05-06-2013, 09:50 AM
Finnsane Finnsane is offline
Registered User
Location: Portland
 
Join Date: May 2013
Posts: 24
Mein Auto: 2011 x3 3.5i
Smile Records look good

Thanks or the replys.
The history looks good. I figured it was a CPU error.
I'll update once I'm out of service.
I'll post pics too!
Thanks
finnsane
Reply With Quote
  #5  
Old 05-13-2013, 09:02 AM
SpaceManGray SpaceManGray is offline
Registered User
Location: Wisconsin
 
Join Date: Aug 2012
Posts: 88
Mein Auto: 2011 X3 35i
Quote:
Originally Posted by Finnsane View Post
I figured it was a CPU error.
Most of the controls in your vehicle, including those on the steering wheel, send signals on a data bus to the various computers (ECUs - electronic control units) in your vehicle. These computers also send data on the bus to communicate with each other.

Since it sounds like you're having problems with MANY of these control units, my guess is the data on the bus is corrupt. I would guess the problem is one of the following:

1. A loose connection on the bus is causing one ECU to communicate incorrectly and interfere with other ECU communication
2. One ECU is bad and is sending bad data, causing problems with other ECUs
3. There is a source of interference affecting the data bus
__________________
2011 X3 (F25) xDrive 35i 3.0L, nav, xm
Reply With Quote
  #6  
Old 05-13-2013, 11:17 AM
Drewsky's Avatar
Drewsky Drewsky is offline
Officially Welcomed to the 'Fest
Location: Tampa, FL
 
Join Date: Mar 2002
Posts: 331
Mein Auto: '14 X3 35i-M Space Grey
Quote:
Originally Posted by Finnsane View Post
I just purchased a 2011 X3 with less then 17,000 miles.
The thing is beautiful and with the dynamic sport package it drives like a dream.
I took her out on a 500 mile round trip for work and found some gremlins in my electrical system.
While driving at freeway speeds I received a notice that the cruise control had failed. It knocked me out of cruise control and I could not turn it back on with the steering wheel buttons. I then noticed that I no longer can any buttons working on the steering wheel. I also had no power in the left signal indicator and my business computer button would not change indicators in the instrument cluster. At the same time my air conditioning stopped working.
It has happened several times since my trip last week. Anyone out there experienced this before? I'm scheduling a service this week at the dealer under warranty but would sure like to know if anyone else has had similar problems.
Thanks,
F
Back in my days of my e46, this exact situation was caused by the flexi cable between the (rotating) steering wheel and the (fixed) steering column. First the buttons on the wheel either quit entirely or act wonky, then blinkers (and/or wipers) quit, and eventually you will get an SRS light on the instrument cluster. Seems when that starts going bad it interferes with the data bus as others above have mentioned. My money is on that little flexi cable.
Reply With Quote
  #7  
Old 05-15-2013, 08:13 PM
Finnsane Finnsane is offline
Registered User
Location: Portland
 
Join Date: May 2013
Posts: 24
Mein Auto: 2011 x3 3.5i
I should have it back from the dealer tomorrow and will fill you in.
They are reprogramming it, also a software upgrade.
Reply With Quote
  #8  
Old 05-19-2013, 01:11 PM
Finnsane Finnsane is offline
Registered User
Location: Portland
 
Join Date: May 2013
Posts: 24
Mein Auto: 2011 x3 3.5i
Got my X3 back on Wednesday

I picked up my X3 from the dealer on Wednesday.
Needed the JPE central control unit replaced.
Dealer completed the following.
Replaced central control unit JBE replaced / vehicle reprogrammed.
Front door lock passenger side replaced. Was sitting about 1/2" higher then the rest of the lock indicators.
All new wipers.
New software upgrade (thanks to the board for providing the insight on turbo lag)
Full vehicle inspection.
All work completed under warranty.
Car electronics seem to be working correctly now.

My Vehicle Specs:
2011 X3 3.5i F25
16,000 miles
CPO
Space Grey Metallic
Black Nevada Leather interior with brushed aluminum trim
Sport Seats
Sport Activity Package
Premium Package
Heated Steering Wheel
Heated Front Seats
Professional Navigation
Smart Phone Integration
BMW Cross Rails

Some reflections as I approach 1 month of ownership.
The new X3 is beautiful. I love to look at it. The combination of Space Grey with the X line trim and silver roof rails is sharp.
The drive is incredible, very connected to the road and the 300hp twin turbo is quite a thrill to experience. I love getting on the freeway and opening up the motor.
I prefer to drive it in Sport Mode with only the chassis tuning active. I use the steptronic shifter to control the revs. The 8 gears take some getting used to as i explore the correct gearing when accelerating and slowing.
The Bluetooth integration is great for accessing my music collection. I love the programmable buttons, i have Bluetooth audio as a button and can call up the music player just as you would a radio stations. I don't mind the IDrive, i have learned how to access everything.
I wish they were offering the 6 speed manual. I traded in a 2005 X3 6 speed for this vehicle and I miss shifting. I see the export models with a 6 speed online and drool over them.
That is the only thing I would change on this vehicle.
Overall the experience of owning this car is a thrill and I look forward to driving it everyday.

Some customizing I'm contemplating:
De-badging
Changing the emblems to be the red propeller
Window Tint
Thule Cargo Box





Last edited by Finnsane; 05-20-2013 at 10:47 AM.
Reply With Quote
Reply

Bookmarks

Tags
2011 2012 x3, air conditioning, electrical failure, x3


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 F25 (2011 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms