Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-06-2013, 08:46 PM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
Coding my BMW X5 E70 - help me along the way.

I will not give you a full DIY answer upfront but I'll report on my personal experience as I go.

BOUGHT THE CABLE
First I ordered the cable that most forum member seem to like:
http://www.one-stop-electronics.com/...&product_id=16

INSTALLED BASE SOFTWARE
Then I got myself a benefactor who sent me the BMW Standard Tool V2.12
That particular software installs a couple of folders: EDIBIAS, NCSEXPERT, INPA. These 3 seems to be essentials for coding.
The BMW Standard tool is quit easy to install as it got a regular windows installer, just accept all default settings and you will be on your way.

1/ First hurdle for me, after the install I see on most tutorials that I need to run the file C:\Ediabas\hardware\OBD\OBDsetup.exe....too bad it was not installed for me (see attached image).
My folder C:\Ediabas\hardware\OBD doesn't contains any executables... can anybody help me out here understand if I really need to run this or not.

UPDATE BASE SOFTWARE WITH LATEST BMW DATEN FILES
After that I mounted the DATEN .iso file I received from another benefactor forum member And I use the BMW Coding Tool V2.5 (http://www.bmwcoding.com/showthread....MW-Coding-Tool) to update my EDIBIAS, NCSEXPERT, INPA folders with the latest DATEN (firmware kind of thing).

2/ At this stage I got another error, permission denied on c:\EC-APPS\NFS\DATA\GDATEN edit-->SGIDC.AS2 (see pic attached).

RUNNING SOME TEST
I tried to anyways runing the test describe in the NCS_DIY.pdf, which call for launching INPALOAD.exe. And without the cable plugged into the OBD port, I do have both circle battery and ignition blacked out... which I should have not...

3/ any idea on that problem ?

Then if I try to click on F6, I get another error message...

That is where I decided to call it a day... not easy to install these coding software


Any help pulling me further down the road will be appreciated







>>>>>>> ! warning !
>>>>>>> THESE STEPS ARE A WORK IN PROGRESS, I WILL UPDATE THIS POST ALONG THE WAY, AND GIVE CONFIRMATION ONCE I AM ABLE TO CODE SOMETHING...someday ...


PRELIMINARY:
! buy the cable
! find (torrent or forum angels) the BMW STANDARD TOOL V2.12 - this is supposed to work with Windows & 64 bits.
! find (torrent or forum angels) the daten for your vehicle, X5 E70 V49 as of 05/2013
! Note that I will be doing these steps on my MACBOOK PRO RETINA, using VMWARE and a Windows 7 ultimate SP1

HERE WE GO:
[REFERENCES]
============
-http://forums.bimmerforums.com/forum/showthread.php?1800496-Dummies-Guide-to-Basic-coding-with-NCS-Expert (most up to date)
-http://forums.*********.co.uk/showthread.php?t=33054 (screenshots but outdated)
BMW CODING TOOL (i used it to import the daten)
-> http://www.bmwcoding.com/showthread....MW-Coding-Tool
NCS DUMMY (i did not use that tool - more for professionals I think)
-> http://forums.bimmerforums.com/forum...-of-NCS-Expert


[INSTALLATION]
==============
! disable any antvirus you may have running to avoid errors

-plug the usb cale
-go to hardware/device list and check ports to get com port #
- install bmw tools V2.12
use all default options
select obd
select com port number as found before
select serial to usb
use all default options

- check your C:\EDIABAS\Bin\obd.ini file for proper com port number (must be same as the one showing in windows device manager / port, you will see only one will show as 'USB serial port')

- overwrite your ncsexpert.exe file to avoid to have to enter a password
- replace your C:\NCSEXPER\BIN and C:\NCSEXPER\CFGDAT
- replace your C:\NCSEXPER\BIN\ncsexpert.ini
- replace your C:\NCSEXPER\CFGDAT\inpa.ini this will allow to show the E70 in the list on ncs screen

- Copy NCSEXPER.exe from root of archive to c:\NCSEXPER\BIN\
- Unpack c_EC-APPS_INPA_CFGDAT.ZIP to c:\EC-APPS\INPA\CFGDAT\
- Unpack c_EC-APPS_INPA_SGDAT.ZIP to c:\EC-APPS\INPA\SGDAT\
- Copy Expertmode.pfl to c:\NCSEXPER\PFL\, this is your expert profile you need to load all the time you start NSC Expert.

- import/update automatically to the latest daten files using bmwcodingtools
how to use bmw coding tools
http://www.bmwcoding.com/showthread....MW-Coding-Tool

SELECT SP SOURCE => point to ISO file
SETUP DEFAULT FOLDERS
UPDATE SP DATEN + UPDATE WINKFP

- OR update maually daten files:
how to update:
http://www.bmwcoding.com/showwiki.ph...CSExpertentool
---
1.Download the Daten files (find a link) and extract as necessary.
2.Go to ECU folder and copy all files to /ediabas/ecu (replace your files with the newest files).
3.Go to sgdat folder and copy all files to /NCSEXPER/SGDAT (replace your files with the newest).
4.Go to daten folder and start laden.bat
5. kmmData folder goes in the root of /NCSEXPER/ -> /NCSEXPER/kmmData

If you don't have laden.bat file go to daten folder and copy all files with .000, .DAT , .ASC extensions to /NCSEXPER/DATEN.
And all other files copy to /NCSEXPER/DATEN/EXX (folder of your vehicle data).
---

[CODING - READ]
================
- Connect cable
- Launch NCSEXPER
[step one read and save the file you want to code]
- load default (read) profile
- F1
- F3
- select your model
- choose ecu (CAS)
- F6 (back)
- Process ECU (choose the module you want to code)
- F2 change job to 'CODIERDATEN_LESEN'
- execute job
- rename NCSexpert/WORK/FSW_PSW.TRC to NCSexpert/WORK/FSW_PSW.BAK (backup)
- copy NCSexpert/WORK/FSW_PSW.BAK to NCSexpert/WORK/FSW_PSW.MAN (file we will work on)
- open NCSexpert/WORK/FSW_PSW.MAN in your text editor like notepad
- make the change you need to the file - search the web to find what you need changed

example:
Double hazard blink modification
module: FRM(FRM3_E7X.C32)
change to be made:
DOPPELBLINKIMPULS_WARNBLK
Original - nicht_aktiv
Change to - aktiv


[CODING - WRITE]
================
- load the expert profile
- F1
- F3
- choose model
- choose ecu (CAS)
- F6 (back)
- process ECU (choose the !! SAME !! module you have read earlier)
- F2 change job to 'SG_Codieren'
- execute job
- wait for it.... if you dont' have error message you have made your first code




-
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2013-05-06 at 10.09.20 PM.png
Views:	268
Size:	68.1 KB
ID:	375159   Click image for larger version

Name:	Screen Shot 2013-05-06 at 11.47.28 PM.jpg
Views:	207
Size:	50.0 KB
ID:	375160   Click image for larger version

Name:	Screen Shot 2013-05-06 at 11.55.28 PM.jpg
Views:	234
Size:	81.4 KB
ID:	375166   Click image for larger version

Name:	Screen Shot 2013-05-06 at 11.55.18 PM.jpg
Views:	184
Size:	80.1 KB
ID:	375167  
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox

Last edited by philooo; 05-08-2013 at 10:07 AM.
Reply With Quote
Ads by Google
  #2  
Old 05-07-2013, 04:21 AM
blue dragon blue dragon is offline
Officially Welcomed to the 'Fest
Location: Pickering/Toronto
 
Join Date: Aug 2011
Posts: 693
Mein Auto: X5 35D
You will need to run obdsetup to tell the computer which port to use for the DCAN cable. After you get that working, you can check to see if there is communication with the car with INPA. You will see the two black dots flickering if you get it right. No point going any further without getting these working
__________________


| ZCW | ZPP | ZPS | ZRC | ZSP | ZTP | 322 | 2VA | 456 | 4AD | 4UB | 610 | 655 | 6FF | 6FL | Combox + CIC + LCI Headlight/Tailight retro |
Reply With Quote
  #3  
Old 05-07-2013, 04:42 AM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
any idea why the file obdsetup was not installed.
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox
Reply With Quote
  #4  
Old 05-07-2013, 07:10 AM
blue dragon blue dragon is offline
Officially Welcomed to the 'Fest
Location: Pickering/Toronto
 
Join Date: Aug 2011
Posts: 693
Mein Auto: X5 35D
^^ PM me an email address, I'll zip it and send it to you tonight.
__________________


| ZCW | ZPP | ZPS | ZRC | ZSP | ZTP | 322 | 2VA | 456 | 4AD | 4UB | 610 | 655 | 6FF | 6FL | Combox + CIC + LCI Headlight/Tailight retro |
Reply With Quote
  #5  
Old 05-07-2013, 11:30 AM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
ok I solved one of my problems where the NCS screenshot was always showing both circle black even when the cable was not connected.

after the cable is plugged and installed, you need to go into windows device manager and there you can see all the com port listed. Click to open the detail and only one will show as 'USB serial port'. That is the port number you need to use.

after intallation you can simply update the file C:\EDIABAS\Bin\obd.ini with the proper port number and you are now setup for the proper com port number.

I will update my first post with my step by step install as I go.
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2013-05-07 at 2.29.41 PM.jpg
Views:	129
Size:	72.8 KB
ID:	375251  
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox

Last edited by philooo; 05-07-2013 at 11:38 AM.
Reply With Quote
  #6  
Old 05-07-2013, 12:17 PM
Toneaero Toneaero is offline
Officially Welcomed to the 'Fest
Location: Minnesota
 
Join Date: Apr 2013
Posts: 105
Mein Auto: 2008 Harley FXCWC
Subscribed.....absorbing large amounts of info.....
Reply With Quote
  #7  
Old 05-08-2013, 05:25 AM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
My good samaritan updated me with the files I needed.

I was missing more files.
c_EC-APPS_INPA_CFGDAT.ZIP which need to be unzipped in c:\EC-APPS\INPA\CFGDAT\
c_EC-APPS_INPA_SGDAT.ZIP which need to be unzipped in c:\EC-APPS\INPA\SGDAT\

I have attached a file to this post listing all the folders and files I currently have installed for BMW Tools to work.

This show the Daten V49 installed and updated with Daten V49.1

PS: keep in mind I have still NOT programmed anything so this is work in progress but I think I am close
Attached Files
File Type: pdf bmwtools-file-folders.pdf (93.8 KB, 689 views)
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox

Last edited by philooo; 05-08-2013 at 12:36 PM.
Reply With Quote
  #8  
Old 05-08-2013, 10:10 AM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
thanks to all my benefactors... I have finally coded my car !!!

arghhh the hardest was/is the get the proper files, they are really hard to get on the web and without philanthropic Bimmerfest members I could not have done it. You know who you are

I have updated my first post above to list the steps I have followed. I also listed two very good forum threads about the subject.

I still have some trouble as I can't read the CIC module (see error attached).
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2013-05-08 at 11.07.19 AM.jpg
Views:	137
Size:	69.7 KB
ID:	375420  
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox
Reply With Quote
  #9  
Old 05-08-2013, 10:13 AM
blue dragon blue dragon is offline
Officially Welcomed to the 'Fest
Location: Pickering/Toronto
 
Join Date: Aug 2011
Posts: 693
Mein Auto: X5 35D
^^ Create a blank text file named FSW_PSW.MAN in your work directory. If that file is not there, and you are not in expert profile, NCS will check for that file.
__________________


| ZCW | ZPP | ZPS | ZRC | ZSP | ZTP | 322 | 2VA | 456 | 4AD | 4UB | 610 | 655 | 6FF | 6FL | Combox + CIC + LCI Headlight/Tailight retro |
Reply With Quote
  #10  
Old 05-08-2013, 10:16 AM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
I have gone around that issue by reading using the default profile -> which in turn create the FSW_PSW.MAN

Then when it is time to write using the expext profile I have the file there.

I was just scared to have the coding file in there empty and risking to overwrite my car with an empty file and loose all my coding ... newbie paranoia


but may be you think this is what create my error above... humm I'll try that and do the reading with the expert profile then
My reading under the default profile worked for coding the euro blink and tailgate close but it might be different based on the modules

oh exciting !
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox

Last edited by philooo; 05-08-2013 at 10:17 AM.
Reply With Quote
  #11  
Old 05-08-2013, 11:31 AM
vetaldj vetaldj is offline
Officially Welcomed to the 'Fest
Location: Orange Co
 
Join Date: Feb 2011
Posts: 288
Mein Auto: 2010 X5 35d
That error is always exists when you do it first time unless you create it manually so no worry.

It is not that simple to write it back empty (you need to follow severals "press this choose that" route) but I was scary as hell when I did it first time as well
__________________
2010 X5 35d Monaco Blue/Saddle Brown with Premium/Technology/Sport/Climat, 62K
SOLD - 1997 BMW 528i Silver, 116.5K

BMWCCA Member # 447308
Reply With Quote
  #12  
Old 05-08-2013, 12:10 PM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
oh i got another error this time .... trying to read the CIC module

'Datatransmission to ECU disturbed...'

it only happen to me with the CIC module. I tried with engine running or engine not running, same error.

any input on that one ?
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2013-05-08 at 12.43.02 PM.jpg
Views:	92
Size:	70.3 KB
ID:	375447  
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox
Reply With Quote
  #13  
Old 05-08-2013, 12:13 PM
blue dragon blue dragon is offline
Officially Welcomed to the 'Fest
Location: Pickering/Toronto
 
Join Date: Aug 2011
Posts: 693
Mein Auto: X5 35D
Did you set the latency on the com port to 1
__________________


| ZCW | ZPP | ZPS | ZRC | ZSP | ZTP | 322 | 2VA | 456 | 4AD | 4UB | 610 | 655 | 6FF | 6FL | Combox + CIC + LCI Headlight/Tailight retro |
Reply With Quote
  #14  
Old 05-08-2013, 12:14 PM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
humm I think I lowered it to 8 instead of 16.... but 1 it is I'll report back
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox
Reply With Quote
  #15  
Old 05-08-2013, 12:16 PM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
I still dont have the obdconfig.exe so I set up my port manually
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox
Reply With Quote
  #16  
Old 05-08-2013, 02:25 PM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
scare time ....

holly molly, I was working on the window close and mirro close with keyfob

First step with FRM went fine:
(FRM)
ASP_KOMFORT_EINKLAPP
Original - nicht_aktiv
Change - aktiv

Second step... humm no so good.
As soon as I executed the job with the CAS modified file:
(CAS)
KOMFORTSCHLIESSUNG_FB
Original - nicht_aktiv
Change - aktiv

I got the big ass warning on the dashboard !!! arghh

Lucky I had made a backup and put the old file back in, message is gone but I did not get the balls to try it again

Only thing I can see is that I had forgotten to put the keyfob in the dash slot. engine was runnning (comfort access)... Do you think keyfob missing might have created the problem ?
Attached Thumbnails
Click image for larger version

Name:	2013-05-08 16.38.17.jpg
Views:	223
Size:	124.6 KB
ID:	375478   Click image for larger version

Name:	2013-05-08 16.38.21.jpg
Views:	182
Size:	133.8 KB
ID:	375479  
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox
Reply With Quote
  #17  
Old 05-08-2013, 03:43 PM
vetaldj vetaldj is offline
Officially Welcomed to the 'Fest
Location: Orange Co
 
Join Date: Feb 2011
Posts: 288
Mein Auto: 2010 X5 35d
Hard to say, everywhere it says you need to have fob in engine off... Try that. Just make sure that you acidently did not change something else...
__________________
2010 X5 35d Monaco Blue/Saddle Brown with Premium/Technology/Sport/Climat, 62K
SOLD - 1997 BMW 528i Silver, 116.5K

BMWCCA Member # 447308
Reply With Quote
  #18  
Old 05-08-2013, 05:05 PM
blue dragon blue dragon is offline
Officially Welcomed to the 'Fest
Location: Pickering/Toronto
 
Join Date: Aug 2011
Posts: 693
Mein Auto: X5 35D
you can code with the engine off. Some modules will require the iginition to be on (but with the engine still off).
__________________


| ZCW | ZPP | ZPS | ZRC | ZSP | ZTP | 322 | 2VA | 456 | 4AD | 4UB | 610 | 655 | 6FF | 6FL | Combox + CIC + LCI Headlight/Tailight retro |
Reply With Quote
  #19  
Old 05-08-2013, 06:13 PM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
I have .. I think a full backup that i made before doing any coding. It is FSW_PSW.TRC which is 169Ko and 11940 lines.
I saved that file from C:\NCSEXPER\WORK as soon as I saw it created. That was right after the few steps F1 -> F3 -> model and ecu selection -> Back

I was under the impression that this file contained all module... Am I right ?

I wonder because I just did created a new file C:\NCSEXPER\WORK\FSW_PSW.TRC at the end of the day (after my 4x4 warning), and to my surprise I do NOT see my coding in it.
For example I know I have DOPPELBLINKIMPULS_WARNBLK = aktiv as I see that I still have the double blink on hazard button...

Is that big FSW_PSW.TRC really reflect all module as they are in the car OR does is simply always show the "default setting" based on the VIN# only ?

If it shows only the default setting how can I export all module as they are on the live ECU, so that I can compare and see if I changed something by mistake
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox
Reply With Quote
  #20  
Old 05-08-2013, 06:55 PM
vetaldj vetaldj is offline
Officially Welcomed to the 'Fest
Location: Orange Co
 
Join Date: Feb 2011
Posts: 288
Mein Auto: 2010 X5 35d
Quote:
Originally Posted by philooo View Post
I have .. I think a full backup that i made before doing any coding. It is FSW_PSW.TRC which is 169Ko and 11940 lines.
I saved that file from C:\NCSEXPER\WORK as soon as I saw it created. That was right after the few steps F1 -> F3 -> model and ecu selection -> Back

I was under the impression that this file contained all module... Am I right ?

I wonder because I just did created a new file C:\NCSEXPER\WORK\FSW_PSW.TRC at the end of the day (after my 4x4 warning), and to my surprise I do NOT see my coding in it.
For example I know I have DOPPELBLINKIMPULS_WARNBLK = aktiv as I see that I still have the double blink on hazard button...

Is that big FSW_PSW.TRC really reflect all module as they are in the car OR does is simply always show the "default setting" based on the VIN# only ?

If it shows only the default setting how can I export all module as they are on the live ECU, so that I can compare and see if I changed something by mistake
Yes, initial file 169K that you saved is all modules.
You said that as soon as you've got those errors you did restore all from back up, so you actually overwrite all codings, no? That is why you don't see coding...

After you did Write all your changes back it should stay there and after next full read it should be in that big trc file.
How I do it: got main back up (initial trc). Then, after reading module I do back up for that module (by saving trc file I just got from reading it), then I modify all that I need, compare this file to initial trc (backup) to make sure that MAN contains just my desired changes and then I perform write.
So far it works for me...

For now, I would leave it for a day and tried on fresh head tomorrow, you will see that all today's problem are gone! You already did alot so cheer up and have some rest!
__________________
2010 X5 35d Monaco Blue/Saddle Brown with Premium/Technology/Sport/Climat, 62K
SOLD - 1997 BMW 528i Silver, 116.5K

BMWCCA Member # 447308

Last edited by vetaldj; 05-08-2013 at 07:01 PM.
Reply With Quote
  #21  
Old 05-08-2013, 07:38 PM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
that would make sense, except that I did not revert ALL back to the initial backup.

I was doing backups of each .TRC module file before processing them as .MAN file.

When I saw the error I only put back the last module I had changed... I still have the double blinker active or the close trunk from remote active.

But I think you are right about calling it a day. I'll see clearer tomorrow morning.
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox
Reply With Quote
  #22  
Old 05-09-2013, 04:47 PM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
Ok so I tried again the coding of the closing of windows and mirror on key fog -> success

this time I made sure I had the keyfob inserted in the dash and all went well, no problem

CAS module ->
KOMFORTSCHLIESSUNG_FB
Original - nicht_aktiv
Change - aktiv

I coded a bunch more stuff

-Digital speed on BC stalk
-Lateral force on BC stalk
-auto eject fob on hold start/stop


Still one question... when I do the first step F1 -> F3 -> Back and that the initial FSW_PSW.TRC is created, that file does NOT show the modification I have done.

If I read the module INDIVIDUALLY they show the coding I have done.

How do you guy read all the car in one big file ? I know it is supposed to be the F1 -> F3 -> Back button steps but it doesn't work for me.
What profile are you using ?

Again thanks to all my benefactors ! could not have done it without you all. I'll try to make a little video of the whole thing to give back to the bimmerfest community !
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox
Reply With Quote
  #23  
Old 05-09-2013, 04:50 PM
vetaldj vetaldj is offline
Officially Welcomed to the 'Fest
Location: Orange Co
 
Join Date: Feb 2011
Posts: 288
Mein Auto: 2010 X5 35d
Hmm, that is interesting question... I will try to read tomorrow morning. I think I have all changes returned but I need to try one more time to be sure...

Glad you were able to do that! This is very confusing process but as soon as you done something it becomes easier.
__________________
2010 X5 35d Monaco Blue/Saddle Brown with Premium/Technology/Sport/Climat, 62K
SOLD - 1997 BMW 528i Silver, 116.5K

BMWCCA Member # 447308
Reply With Quote
  #24  
Old 05-09-2013, 05:07 PM
philooo philooo is offline
Officially Welcomed to the 'Fest
Location: Ft-Lauderdale
 
Join Date: Apr 2012
Posts: 274
Mein Auto: 2011 X5 5.0
yeah Vetal,

make sure you get the full file with your mods so that when you install the hitch you can really compare the right files.

Phil
__________________
'11 X5 50i M-Sport
19" Black Saphire | Black | Alu | Lux Seat | Adaptive | Cold | Tech | Sound | Prem | Comf Acces | no combox
Reply With Quote
  #25  
Old 05-10-2013, 03:58 AM
vetaldj vetaldj is offline
Officially Welcomed to the 'Fest
Location: Orange Co
 
Join Date: Feb 2011
Posts: 288
Mein Auto: 2010 X5 35d
Ok, did it today and must agree that philooo is right - after initial read of car trc file doesn't contain any changes in compare to initial file I created when I started coding except that 3 lines were added at the end...

This mean that my task will be little bit more time consuming (read car before and after hitch programmed) since looks like I need to read each and any module to be sure... Oh well, will do it anyway but it will be much more eaiser afterwards as you guys will know which specific module was affected.

Looks like I will start reading this weekend as I don't plan to code anything anyway soon.

Will report back next week.
__________________
2010 X5 35d Monaco Blue/Saddle Brown with Premium/Technology/Sport/Climat, 62K
SOLD - 1997 BMW 528i Silver, 116.5K

BMWCCA Member # 447308
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms