Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 05-11-2013, 07:33 AM
maxwell d maxwell d is offline
Registered User
Location: NC
 
Join Date: May 2013
Posts: 5
Mein Auto: 2008 BMW 335i coupe
Engine Malfunction Light on after giving it some.

My 08 335i coupe keeps having the engine malfunction light and reduced power message coming on if I try to accelerate quickly. This has only occurred recently. I have had the car for over 2years and it has always performed admirably, acceleration is great. before I take it into the dealer I was hoping someone may have some suggestions or similar experience to arm me in case of Dealer BS. I am presuming its a Turbo issue? Just wondering what level of severity it might be. I have a non-BMW Comprehensive warranty, and hope anything major is covered if BMW don't cover it. Car has done just over 50K. Any suggestions will be appreciated. i want my overtaking demon back at full fitness. Just love this car and take great pleasure in showing all the "young pretenders" in the lexus's and infinitis' which car sets the standard.
Reply With Quote
Ads by Google
  #2  
Old 05-11-2013, 07:47 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,009
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by maxwell d View Post
My 08 335i coupe keeps having the engine malfunction light and reduced power message coming on if I try to accelerate quickly. This has only occurred recently. I have had the car for over 2years and it has always performed admirably, acceleration is great. before I take it into the dealer I was hoping someone may have some suggestions or similar experience to arm me in case of Dealer BS. I am presuming its a Turbo issue? Just wondering what level of severity it might be. I have a non-BMW Comprehensive warranty, and hope anything major is covered if BMW don't cover it. Car has done just over 50K. Any suggestions will be appreciated. i want my overtaking demon back at full fitness. Just love this car and take great pleasure in showing all the "young pretenders" in the lexus's and infinitis' which car sets the standard.

Mileage?

To have an idea what's happening, read codes. You'll want a code reader capable of BMW codes, not generic a la Autozone.

Many possibilities. Without a readout, diff to say.
Reply With Quote
  #3  
Old 05-11-2013, 07:50 AM
maxwell d maxwell d is offline
Registered User
Location: NC
 
Join Date: May 2013
Posts: 5
Mein Auto: 2008 BMW 335i coupe
thx i will look into that
Reply With Quote
  #4  
Old 05-11-2013, 08:03 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,009
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by maxwell d View Post
thx i will look into that
Wait - mileage?
Reply With Quote
  #5  
Old 05-11-2013, 08:07 AM
maxwell d maxwell d is offline
Registered User
Location: NC
 
Join Date: May 2013
Posts: 5
Mein Auto: 2008 BMW 335i coupe
about 52K
Reply With Quote
  #6  
Old 05-11-2013, 08:20 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,009
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by maxwell d View Post
about 52K

You're due for blastin' soon - maybe now.

DIY here.

Dealer $600 and up. Indy variably less. DIY priceless.

.

Last edited by CALWATERBOY; 05-11-2013 at 08:23 AM.
Reply With Quote
  #7  
Old 05-11-2013, 08:34 AM
maxwell d maxwell d is offline
Registered User
Location: NC
 
Join Date: May 2013
Posts: 5
Mein Auto: 2008 BMW 335i coupe
thanks for the info, I'm a driver not a fixer unfortunately, I'll look into reputable local independents, before i head to the local dealer and do the usual take out my wallet and watch them empty it!
thanks again.
one thing could a batch of bad Gas have caused this? recently filled up with local supermarket high octane, wondered if that might be issue?
Reply With Quote
  #8  
Old 05-12-2013, 06:33 AM
TXFred TXFred is offline
Officially Welcomed to the 'Fest
Location: Austin, TX
 
Join Date: Apr 2012
Posts: 236
Mein Auto: 2008 335i Convertible
I wouldn't worry about the fuel. I use supermarket fuel all the time. Gas is gas, no matter what "power booster additive" they try to claim they have in their fuel.

In addition to the bead blasting, look into cleaning your VANOS solenoids. That's not a complicated job, so if you want to learn to wrench, it's a good place to start. When my solenoids got dirty and began sticking, the car would go into limp home mode after a high power run, same as what you're describing.

Frederic
__________________
Any idiot can be fast in a straight line. The corners are what separates the drivers from the commuters.

Powered by corn.
Reply With Quote
  #9  
Old 05-23-2013, 05:39 PM
dannyvd1 dannyvd1 is offline
Registered User
Location: Chicago
 
Join Date: May 2013
Posts: 4
Mein Auto: 2008 535i
My 2008 535i has been getting the reduced engine power light for about a month. BMW diagnosed 2 bad vacum solenoid switches. Will be ready tomorrow. Hope this fixes the problem.
Reply With Quote
  #10  
Old 05-23-2013, 06:39 PM
ptrcd003 ptrcd003 is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Dec 2008
Posts: 553
Mein Auto: 328i LCI
Quote:
Originally Posted by CALWATERBOY View Post
Mileage?
You realize he put the mileage in the original post, right?
Reply With Quote
  #11  
Old 05-25-2013, 06:10 AM
maxwell d maxwell d is offline
Registered User
Location: NC
 
Join Date: May 2013
Posts: 5
Mein Auto: 2008 BMW 335i coupe
As soon as i get the time I'll put car in for repair and report back on results, hopefully help someone else
Reply With Quote
  #12  
Old 05-25-2013, 09:56 PM
sptt144 sptt144 is offline
Officially Welcomed to the 'Fest
Location: Orange County, Ca.
 
Join Date: Aug 2012
Posts: 959
Mein Auto: 2009 335i
When I first got mine at 29K, it was happening to me when I was pushing the limit. I would let it cool down and it would be fine but if I stayed on it and drove the oil temp up, it would go into limp mode. Ever since BMW changed out my coils and injectors it hasn't happened again and I have a JB4 installed now. It has 40K now. Not sure if there is any relation.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms