Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 05-12-2013, 10:17 AM
DjAikonX3 DjAikonX3 is offline
Registered User
Location: West Chester
 
Join Date: Jun 2011
Posts: 22
Mein Auto: 2006 Bmw X3 3.0i Black
TPMS Light blinking then staying on, All pressure is correct

Hello,

I hav recently changed tires on my 06 X3 and the tpms light stays on after blinking for a while as soon as i startup the car, i have tried resetting using the button and following the instructions and is not making it come off what could it be? is there a way to reset the whole computer maybe? so everything resets again? please help

Thanks!
Reply With Quote
Advertisement
  #2  
Old 05-12-2013, 06:29 PM
Grabby544 Grabby544 is offline
Account closed at users request
Location: Wichita Falls, TX
 
Join Date: May 2013
Posts: 267
Mein Auto: 2009 X3
Re: TPMS Light blinking then staying on, All pressure is correct

Have you ever had your tps sensors in the tires replaced? They typically only last 5-7 years on average.

Sent from my ADR6350 using BimmerApp mobile app
Reply With Quote
  #3  
Old 05-12-2013, 08:27 PM
Supercourse Supercourse is offline
Officially Welcomed to the 'Fest
Location: British Columbia, Canada
 
Join Date: Feb 2008
Posts: 3,210
Mein Auto: 2004 X3 2.5i
Assuming you definitely have TPMS and not FTM (not all '06's did - just the late model year ones I believe) maybe installer damaged one of the sensors.

- if it started blinking immediately after the install, ask them if they did anything to try and re-initialize it themselves (some tire shops do, some don't)

- other than reducing psi in all tires to about 15, filling to 32 and trying the initialization again, I can't think of anything else other than having it hooked up to a BMW GT1 computer for diagnosis.
Reply With Quote
  #4  
Old 05-13-2013, 04:51 AM
DjAikonX3 DjAikonX3 is offline
Registered User
Location: West Chester
 
Join Date: Jun 2011
Posts: 22
Mein Auto: 2006 Bmw X3 3.0i Black
No the sensor have not been replaced just the tires,

what is the most inexpensive resource to get this sensors? i saw ITM? are those good?

also i will try lowering to 32 psi and see what happens, i really appreciate the response
Reply With Quote
  #5  
Old 05-13-2013, 06:09 AM
Grabby544 Grabby544 is offline
Account closed at users request
Location: Wichita Falls, TX
 
Join Date: May 2013
Posts: 267
Mein Auto: 2009 X3
Re: TPMS Light blinking then staying on, All pressure is correct

Never heard of that company. When in doubt go oem. But have your car checked for codes before you replace the sensors, I think there kind of pricey.


Sent from my ADR6350 using BimmerApp mobile app
Reply With Quote
  #6  
Old 05-17-2013, 06:52 AM
DjAikonX3 DjAikonX3 is offline
Registered User
Location: West Chester
 
Join Date: Jun 2011
Posts: 22
Mein Auto: 2006 Bmw X3 3.0i Black
So lowered the PSI to 32 and nothing light is still on, i guess i will have to take it to the dealer and see what they find - Thanks guys!
Reply With Quote
  #7  
Old 05-30-2013, 04:03 PM
DjAikonX3 DjAikonX3 is offline
Registered User
Location: West Chester
 
Join Date: Jun 2011
Posts: 22
Mein Auto: 2006 Bmw X3 3.0i Black
TPMS Light blinking then staying on, All pressure is correct

Ok so i bought the sensors and valves and had Tire Discounters put them on reset it the tpms light on the light is still on is there something special needed to be done when replacing this sensors other than doing a normal reset??


Sent from BimmerApp mobile app
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms