Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 05-14-2013, 07:49 PM
Bet2238 Bet2238 is offline
Registered User
Location: California
 
Join Date: May 2013
Posts: 10
Mein Auto: 2009 328i
Reposting Service soon Engine Light

Hello!, two months after my warranty expired service soon light illuminated. I thought it was a maintenance light coz i knew i'm due for an oil change but that's not it after an oil change and reset it's still there so i decided to buy an OBD2 (innova3030). My initial code was p0050 (bank 2 sensor 1) drove it for a couple of days and i've noticed that my idle rpm is not steady and hesitant to start. Scanned it again and now showing a bunch of code such as p0300,p0304,p0305,p0306,p0050,p1017,p1014,p0171. I replaced the oxygen sensor(Bank 2 sensor 1) knowing that it could be the problem since it was the first code that showed up ( used bosch ) after the replacement all the code are still present. I use the obd2 that i bought to clear but i couldn't clear the code please help any thoughts and ideas are appreciated .. Thanks

***
Ok 5 out 8 codes are now gone. The remaining codes left are p1017,p1014 and p0171 what u guys think. What could be the problem. Please help

***
A response fron Fast Bob:
It normally takes a number of driving cycles (of 15 miles or more) before the codes delete. This can take up to a week.

***
Thanks for the reply fast Bob i appreciated that. I drove it for a couple of days now the idle rpm is pretty stable it stays at 700 rpm, still have a little difficulty starting, the 3 codes are still there, and i have noticed i can hear a high pitch sound when decelerating (once in a while)and my gas i think it's burning too much gas for 50 miles I used atleast 3 gallons do you think it's a vacuum leak? If so, do you think i have two different problem?
Reply With Quote
Ads by Google
  #2  
Old 05-14-2013, 09:17 PM
fb88 fb88 is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Sep 2011
Posts: 620
Mein Auto: 2014 X1 xDrive28i
http://engine-codes.com/p1014_bmw.html
http://engine-codes.com/p1017_bmw.html
http://engine-codes.com/p0171_bmw.html <--- use CRC MAF cleaner on your MAF sensor to see. Also has the air filter been replaced?
http://www.amazon.com/CRC-05110-Mass...RC+MAF+Cleaner
Reply With Quote
  #3  
Old 05-15-2013, 11:40 AM
Bet2238 Bet2238 is offline
Registered User
Location: California
 
Join Date: May 2013
Posts: 10
Mein Auto: 2009 328i
Thanks fb88 i looked at the MAF before but i didn't clean it coz it looks clean as per air filter i haven't replace it yet. Once the MAF is cleaned and filter is changed and still the same do you think i need to replace the(oxygen sensor)bank 1 sensor 1?
Reply With Quote
  #4  
Old 05-15-2013, 06:53 PM
fb88 fb88 is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Sep 2011
Posts: 620
Mein Auto: 2014 X1 xDrive28i
How many miles is your car? I don't think you can tell by naked eye if MAF is dirty. Might as well replace air filter if it's overdue.
I don't know about the oxygen censor because I only fixed my problem w/the MAF cleaner. (fuel too lean, hesitation, stalls when stopped)
I'd think oxygen sensor would have its own code.

http://www.e90post.com/forums/showthread.php?t=357827

Last edited by fb88; 05-15-2013 at 06:54 PM.
Reply With Quote
  #5  
Old 05-15-2013, 07:42 PM
Bet2238 Bet2238 is offline
Registered User
Location: California
 
Join Date: May 2013
Posts: 10
Mein Auto: 2009 328i
I have 52K on mine, I will clean my MAF sensor and I will post the outcome.
Reply With Quote
  #6  
Old 05-21-2013, 06:28 PM
Bet2238 Bet2238 is offline
Registered User
Location: California
 
Join Date: May 2013
Posts: 10
Mein Auto: 2009 328i
I finally send my car to an indy mechanic and i was told that the problem is the valvetronic eccentric shaft sensor. but when he opened the valve cover he found some wear and tear on the gears and some metal shaving now he's talking about replacing the cam shaft. Is it really possible for that gear to worn out?
Reply With Quote
  #7  
Old 05-21-2013, 07:20 PM
fb88 fb88 is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Sep 2011
Posts: 620
Mein Auto: 2014 X1 xDrive28i
How much is he asking to replace the shaft sensor?
vs replacing cam shaft?
what if you don't replace the cam shaft?
Reply With Quote
  #8  
Old 05-21-2013, 09:05 PM
Bet2238 Bet2238 is offline
Registered User
Location: California
 
Join Date: May 2013
Posts: 10
Mein Auto: 2009 328i
the mechanic wants me to see it, so tomorrow i will check it out then we will make a decision
Reply With Quote
  #9  
Old 05-21-2013, 11:19 PM
1zamboni 1zamboni is offline
Officially Welcomed to the 'Fest
Location: Monte Sereno, CA
 
Join Date: Mar 2006
Posts: 423
Mein Auto: 2009 E82 & 2012 E93
Mine came on today and my SA thinks is the shaft sensor might gone bad, will keep you posted when I drop the car off on Thursday for diagnostic.
__________________
13 E93 M3 Melbourne Red
12 E93 Space Gray (Retired BMW buy back)
09 E82 Space Gray/Black int/Steps/Sport/Nav/Premium/Xenon/Phone Int/Hifi/269 wheel
2006 E90 ( Sold )
2001 E46 ( Sold )

My next vehicle would be a Zamboni
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms