Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 05-16-2013, 05:59 AM
mdr411 mdr411 is offline
Registered User
Location: Massachusetts
 
Join Date: May 2012
Posts: 3
Mein Auto: 2007 328xi
Car died on highway, second time this week

Monday I was driving to work, right before I arrive the red battery light came on. I went back inside and googled it, guessed either bad battery or alternator. Started the drive one, after 10 minutes all sorts of warning lights start coming on, car starts getting sluggish then dies. I noticed the dash lights were getting dimmer and the cr slowly lost all power. Got it towed home and replaced the alternator. Now the battery was dead do I jumped it and everything seemed fine. Then on my test drive the power steering lock warning came on red. So I brought it to my guy and be could. Find anything wrong(see other post). When I started it up to brim it home I noticed the light was gone...? So I figured I'm good to brig the car to work today. Wrong. I'm 5 minutes from work, I had made it 45 miles when the dash began lighting up warnings like a Christmas tree. First the abs, then 4x4, the. Some circle with waves, there were more. Then the car died. I pulled it to the side and heard a clicking sound coming from the glove box/ fuse area. I'm in the tow truck now bringing it back to the shop. Wtf...btw way it's a 2007 328xi with 130,000 miles. I've always loved it but I'm beginning to see red! What's going on? Bad battery? Bad alternator? I bought one from autozone, i know I prob should t have but I was able to get it that day.
Reply With Quote
Advertisement
  #2  
Old 05-16-2013, 06:06 AM
lqaddict's Avatar
lqaddict lqaddict is online now
Salz und Pfeffer
Location: NYC
 
Join Date: Dec 2006
Posts: 925
Mein Auto: 2014 F22 M235i
See this http://www.bimmerfest.com/forums/sho...d.php?t=418907
__________________
BMW CCA Member 454031
Save the manuals
Reply With Quote
  #3  
Old 05-16-2013, 06:11 AM
Watchme Watchme is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: May 2013
Posts: 375
Mein Auto: 2011 328i E90
Quote:
Originally Posted by mdr411 View Post
Monday I was driving to work, right before I arrive the red battery light came on. I went back inside and googled it, guessed either bad battery or alternator. Started the drive one, after 10 minutes all sorts of warning lights start coming on, car starts getting sluggish then dies. I noticed the dash lights were getting dimmer and the cr slowly lost all power. Got it towed home and replaced the alternator. Now the battery was dead do I jumped it and everything seemed fine. Then on my test drive the power steering lock warning came on red. So I brought it to my guy and be could. Find anything wrong(see other post). When I started it up to brim it home I noticed the light was gone...? So I figured I'm good to brig the car to work today. Wrong. I'm 5 minutes from work, I had made it 45 miles when the dash began lighting up warnings like a Christmas tree. First the abs, then 4x4, the. Some circle with waves, there were more. Then the car died. I pulled it to the side and heard a clicking sound coming from the glove box/ fuse area. I'm in the tow truck now bringing it back to the shop. Wtf...btw way it's a 2007 328xi with 130,000 miles. I've always loved it but I'm beginning to see red! What's going on? Bad battery? Bad alternator? I bought one from autozone, i know I prob should t have but I was able to get it that day.
OK there's definitely a lot of frustration in your post, and it is hard to follow.
1. I never got whether or not you replaced your battery?
2. The alternators from autozone come defective from the box more times than you will accept to believe.
3. Sounds like it may be a simple fix, but you have to work to figure it out. First hing is to check if you have at least 12V between the battery terminals. Second is check the voltage dip while you are cranking the motor. And third, check the voltage while the engine is running (should be about 14V).
After this is done, you may have to hunt for a bad ground.
Reply With Quote
  #4  
Old 05-16-2013, 07:10 AM
jburke4689 jburke4689 is offline
Officially Welcomed to the 'Fest
Location: Ellicott City, MD
 
Join Date: Apr 2008
Posts: 570
Mein Auto: 2007 335i
Have you had your car in for the battery connector recall?
__________________
Reply With Quote
  #5  
Old 05-16-2013, 08:17 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,007
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by mdr411 View Post
Monday I was driving to work, right before I arrive the red battery light came on. I went back inside and googled it, guessed either bad battery or alternator. Started the drive one, after 10 minutes all sorts of warning lights start coming on, car starts getting sluggish then dies. I noticed the dash lights were getting dimmer and the cr slowly lost all power. Got it towed home and replaced the alternator. Now the battery was dead do I jumped it and everything seemed fine. Then on my test drive the power steering lock warning came on red. So I brought it to my guy and be could. Find anything wrong(see other post). When I started it up to brim it home I noticed the light was gone...? So I figured I'm good to brig the car to work today. Wrong. I'm 5 minutes from work, I had made it 45 miles when the dash began lighting up warnings like a Christmas tree. First the abs, then 4x4, the. Some circle with waves, there were more. Then the car died. I pulled it to the side and heard a clicking sound coming from the glove box/ fuse area. I'm in the tow truck now bringing it back to the shop. Wtf...btw way it's a 2007 328xi with 130,000 miles. I've always loved it but I'm beginning to see red! What's going on? Bad battery? Bad alternator? I bought one from autozone, i know I prob should t have but I was able to get it that day.

First things first mdr-man. Do THIS
Reply With Quote
  #6  
Old 05-16-2013, 08:59 AM
Tom K. Tom K. is offline
Officially Welcomed to the 'Fest
Location: Maryland
 
Join Date: May 2008
Posts: 2,581
Mein Auto: '07 328iT.'13 Boxster
Quote:
Originally Posted by jburke4689 View Post
Have you had your car in for the battery connector recall?
And have both the IBS and JBE checked out by a BMW tech.

Tom
Reply With Quote
  #7  
Old 05-18-2013, 03:43 AM
mdr411 mdr411 is offline
Registered User
Location: Massachusetts
 
Join Date: May 2012
Posts: 3
Mein Auto: 2007 328xi
It ended up being a bad battery.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms