Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 05-18-2013, 06:47 AM
limeykraut limeykraut is offline
Registered User
Location: Atlanta, GA
 
Join Date: Apr 2013
Posts: 63
Mein Auto: 2006 530xiWagon
Voice commands

My new-to-me 530xi has the buttons for voice command, and the bmwvin site shows I have that option, but the buttons don't work. No 'tone' when I press them, and the navigation is silent. Where would I look for a module, and/or is there a master on/off other than what's in the manual? Tia


Sent from BimmerApp mobile app
__________________


2006 530xiT, Cold, Premium, Premium Sound, Steptronic, Comfort Seats, PDC, Active cruise, HUD, Nav
Reply With Quote
Advertisement
  #2  
Old 05-18-2013, 07:07 AM
wcr3d wcr3d is offline
Officially Welcomed to the 'Fest
Location: Indiana
 
Join Date: Jul 2012
Posts: 368
Mein Auto: 2006 530XI
There is no master switch that I know of. But, it may not be your problem. One thing I noticed on mine is the volume knob needs to be adjusted for each individual item. As in phone, music, nav...etc. Like during a phone call. You have to catch it when the person is talking for it to take affect. Not saying this is your problem but worth a shot. Also on the bottom of your IDrive screen when you are using voice commands there should be an icon like a head or something when the computer is speaking. It should help determine if its the speakers, module or IDrive.
__________________
Sport, Premium and Cold Weather Packages.
Reply With Quote
  #3  
Old 05-18-2013, 07:25 AM
limeykraut limeykraut is offline
Registered User
Location: Atlanta, GA
 
Join Date: Apr 2013
Posts: 63
Mein Auto: 2006 530xiWagon
Voice commands

I get no response to the voice command buttons, either of them. Does the volume of initializing tone vary as well? The one that tells you it's ready to accept commands? Does the radio volume drop when the Nav is giving instructions?


Sent from BimmerApp mobile app
__________________


2006 530xiT, Cold, Premium, Premium Sound, Steptronic, Comfort Seats, PDC, Active cruise, HUD, Nav
Reply With Quote
  #4  
Old 05-18-2013, 07:26 AM
limeykraut limeykraut is offline
Registered User
Location: Atlanta, GA
 
Join Date: Apr 2013
Posts: 63
Mein Auto: 2006 530xiWagon
Voice commands

Oh, and no icon on the bottom of the screen unless I turn off voice command in the Nav and then I get that icon


Sent from BimmerApp mobile app
__________________


2006 530xiT, Cold, Premium, Premium Sound, Steptronic, Comfort Seats, PDC, Active cruise, HUD, Nav
Reply With Quote
  #5  
Old 05-18-2013, 02:36 PM
wcr3d wcr3d is offline
Officially Welcomed to the 'Fest
Location: Indiana
 
Join Date: Jul 2012
Posts: 368
Mein Auto: 2006 530XI
Yes the volume varies on each seperate thing. You may actually be turning it on when you think off. The icon shows when you start it and the voice says its ready.
__________________
Sport, Premium and Cold Weather Packages.
Reply With Quote
  #6  
Old 05-18-2013, 03:03 PM
boramkiv's Avatar
boramkiv boramkiv is offline
Propellers Up Front
Location: Chesapeake, VA
 
Join Date: Jan 2011
Posts: 1,808
Mein Auto: Some Bavarian car outside
You should see a voice icon on the bottom of the screen (it looks exactly like the one on the steering wheel) once the voice button is pushed even if you don't hear a beep. Yes, the volume may be turned down, but unlikely for the first use of the voice command.
You may need to get the dealer to update to the latest version, and see whats happening. The voice command works VERY well in my opinion, and does so if you have navigation. It should operate something like this:
Reply With Quote
  #7  
Old 05-18-2013, 03:36 PM
limeykraut limeykraut is offline
Registered User
Location: Atlanta, GA
 
Join Date: Apr 2013
Posts: 63
Mein Auto: 2006 530xiWagon
Voice commands

Hmmm...ok, I don't get that icon at all. The phone works through Bluetooth, so the connection to speakers is ok I suppose, so maybe it needs an initializing as you suggest??


Sent from BimmerApp mobile app
__________________


2006 530xiT, Cold, Premium, Premium Sound, Steptronic, Comfort Seats, PDC, Active cruise, HUD, Nav
Reply With Quote
  #8  
Old 05-18-2013, 04:37 PM
boramkiv's Avatar
boramkiv boramkiv is offline
Propellers Up Front
Location: Chesapeake, VA
 
Join Date: Jan 2011
Posts: 1,808
Mein Auto: Some Bavarian car outside
Try the hard reset, remove any discs in both drives, disconnect negative terminal for an hour and then reconnect.
Wait for it to load up, and try again. If not you need to see a dealer or independent mechanic with software.

If your idrive home screen looks like this, you need an update.


If it looks like this, you may not need an update.

Last edited by boramkiv; 05-18-2013 at 05:08 PM.
Reply With Quote
  #9  
Old 05-19-2013, 07:35 AM
limeykraut limeykraut is offline
Registered User
Location: Atlanta, GA
 
Join Date: Apr 2013
Posts: 63
Mein Auto: 2006 530xiWagon
Voice commands

Ok, thanks. I'll try that, since my screen looks like your second pic.


Sent from BimmerApp mobile app
__________________


2006 530xiT, Cold, Premium, Premium Sound, Steptronic, Comfort Seats, PDC, Active cruise, HUD, Nav
Reply With Quote
  #10  
Old 05-19-2013, 09:34 AM
limeykraut limeykraut is offline
Registered User
Location: Atlanta, GA
 
Join Date: Apr 2013
Posts: 63
Mein Auto: 2006 530xiWagon
Voice commands

Just to confirm, if the VIN decode shows the car has voice command, any necessary modules are there, correct?


Sent from BimmerApp mobile app
__________________


2006 530xiT, Cold, Premium, Premium Sound, Steptronic, Comfort Seats, PDC, Active cruise, HUD, Nav
Reply With Quote
  #11  
Old 05-19-2013, 03:22 PM
boramkiv's Avatar
boramkiv boramkiv is offline
Propellers Up Front
Location: Chesapeake, VA
 
Join Date: Jan 2011
Posts: 1,808
Mein Auto: Some Bavarian car outside
Quote:
Originally Posted by limeykraut View Post
Just to confirm, if the VIN decode shows the car has voice command, any necessary modules are there, correct?


Sent from BimmerApp mobile app
Yes, but no.
Decoder does show what it rolled out the factory with.
Previous owner could have done something, car could have been rebuilt incorrectly
after minor crash or something.
You never really know.
This is a pretty good VIN decoder, tells quite a lot.

If its still not working, best to get it checked out.
Reply With Quote
  #12  
Old 05-19-2013, 03:30 PM
pjinca pjinca is online now
USAF Pararescue Veteran
Location: SoCal
 
Join Date: Jun 2009
Posts: 2,128
Mein Auto: 2008 550i
Here's a complete list of available voice commands:
http://5series.net/info/E60_Voice_Commands.pdf
__________________

[B]2008 550 - Carbon Black/Black - M-sport, Cold Weather, Premium, NAV, Comfort Access, Logic 7 (LOADED, every option except night vision)

Previous 3 cars (the 550 is my 38th car):
2005 530i - Prem, Sport, NAV
2006 Jeep SRT-8
2003 Infiniti G35 coupe
Reply With Quote
  #13  
Old 05-19-2013, 03:40 PM
limeykraut limeykraut is offline
Registered User
Location: Atlanta, GA
 
Join Date: Apr 2013
Posts: 63
Mein Auto: 2006 530xiWagon
Voice commands

Well, no go on the reset. Nothing changed...hiho, hiho, to the dealer I go...


Sent from BimmerApp mobile app
__________________


2006 530xiT, Cold, Premium, Premium Sound, Steptronic, Comfort Seats, PDC, Active cruise, HUD, Nav
Reply With Quote
  #14  
Old 07-16-2013, 07:35 AM
limeykraut limeykraut is offline
Registered User
Location: Atlanta, GA
 
Join Date: Apr 2013
Posts: 63
Mein Auto: 2006 530xiWagon
I finally had time on a Saturday to head to the dealer. He ran the VIN, and said it is equipped properly, so he heads out to the car and when he gets nothing from the steering wheel button, no beep, no icon, no nothing, he says the only option he has is to turn it loose in service with a tech to determine what the issue is...starting at $135.00, and onward and upwards depending in the time it takes to narrow down the problem. He did say his first thought was that it could be the steering wheel switch is bad. Everything else works - bluetooth, the Nav (just silent), it's only the absence of any response to the VC buttons, which makes him think that.

Thoughts? Opinions? I can change the steering wheel column switch, about $70 plus the time. What about the fact that there's an additional switch in the center console? Anyone know a way to determine which switch might be bad?
__________________


2006 530xiT, Cold, Premium, Premium Sound, Steptronic, Comfort Seats, PDC, Active cruise, HUD, Nav
Reply With Quote
  #15  
Old 07-18-2013, 08:12 AM
limeykraut limeykraut is offline
Registered User
Location: Atlanta, GA
 
Join Date: Apr 2013
Posts: 63
Mein Auto: 2006 530xiWagon
Anyone? Anyone? Bueller....Bueller...?
__________________


2006 530xiT, Cold, Premium, Premium Sound, Steptronic, Comfort Seats, PDC, Active cruise, HUD, Nav
Reply With Quote
  #16  
Old 07-18-2013, 08:27 AM
boramkiv's Avatar
boramkiv boramkiv is offline
Propellers Up Front
Location: Chesapeake, VA
 
Join Date: Jan 2011
Posts: 1,808
Mein Auto: Some Bavarian car outside
Does the center console voice button work? That would be a HUGE plus if you have one and it works.
Reply With Quote
  #17  
Old 07-18-2013, 08:46 AM
fdriller9 fdriller9 is online now
Officially Welcomed to the 'Fest
Location: NJ/Philly
 
Join Date: Oct 2006
Posts: 3,064
Mein Auto: '06 AW 330xi
Quote:
Originally Posted by boramkiv View Post
Does the center console voice button work? That would be a HUGE plus if you have one and it works.
Yea I was about to suggest the same. You might have a voice command button by the iDrive knob.
__________________

| LCI Msport Conversion | Custom Kevlar/Carbon Fiber Wind Splitter | Exotic Tuning Front Lip | H&R Coilovers | M3 Subframe Bushings | E93 M3 23.6mm Rear Sway Bar | Whiteline 27mm Front Sway Bar | Ground Control Camber Kit | L7 | Hand-Made LED Angel Eyes | Breyton GTS-R | Bridgestone Pole Position S-04 | CarPC with Centrafuse Front End | Alpine MRP-M500 | Custom LED Reverse Lights | OEM Blacklines | BMW Performance Trunk Spoiler |
Reply With Quote
  #18  
Old 07-18-2013, 09:07 AM
pjinca pjinca is online now
USAF Pararescue Veteran
Location: SoCal
 
Join Date: Jun 2009
Posts: 2,128
Mein Auto: 2008 550i
It may be similar to he phone button, all E60s have the phone button, but not all came with Bluetooth. It wasn't standard until 2006 models, before that BT was an option.
__________________

[B]2008 550 - Carbon Black/Black - M-sport, Cold Weather, Premium, NAV, Comfort Access, Logic 7 (LOADED, every option except night vision)

Previous 3 cars (the 550 is my 38th car):
2005 530i - Prem, Sport, NAV
2006 Jeep SRT-8
2003 Infiniti G35 coupe
Reply With Quote
  #19  
Old 07-18-2013, 01:47 PM
limeykraut limeykraut is offline
Registered User
Location: Atlanta, GA
 
Join Date: Apr 2013
Posts: 63
Mein Auto: 2006 530xiWagon
Quote:
Originally Posted by fdriller9 View Post
Yea I was about to suggest the same. You might have a voice command button by the iDrive knob.
I do have that button by the iDrive (MENU/voice), neither do anything. No beep, no icon, no nothing. It did make me wonder if the button on the steering wheel was the 'master' button, since the SA saw that, but was focused on the steering wheel one.
__________________


2006 530xiT, Cold, Premium, Premium Sound, Steptronic, Comfort Seats, PDC, Active cruise, HUD, Nav
Reply With Quote
  #20  
Old 07-18-2013, 01:49 PM
limeykraut limeykraut is offline
Registered User
Location: Atlanta, GA
 
Join Date: Apr 2013
Posts: 63
Mein Auto: 2006 530xiWagon
Quote:
Originally Posted by pjinca View Post
It may be similar to he phone button, all E60s have the phone button, but not all came with Bluetooth. It wasn't standard until 2006 models, before that BT was an option.
Agreed, which is why we checked for the correct option being installed, and it is, before he went to the car and tried the button. FWIW, bluetooth works fine, both my iphone5 and the wife's older phone paired without issue. I don't know if the 'voice' that is supposed to be there on navigation, etc uses the same speakers as the bluetooth uses.
__________________


2006 530xiT, Cold, Premium, Premium Sound, Steptronic, Comfort Seats, PDC, Active cruise, HUD, Nav
Reply With Quote
  #21  
Old 07-18-2013, 02:26 PM
pjinca pjinca is online now
USAF Pararescue Veteran
Location: SoCal
 
Join Date: Jun 2009
Posts: 2,128
Mein Auto: 2008 550i
Quote:
Originally Posted by limeykraut View Post
Agreed, which is why we checked for the correct option being installed, and it is, before he went to the car and tried the button. FWIW, bluetooth works fine, both my iphone5 and the wife's older phone paired without issue. I don't know if the 'voice' that is supposed to be there on navigation, etc uses the same speakers as the bluetooth uses.
Correct, it uses the same mic and speakers for both BT an Voice Command. What was curious to me is that you mentioned that the nav also does not make any sound, correct?
__________________

[B]2008 550 - Carbon Black/Black - M-sport, Cold Weather, Premium, NAV, Comfort Access, Logic 7 (LOADED, every option except night vision)

Previous 3 cars (the 550 is my 38th car):
2005 530i - Prem, Sport, NAV
2006 Jeep SRT-8
2003 Infiniti G35 coupe
Reply With Quote
  #22  
Old 07-19-2013, 05:24 AM
limeykraut limeykraut is offline
Registered User
Location: Atlanta, GA
 
Join Date: Apr 2013
Posts: 63
Mein Auto: 2006 530xiWagon
Quote:
Originally Posted by pjinca View Post
Correct, it uses the same mic and speakers for both BT an Voice Command. What was curious to me is that you mentioned that the nav also does not make any sound, correct?
Correct. Nav works, and has the option on screen to shut off the voice, but even turned on, there is no 'talking' from the car at all.

So the voice module must be working for the Bluetooth to work? That would lend credence to the possibility of it being the switch, and also it would mean that my other thought of the module being unplugged wouldn't apply?
__________________


2006 530xiT, Cold, Premium, Premium Sound, Steptronic, Comfort Seats, PDC, Active cruise, HUD, Nav
Reply With Quote
  #23  
Old 07-19-2013, 07:14 AM
boramkiv's Avatar
boramkiv boramkiv is offline
Propellers Up Front
Location: Chesapeake, VA
 
Join Date: Jan 2011
Posts: 1,808
Mein Auto: Some Bavarian car outside
It's not the steering wheel button or idrive voice button or (switches) because highly unlikely that they both would go out at the same time.
I think it's a programming issue especially since you're getting no sound from the nav lady, but getting sound from other audio. The dealer should not have leaned toward the switch because both of them doesnt work and you're not getting Nav instructions, so don't even bother removing the steering wheel.
Reply With Quote
  #24  
Old 07-19-2013, 07:20 AM
limeykraut limeykraut is offline
Registered User
Location: Atlanta, GA
 
Join Date: Apr 2013
Posts: 63
Mein Auto: 2006 530xiWagon
Quote:
Originally Posted by boramkiv View Post
It's not the steering wheel button or idrive voice button or (switches) because highly unlikely that they both would go out at the same time.
I think it's a programming issue especially since you're getting no sound from the nav lady, but getting sound from other audio. The dealer should not have leaned toward the switch because both of them doesnt work and you're not getting Nav instructions, so don't even bother removing the steering wheel.
I asked about software updates, and they didn't think so. Could they have been able to tell from the VIN that it had the latest version? They didn't say that, but... All they offered was to turn it over to a tech to do electrical diagnostics....
__________________


2006 530xiT, Cold, Premium, Premium Sound, Steptronic, Comfort Seats, PDC, Active cruise, HUD, Nav
Reply With Quote
  #25  
Old 07-19-2013, 07:27 AM
boramkiv's Avatar
boramkiv boramkiv is offline
Propellers Up Front
Location: Chesapeake, VA
 
Join Date: Jan 2011
Posts: 1,808
Mein Auto: Some Bavarian car outside
They can't tell from the VIN, but once you run a test on the modules the versions will show. I just had a member switch from non nav to nav and had to have some items coded because there was NO sound at all. You're good on the part of options listed, but as far as them working it could be a failed module or the way they are programmed to operate.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms