Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 05-21-2013, 10:22 AM
rockbottom8's Avatar
rockbottom8 rockbottom8 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles, CA
 
Join Date: Jul 2005
Posts: 307
Send a message via AIM to rockbottom8 Send a message via MSN to rockbottom8 Send a message via Yahoo to rockbottom8 Send a message via Skype™ to rockbottom8
Mein Auto: 2014 428i
Front Brake Service won't reset!

About 5 months ago I replaced all brakes/pads/etc. I was checking today and noticed that my frons were due in 4000 but my rears were due in 16k. I decided to reset the fronts and now the Brake light is always on and it says service every time i turn on the car. I've tried to reset it 3 times already...see screen shots.

Can someone help?
Attached Thumbnails
Click image for larger version

Name:	IMG_20130521_094606.jpg
Views:	45
Size:	236.9 KB
ID:	377825   Click image for larger version

Name:	IMG_20130521_094631.jpg
Views:	68
Size:	247.3 KB
ID:	377826   Click image for larger version

Name:	IMG_20130521_094636.jpg
Views:	40
Size:	250.4 KB
ID:	377827   Click image for larger version

Name:	IMG_20130521_094640.jpg
Views:	44
Size:	244.3 KB
ID:	377828   Click image for larger version

Name:	IMG_20130521_094653.jpg
Views:	38
Size:	189.9 KB
ID:	377829  

__________________
Current: 2014 428i | Jet Black | Leather Dakota Black/Red highlight | Anthracite Wood Trim | Premium | Cold Weather | Sport Line | Driver Assistance | Harman Kardon | Tint 35%
Previous: 2006 325i | Titanium Silver | Black Leather | Poplar Trim | Premium | Cold Weather | Sport | Steptronic | Xenon | Tint 50%, 35%, 20% | Sirius | Logic 7 | JL 500/1 AMP | JL w6v2 12" Sub
Reply With Quote
Ads by Google
  #2  
Old 05-21-2013, 10:40 AM
Saintor's Avatar
Saintor Saintor is offline
Abuser of everything
Location: MTL
 
Join Date: Dec 2002
Posts: 2,748
Mein Auto: BMW E90 2007
Did you replace pad sensors? If you didn't, you can always cut the head, tie the wires together and it will do the trick.
__________________
2007 E90 AW 323i Step | Lowered 1.25"/1" | BMW Performance Exhaust | Debadged | Scangauge II | Style 162 18" & 161 17" wheels & rear 15mm spacers
Reply With Quote
  #3  
Old 05-21-2013, 10:41 AM
rockbottom8's Avatar
rockbottom8 rockbottom8 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles, CA
 
Join Date: Jul 2005
Posts: 307
Send a message via AIM to rockbottom8 Send a message via MSN to rockbottom8 Send a message via Yahoo to rockbottom8 Send a message via Skype™ to rockbottom8
Mein Auto: 2014 428i
i'd have to ask the place that did it and see... i sure hope they did.
__________________
Current: 2014 428i | Jet Black | Leather Dakota Black/Red highlight | Anthracite Wood Trim | Premium | Cold Weather | Sport Line | Driver Assistance | Harman Kardon | Tint 35%
Previous: 2006 325i | Titanium Silver | Black Leather | Poplar Trim | Premium | Cold Weather | Sport | Steptronic | Xenon | Tint 50%, 35%, 20% | Sirius | Logic 7 | JL 500/1 AMP | JL w6v2 12" Sub
Reply With Quote
  #4  
Old 05-21-2013, 10:44 AM
j_nolesfan j_nolesfan is offline
Registered User
Location: Atlanta
 
Join Date: Jan 2013
Posts: 63
Mein Auto: 07 328i Coupe
I had the same problem. It's all in how you click the buttons. If I remember correctly, it's two very abrupt taps on the button about like double-clicking a mouse. Very frustrating. I had my brake warning light on for 10,000 miles before I got it to reset and even then, I was just screwing around and happened upon the resolution.

Let me know if it works!

Jeff
Reply With Quote
  #5  
Old 05-21-2013, 10:46 AM
rockbottom8's Avatar
rockbottom8 rockbottom8 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles, CA
 
Join Date: Jul 2005
Posts: 307
Send a message via AIM to rockbottom8 Send a message via MSN to rockbottom8 Send a message via Yahoo to rockbottom8 Send a message via Skype™ to rockbottom8
Mein Auto: 2014 428i
what u mean? I go to the item...then i press it once to get the reset option. then i press and hold for 3 seconds till the clock comes and it supposedly resets.
__________________
Current: 2014 428i | Jet Black | Leather Dakota Black/Red highlight | Anthracite Wood Trim | Premium | Cold Weather | Sport Line | Driver Assistance | Harman Kardon | Tint 35%
Previous: 2006 325i | Titanium Silver | Black Leather | Poplar Trim | Premium | Cold Weather | Sport | Steptronic | Xenon | Tint 50%, 35%, 20% | Sirius | Logic 7 | JL 500/1 AMP | JL w6v2 12" Sub
Reply With Quote
  #6  
Old 05-21-2013, 11:00 AM
j_nolesfan j_nolesfan is offline
Registered User
Location: Atlanta
 
Join Date: Jan 2013
Posts: 63
Mein Auto: 07 328i Coupe
My son was actually doing it at the time but I'm pretty sure the reset is just a tap and not a hold 3 seconds.
Reply With Quote
  #7  
Old 05-27-2013, 06:08 AM
smbmw3 smbmw3 is offline
Officially Welcomed to the 'Fest
Location: Scottsdale, AZ
 
Join Date: Oct 2010
Posts: 117
Mein Auto: 1998 M3
Quote:
Originally Posted by rockbottom8 View Post
what u mean? I go to the item...then i press it once to get the reset option. then i press and hold for 3 seconds till the clock comes and it supposedly resets.
No matter what you "reset" in the car when it comes to brakes, it is all about the sensors on the physical car. They have to be replaced along with the brakes.
__________________
Current: 1998 BMW M3
Former: 2007 335i and 328i
Reply With Quote
  #8  
Old 05-27-2013, 09:57 AM
j_nolesfan j_nolesfan is offline
Registered User
Location: Atlanta
 
Join Date: Jan 2013
Posts: 63
Mein Auto: 07 328i Coupe
Re: Front Brake Service won't reset!

Quote:
Originally Posted by smbmw3 View Post
No matter what you "reset" in the car when it comes to brakes, it is all about the sensors on the physical car. They have to be replaced along with the brakes.
You do you have to replace the sensor if it came in contact with a rotor. Otherwise, you can reuse the existing sensor.

Sent from my LG-LS970 using BimmerApp mobile app
Reply With Quote
  #9  
Old 05-27-2013, 11:25 AM
chopin1012 chopin1012 is offline
Registered User
Location: N/A
 
Join Date: Jan 2009
Posts: 65
Mein Auto: 2006 BMW 330i Sedan
For the E46, you can reuse the sensor if the light didn't come on. For the E90, you must replace the sensor every time as it's designed differently.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms