Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 05-29-2013, 06:27 PM
cj_lovely7 cj_lovely7 is offline
Registered User
Location: Kentucky
 
Join Date: Jun 2012
Posts: 10
Mein Auto: X5 4.8is
2004 BMW X5 4.8is instrument cluster..HELP

within the last year i have noticed some small malfunctions in my car, mostly from the dash column. The MPh area of the dash will blink on and off..sometimes this will stay off for minutes at a time. I notice streaks of darkness in my stereo dash (all numbers aren't completly light up). More recently my suspension has become inactivated and though my ride is rough, I can still drive the car. Ive taken it to two dealers and both say they are unable to read any codes from it and suggest it to be the instument cluster. Im being quoted $1800. Has anyone else had exsperience with this?!?!?!?..im told that more things will begin to fail if not fixed because the cluster is not communicating with the car...Any suggestions please
Reply With Quote
Ads by Google
  #2  
Old 06-10-2013, 02:01 AM
gizzyx5 gizzyx5 is offline
Registered User
Location: new zealand
 
Join Date: Apr 2013
Posts: 1
Mein Auto: e53 x5 4.6is
yip i have same problem with my 01 4.6is indicator lights on dash come and go,radio inoperative screen blank,then works but cannot change station or volume etc check brake/tail lights,pdc sensors beep and flash rev camera blank please help!!!!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms