Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 06-16-2013, 12:40 AM
freddyx5 freddyx5 is offline
Registered User
Location: UAE, Abu Dhabi
 
Join Date: Jun 2013
Posts: 1
Mein Auto: BMW X5 2002
Question Bmw x5 2002

Hi,

I have a problems when I apply brakes, I hear and feel a noise coming at the back. It seems like after applying the brakes something hit and make a noise "dung". could you please advise me, what is the noise?

Thanks.
Reply With Quote
Advertisement
  #2  
Old 06-17-2013, 10:00 AM
tim330i's Avatar
tim330i tim330i is offline
Administrator
Location: Boston
 
Join Date: Dec 2001
Posts: 5,913
Mein Auto: Ti Silver 03 M3
Welcome to Bimmerfest.com! One of the mods moved your thread over to the X5 forum for you. Try searching in here for someone with a similar problem.

Good luck,
Tim
Reply With Quote
  #3  
Old 06-17-2013, 04:49 PM
boramkiv's Avatar
boramkiv boramkiv is offline
Propellers Up Front
Location: Chesapeake, VA
 
Join Date: Jan 2011
Posts: 1,814
Mein Auto: Some Bavarian car outside
Quote:
Originally Posted by freddyx5 View Post
Hi,

I have a problems when I apply brakes, I hear and feel a noise coming at the back. It seems like after applying the brakes something hit and make a noise "dung". could you please advise me, what is the noise?

Thanks.
Very difficult to diagnose with the information. X5 generally have tranny issues where they thud while slowing from 2nd gear to 1st.
It could be the rear axle and any components on it. Maybe your rear subframe bushings are completely gone. Just one many things to consider.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms