Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)

E36 (1991 - 1999)
The E36 chassis 3-Series BMW was a huge hit among driving enthusiasts from the first moment the car hit the pavement. The E36 won numerous awards over the years it was produced and is still a favorite of many BMW enthusiasts to this day! -- View the E36 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 06-19-2013, 04:49 PM
newburgfdz71 newburgfdz71 is offline
Registered User
Location: st thomas, pa
 
Join Date: Oct 2010
Posts: 31
Mein Auto: 1998 328i
another misfire problem

ok so the last week i have been reading misfire thread after misfire thread on several forums, and none really match my problem. i have a 98 328i 5speed car and it only seams to act up when under load or if i jump on it. when it misfires its almost like someone has shut the fuel off then turned it back on and sometimes the car will completely shut off and the only way to get it to really start is to start it in gear. i have replaced the fuel pump, fuel filter, spark plugs, coils, and cleaned the maf all within the last 6 months
Reply With Quote
Advertisement
  #2  
Old 06-20-2013, 09:17 AM
newburgfdz71 newburgfdz71 is offline
Registered User
Location: st thomas, pa
 
Join Date: Oct 2010
Posts: 31
Mein Auto: 1998 328i
i forgot to mention that the cyclone valve was replaced and the icv was cleaned about a month ago when i was doing other maintence on the car
Reply With Quote
  #3  
Old 06-20-2013, 09:18 AM
newburgfdz71 newburgfdz71 is offline
Registered User
Location: st thomas, pa
 
Join Date: Oct 2010
Posts: 31
Mein Auto: 1998 328i
and also no vac leaks
Reply With Quote
  #4  
Old 06-20-2013, 10:30 AM
LordlierPie7781 LordlierPie7781 is offline
Officially Welcomed to the 'Fest
Location: North SF Bay Area
 
Join Date: Apr 2013
Posts: 107
Mein Auto: 93 Dinan S3, 325is base
Im new to wrenching on these cars, but it looks like you cleaned or replaced everything but the fuel rail, is that a part that could cause this issue? or maybe the injectors are not in good condition? just two thoughts on it.
Reply With Quote
  #5  
Old 06-20-2013, 10:36 AM
Leusent Leusent is offline
Officially Welcomed to the 'Fest
Location: Canada
 
Join Date: Jun 2010
Posts: 477
Mein Auto: 328is
Perhaps you've got some gunk built up in the fuel rail?
__________________
Winter: 1997 DOHC I-6 2.8L 5Spd BMW 328is (2-Door)
Summer: 1992 DOHC I-4 2.0L 5Spd Toyota MR-2 Turbo (2-Seat)
Summer: 1983/1984/2007 Honda CB550SC/VF500F/CBR600RR (2-Wheel)
Reply With Quote
  #6  
Old 06-21-2013, 07:35 PM
newburgfdz71 newburgfdz71 is offline
Registered User
Location: st thomas, pa
 
Join Date: Oct 2010
Posts: 31
Mein Auto: 1998 328i
ok so tonight i waas messing around with my car and noticed that my vanos is starting to rattle could this cause my problems
Reply With Quote
  #7  
Old 06-21-2013, 08:16 PM
dc_wright's Avatar
dc_wright dc_wright is online now
bimmerfest Supporting Member
Location: Orlando, Florida
 
Join Date: Nov 2007
Posts: 7,765
Send a message via ICQ to dc_wright
Mein Auto: '96 328iC, '04 325Ci
Have you checked the throttle position sensor? It's what tells the DME where the throttle butterfly is positioned. If the TPS is going open momentarily it will be like you've taken your foot off the throttle.....
__________________
2006 Z4 3.0si Sport Package (But I'll still hang with my "homies" in the E36 forum)
Reply With Quote
  #8  
Old 06-21-2013, 09:47 PM
newburgfdz71 newburgfdz71 is offline
Registered User
Location: st thomas, pa
 
Join Date: Oct 2010
Posts: 31
Mein Auto: 1998 328i
tps is only about 8 months old
Reply With Quote
  #9  
Old 06-22-2013, 07:56 AM
Nicky3 Nicky3 is offline
Officially Welcomed to the 'Fest
Location: Nashville,TN
 
Join Date: Dec 2012
Posts: 621
Mein Auto: 96 328is
Is it an OEM sensor or after market?
Reply With Quote
  #10  
Old 06-22-2013, 10:14 AM
dc_wright's Avatar
dc_wright dc_wright is online now
bimmerfest Supporting Member
Location: Orlando, Florida
 
Join Date: Nov 2007
Posts: 7,765
Send a message via ICQ to dc_wright
Mein Auto: '96 328iC, '04 325Ci
Is the CEL illuminated and/or have you had the fault codes read?
__________________
2006 Z4 3.0si Sport Package (But I'll still hang with my "homies" in the E36 forum)
Reply With Quote
  #11  
Old 06-22-2013, 11:54 AM
newburgfdz71 newburgfdz71 is offline
Registered User
Location: st thomas, pa
 
Join Date: Oct 2010
Posts: 31
Mein Auto: 1998 328i
tps is an aftermarket sensor and i just got my reader back off my bother so i still have to check. i will repost as soon as i pull my codes
Reply With Quote
  #12  
Old 06-22-2013, 11:56 AM
newburgfdz71 newburgfdz71 is offline
Registered User
Location: st thomas, pa
 
Join Date: Oct 2010
Posts: 31
Mein Auto: 1998 328i
as far as the cel being illuminated i dont know because the po had removed the bulb and bulb holder so i need to order some up
Reply With Quote
  #13  
Old 06-22-2013, 12:45 PM
dc_wright's Avatar
dc_wright dc_wright is online now
bimmerfest Supporting Member
Location: Orlando, Florida
 
Join Date: Nov 2007
Posts: 7,765
Send a message via ICQ to dc_wright
Mein Auto: '96 328iC, '04 325Ci
Your car is OBD2 so you can go to any of the big box parts stores (Advance, Autozone, etc.) and they'll connect a scanner and read the codes for you for free. I would do that before I tried anything else. Without knowing what faults the DME is seeing you're just wasting money throwing parts at this problem.
__________________
2006 Z4 3.0si Sport Package (But I'll still hang with my "homies" in the E36 forum)
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms