Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 06-20-2013, 02:09 PM
kvasg kvasg is offline
Registered User
Location: Austin
 
Join Date: Oct 2004
Posts: 48
Mein Auto: 325i
Fuel Pump Sensor

Hello BMWfanatics.
Has this issue happened to anyone of you? I have a 2001 325i (160k) miles. Today while heading back to work from lunch, my car wouldn't start. It would start for few seconds and immediately shut off. Lights, and everything work in the car. So I ended up getting it towed to my house and after it was back on the ground, I started and it worked. The AAA towing person stated it was probably a Fuel Pump sensor. Any advice? I'm afraid to drive this and it turns out to be another issue like this again. My check engine light didn't come either.
Reply With Quote
Ads by Google
  #2  
Old 06-20-2013, 05:43 PM
LOS842 LOS842 is offline
Registered User
Location: new jersey
 
Join Date: Jun 2013
Posts: 3
Send a message via Yahoo to LOS842
Mein Auto: 325 xi
Re: Fuel Pump Sensor

This issue jus happened to my 2003 325xi I called the dealer to see if it was under warranty and its not and it would cost me 1200 they are crazy

Sent from BimmerApp mobile app
Reply With Quote
  #3  
Old 06-20-2013, 10:30 PM
GoForthFast GoForthFast is offline
Officially Welcomed to the 'Fest
Location: New York
 
Join Date: Jul 2004
Posts: 2,324
Mein Auto: '04 330Ci 6-speed
Probably needs a new fuel pump. Not sensor. What is a fuel pump sensor??

Look up DIY on youtube

Part is around 130 and takes 40 minutes if you can DIY well.
Reply With Quote
  #4  
Old 06-21-2013, 12:18 PM
moemeadors moemeadors is offline
Registered User
Location: virginia
 
Join Date: Jun 2013
Posts: 8
Mein Auto: 2002 325ci convertible
Just finished with this problem. Fuel pump. exact same problem. Checked it by the Youtube video with volt meter at harnass. Listen for the pump with the back seat up...if it is running, it isi obvious. get the right fuel line hose clamps. Rock auto has a great price, about 90 cheaper than advance.
Reply With Quote
  #5  
Old 06-21-2013, 12:26 PM
kvasg kvasg is offline
Registered User
Location: Austin
 
Join Date: Oct 2004
Posts: 48
Mein Auto: 325i
Thanks everyone. I guess i'm confused on why it would work at random times? Today when i started it, its running as well. I spoke with my mobile mechanic and since I didn't get the check engine light, what is the best way for him to see if it is the fuel pump or sensor? How would i know its not the sensor?
Reply With Quote
  #6  
Old 06-21-2013, 01:42 PM
mawana's Avatar
mawana mawana is offline
Officially Welcomed to the 'Fest
Location: DFW, TX
 
Join Date: Nov 2006
Posts: 2,022
Mein Auto: e46 ZHP, e90 M3
Quote:
Originally Posted by LOS842 View Post
This issue jus happened to my 2003 325xi I called the dealer to see if it was under warranty and its not and it would cost me 1200 they are crazy

Sent from BimmerApp mobile app
Warranty!!!
__________________
"Common sense is the collection of prejudices acquired by age 18." ~ Albert Einstein
BMWCCA 405578
Reply With Quote
  #7  
Old 06-21-2013, 02:36 PM
kvasg kvasg is offline
Registered User
Location: Austin
 
Join Date: Oct 2004
Posts: 48
Mein Auto: 325i
Looks like, the warranty has passed it. The fuel pump warranty is only for 10 years or 120k miles. I have 12 years and 160k miles on my car.
Any way to really be sure its the fuel pump?
Reply With Quote
  #8  
Old 06-21-2013, 05:39 PM
Fast Bob's Avatar
Fast Bob Fast Bob is offline
Keeping it surreal
Location: Here, there, everywhere....
 
Join Date: Jun 2004
Posts: 33,902
Mein Auto: 2004 330Ci ZHP 3 pedals
Is this a SULEV car ?
__________________
The road goes ever onward....
(R.I.P. Jever)

*Please support the Wounded Warrior Project*

When faced with choosing between two evils, always go with the one you`ve never tried before....
Reply With Quote
  #9  
Old 06-21-2013, 10:34 PM
GoForthFast GoForthFast is offline
Officially Welcomed to the 'Fest
Location: New York
 
Join Date: Jul 2004
Posts: 2,324
Mein Auto: '04 330Ci 6-speed
Quote:
Originally Posted by kvasg View Post
Thanks everyone. I guess i'm confused on why it would work at random times? Today when i started it, its running as well.
Look up the word erratic.
Reply With Quote
  #10  
Old 06-21-2013, 10:50 PM
Fast Bob's Avatar
Fast Bob Fast Bob is offline
Keeping it surreal
Location: Here, there, everywhere....
 
Join Date: Jun 2004
Posts: 33,902
Mein Auto: 2004 330Ci ZHP 3 pedals
Quote:
Originally Posted by kvasg View Post
, what is the best way for him to see if it is the fuel pump or sensor? How would i know its not the sensor?
What is a fuel pump sensor ? What purpose would it serve ?

Do you mean relay, and not "sensor" ?
__________________
The road goes ever onward....
(R.I.P. Jever)

*Please support the Wounded Warrior Project*

When faced with choosing between two evils, always go with the one you`ve never tried before....
Reply With Quote
  #11  
Old 06-22-2013, 10:10 AM
ahull's Avatar
ahull ahull is online now
Officially Welcomed to the 'Fest
Location: Carolina
 
Join Date: Apr 2006
Posts: 3,105
Mein Auto: ist schnell! (03 330i SC)
Might be saying "sender" so basically the pump but could be the relay or other typical items
__________________
2003 330i TiAg Sport Pkg
DIY MODS: AA Stage I supercharger, Meyle HD FCAs w Powerflex CABs, Bilstein shocks, Meyle HD Rtabs, Angel Eyes, Clear Corners/Markers w/ LEDs, LED tails, ZHP rims, Akebono pads, AUX input
DIY E46 Merit Badges: Sunroof resurrection, CCV, OFHG, VCG w/ VANOS seals, DISA, Cooling Refresh I, steering giubo, window regs, Magnetic Infandibulator (see wiki)
DIY On deck: Rear Diff bushing. UUC SSK, clutch job eventually, Wavetrac LSD

Last edited by ahull; 06-22-2013 at 10:11 AM.
Reply With Quote
  #12  
Old 06-22-2013, 12:01 PM
GoForthFast GoForthFast is offline
Officially Welcomed to the 'Fest
Location: New York
 
Join Date: Jul 2004
Posts: 2,324
Mein Auto: '04 330Ci 6-speed
Quote:
Originally Posted by Fast Bob View Post
Is this a SULEV car ?
+1

Let's get some feedback here.
Reply With Quote
  #13  
Old 06-24-2013, 07:02 AM
STS42 STS42 is offline
Registered User
Location: boston
 
Join Date: Jan 2013
Posts: 71
Mein Auto: 2005 330 cic
I had this happen at 51k on a trip. A bmw dealer replaced the fuel pump and it failed again, it turned out to be the fuel pump relay that my home dealer diagnosed.
Reply With Quote
  #14  
Old 06-24-2013, 07:51 AM
GoForthFast GoForthFast is offline
Officially Welcomed to the 'Fest
Location: New York
 
Join Date: Jul 2004
Posts: 2,324
Mein Auto: '04 330Ci 6-speed
Quote:
Originally Posted by STS42 View Post
it turned out to be the fuel pump relay that my home dealer diagnosed.
Don't forget in a pinch, can always swap wiith the horn relay to get running again.
Reply With Quote
  #15  
Old 06-27-2013, 12:46 PM
moemeadors moemeadors is offline
Registered User
Location: virginia
 
Join Date: Jun 2013
Posts: 8
Mein Auto: 2002 325ci convertible
my fuel pump problem was...erratic. annoyingly so. you can test at the harness and/or schrader valve on the fuel rail.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms