Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 1 Series / 2 Series > E82 / E88 1 Series (2008 - 2013)

E82 / E88 1 Series (2008 - 2013)
BMWs throw back to the iconic 2002, with a renewed form and function. The smallest car in BMW's line up but still packs a punch. Available in coupe or convertible, powered by either an inline 6 in the 128 or the twin turbo rocket sled 135.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-22-2013, 06:24 AM
MRjayr MRjayr is offline
Registered User
Location: Melbourne
 
Join Date: Dec 2010
Posts: 40
Mein Auto: E46 323i
Pls really need help 06 118i! INPA codes + Transmission!

Hi friends,

Just got the car back from the shop where a cylinder head gasket was changed. Now i plugged my OBD2 cable K+DCAN and scanned for some errors as i got the "Red Car on Lift" icon along with the red park brake light which wont go away even when park brake is down.

Now at this point the car shifts properly and smoothly no transmission problems yet...

Anyway scanned for errors using INPA - Loader E89x v1.07 under "Engine" tab and got the following errors;

2A59 - VVT Leading Sensor or Valvetronic Eccentric Shaft Sensor
Is this something i can replace? Or did the mechanic not put back together my top end properly after the cylinder head gasket replacement?

2E7C - BSD Wire Failure
Would explain the spare wire i found near my battery terminal...

2EBE - BSD from Generator Missing
Have a wire harness under my rear passenger seat that doesnt clip into anything could this be the missing generator?

2EFE - Engine Blower / Electric Fan
Makes sense now that my cooling fan has never came on. It does work though as ive tested it via INPA

2B63 - Camshaft Sensor Outlet or Camshaft Sensor 2 Exhaust
Again, Is this something i can replace? Or did the mechanic not put back together my top end properly after the cylinder head gasket replacement?

2F17 - Forced Switched EGS (Electronic Gearing System) or Engine Oil Temp too High.
If its gearbox related might explain why my car doesnt shift properly anymore. Explain more later...

2B9E - Energy Saving Mode Active
No idea on this one...

2B98 CDKNVRMON - plausibility monitoring of the RAM backup
This one came after i done the Adaptive Value reset on the gearbox i believe..

Error Log .xps File for DME/DDE Screenshot



Over to the Transmission Menu and "Gearbox Control Module GS19" tab.
Now this is where i think i might of f*cked something. I went and cleared all the adaptive values for the Transmission thinking this would give me smoother shifting.

It didnt! I now cant use DS, i can engage it but it wont shift up when i want to. In D it takes ages to shift into 2nd gear, i either have to redline it to shift or slowly buildup speed to approx 30km and then it will shift into 2nd while sitting at approx 3k RPM.
My assumption is that its in some sort of LIMP mode??

So in a desperate attempt to get the old settings i clicked on Read Memory (still under Gearbox Control Unit window)
and clicked all of the bellow one by one;

F1> Read LAR
F2> Read FLASH
F3> Read UIFM

Im not sure what that done

So with the problem still being there i went into the Error Memory (still under Gearbox Control Unit window) and got the following;

Pressed F1> Read Error Memory. No Errors

Pressed F3> Information Memory. 1 Error in Error Memory.

5113 info counter 2 - DME-forced highswitching
(could this mean forced high rpm gear changes?)
Error Log file for Transmission Screenshot



SOOO first things first!
I want my car to shift normal again!!! Please what do i need to do? If i need to provide more info please let me know.

OR if you can comment on any of the errors that would be appreciated too!

Soo many errors!

Thanks to all!
__________________
Reply With Quote
Ads by Google
  #2  
Old 06-22-2013, 05:19 PM
mr_bean mr_bean is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Mar 2009
Posts: 654
Mein Auto: 2000 328i
Take it back to the shop that replaced the head gasket. It seems as though they screwed something up and they should be liable to fix it.
Reply With Quote
  #3  
Old 06-22-2013, 06:33 PM
SilverX3's Avatar
SilverX3 SilverX3 is offline
Officially Welcomed to the 'Fest
Location: Australia
 
Join Date: Sep 2005
Posts: 2,748
Mein Auto: 130i & E92 325i, E90 SOLD
I need to buy a scanner too any recommendation..
__________________
Residence - StarTrek Enterprise
Job - Captain
Current Starship Fleet:
06 130i - ROCK SOLID Performer
07 320i - SOLD
08 E92 325i - Blue SOLD
Bicycles: Giant TCR Advanced Zero SOLD, Argon 18 Krypton, Argon 18E114, Trek Madone COMING
BOUGHT : MY11.5 X1 Xdrive25i

New car... Estoril Blue Car
Reply With Quote
  #4  
Old 06-23-2013, 12:34 AM
MRjayr MRjayr is offline
Registered User
Location: Melbourne
 
Join Date: Dec 2010
Posts: 40
Mein Auto: E46 323i
I bought mine off ebay. Works well. Just need to learn how to use the software properly.
http://www.ebay.com/itm/221217479096...84.m1439.l2649
__________________
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 1 Series / 2 Series > E82 / E88 1 Series (2008 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms