Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-30-2013, 05:39 PM
Brickenfist Brickenfist is offline
Registered User
Location: Rochester
 
Join Date: Mar 2013
Posts: 27
Mein Auto: 1985 325e
Light problems

My left turn signal isn't working. It doesn't flash, but it clicks rapidly. Every now and then though, it starts to work again. My right turn signal works fine.

My head light on the left side is also acting up. The bulb is fine (it doesn't seem blown at all and its still intact) but it doesn't turn on. I tried messing with the wires, and then it killed my car. I have it unplugged right now.

I'm stumped and have no idea what to do.
Reply With Quote
Advertisement
  #2  
Old 07-01-2013, 02:10 AM
Billwill Billwill is offline
Officially Welcomed to the 'Fest
Location: South Africa
 
Join Date: Oct 2009
Posts: 529
Mein Auto: BMW E30 318i 1991
Clean the contacts on your left turn signal or replace the socket and the bulb. If that does not help then the ground wire may be bad....add another lead to the ground terminal and fix this wire to a clean metal chassis place.

The headlight....as above and check fuses.

A bulb that "looks" intact is often not...sometimes there can be an intermittent bad connection inside the bulb itself!
Reply With Quote
  #3  
Old 07-01-2013, 03:27 PM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,698
Mein Auto: E23;E30;E38;E32;E34 +
+ 1 on above plus checking for damaged /broken wires and terminals.
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #4  
Old 07-06-2013, 11:41 AM
Brickenfist Brickenfist is offline
Registered User
Location: Rochester
 
Join Date: Mar 2013
Posts: 27
Mein Auto: 1985 325e
My turn signal started working again all of a sudden.... Anyway, I should have checked my headlights better. The left light turns on, and when I turn on my brights the left lights don't turn on, but both of the lights on the right turn on. I'm so confused. I will try cleaning and checking connections.
Reply With Quote
  #5  
Old 07-06-2013, 07:02 PM
First time's Avatar
First time First time is offline
INSANELY UNPREDICTABLE!
Location: in my house
 
Join Date: May 2010
Posts: 536
Mein Auto: 1984 318i
Light problems

Check the fuses. I believe the fuses numbered 1 and 2 are for the hi-beams. They should be 7.5amps.

If the connections/grounds/and fuses check out. Blame it on the signal stalk.


Sent from BimmerApp mobile app
Reply With Quote
  #6  
Old 07-09-2013, 12:36 AM
Brickenfist Brickenfist is offline
Registered User
Location: Rochester
 
Join Date: Mar 2013
Posts: 27
Mein Auto: 1985 325e
It looks like i don't have a fuse in #1 but borrowed another and that takes care of the hi beam problem. I just need to figure out why the right side doesn't turn on when I turn on my lights. Also, if I push down hard enough my left blinker works. Thoughts?
Reply With Quote
  #7  
Old 07-09-2013, 04:50 PM
First time's Avatar
First time First time is offline
INSANELY UNPREDICTABLE!
Location: in my house
 
Join Date: May 2010
Posts: 536
Mein Auto: 1984 318i
Light problems

Faulty signal stalk. Or loose connection at the stalk. Either way you need ot pull off the cover to investigate.

By right side meaning the right side parking lights dont come on?


Sent from BimmerApp mobile app
Reply With Quote
  #8  
Old 07-20-2013, 12:08 PM
Brickenfist Brickenfist is offline
Registered User
Location: Rochester
 
Join Date: Mar 2013
Posts: 27
Mein Auto: 1985 325e
Wow, so it was just another fuse problem. Fuse #14 was missing so now my low beams are working both sides. Now though, I can't start the car with that fuse in. When I start the car first then put the fuse in, the rpm fluctuates(spelling?).

Also, my left turn signal, if I push down enough, will work. Some sort of contact problem I'm guessing.
Reply With Quote
  #9  
Old 07-20-2013, 03:02 PM
toybuilder's Avatar
toybuilder toybuilder is offline
Officially Welcomed to the 'Fest
Location: Eastern Panhandle, WV
 
Join Date: Feb 2013
Posts: 664
Mein Auto: 89 325i 2dr&DucatiMonster
Do you know what the build date is on the car ? I have the factory electrical manuals for most of the E30's and most of the years/by build dates are different here and there.Let me know and I'll try and figure it out for you Fuse 14 causing the car not to start is strange to say the least.Hope to hear from you soon.
Reply With Quote
  #10  
Old 07-21-2013, 05:56 PM
Brickenfist Brickenfist is offline
Registered User
Location: Rochester
 
Join Date: Mar 2013
Posts: 27
Mein Auto: 1985 325e
I do not know what the date would be or how I would go about checking it.
Reply With Quote
  #11  
Old 07-23-2013, 12:59 AM
toybuilder's Avatar
toybuilder toybuilder is offline
Officially Welcomed to the 'Fest
Location: Eastern Panhandle, WV
 
Join Date: Feb 2013
Posts: 664
Mein Auto: 89 325i 2dr&DucatiMonster
Sorry I should have told you how to find it.If you open the drivers door there should be a MGF tag with info like weight and tire pressure but it also will have a build date for the car .
Reply With Quote
  #12  
Old 07-28-2013, 08:54 PM
romeomike's Avatar
romeomike romeomike is offline
Running life's race...
Location: Las Vegas
 
Join Date: Mar 2009
Posts: 301
Mein Auto: 91 318i
You can also plug in the last seven of your VIN at realoem.com and find the build month/year that way.
__________________
On Christ the solid Rock I stand, all other ground is sinking sand. (Edward Mote 1797-1874)
Reply With Quote
  #13  
Old 07-28-2013, 09:25 PM
toybuilder's Avatar
toybuilder toybuilder is offline
Officially Welcomed to the 'Fest
Location: Eastern Panhandle, WV
 
Join Date: Feb 2013
Posts: 664
Mein Auto: 89 325i 2dr&DucatiMonster
Wow, I thought looking at your car would be pretty easy ,guess I was mistaken.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms