Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 07-01-2013, 09:11 AM
crose6994 crose6994 is offline
Registered User
Location: New Jersey
 
Join Date: Mar 2013
Posts: 14
Mein Auto: 2008 328xi
Engine trouble. thoughts?

2008 328xi

hello, vehicle has been good to me except for this past week. when i accelerate the vehicle starts vibrating and the check engine light will come on and it will act as if its in some kind of limp mode. i will shut the car off and back on and the light is gone and its normal again for a few days. any ideas where to start looking? thanks
Reply With Quote
Advertisement
  #2  
Old 07-01-2013, 09:54 AM
floydarogers's Avatar
floydarogers floydarogers is offline
Pedant and Curmudgeon
Location: Renton, WA
 
Join Date: Oct 2010
Posts: 3,700
Mein Auto: 335d, 328d, Toyota T100
Quote:
Originally Posted by crose6994 View Post
2008 328xi

hello, vehicle has been good to me except for this past week. when i accelerate the vehicle starts vibrating and the check engine light will come on and it will act as if its in some kind of limp mode. i will shut the car off and back on and the light is gone and its normal again for a few days. any ideas where to start looking? thanks
As we tell everyone (and you would have found it if you had bothered to search): There are only several hundred things that could be wrong. Get the codes read then maybe we can help you.
Reply With Quote
  #3  
Old 07-01-2013, 10:02 AM
crose6994 crose6994 is offline
Registered User
Location: New Jersey
 
Join Date: Mar 2013
Posts: 14
Mein Auto: 2008 328xi
Quote:
Originally Posted by floydarogers View Post
As we tell everyone (and you would have found it if you had bothered to search): There are only several hundred things that could be wrong. Get the codes read then maybe we can help you.
floydarogers, thank you for your reasonable response. i have been on this site for quite awhile with very few posts. all i do is search and read. just curious because its just seems odd how its an on and off again issue. figured someone might have a clue and or the same issues.
Reply With Quote
  #4  
Old 07-01-2013, 10:15 AM
3two8iguy's Avatar
3two8iguy 3two8iguy is offline
Officially Welcomed to the 'Fest
Location: Somewhere between New York & Raleigh
 
Join Date: May 2013
Posts: 310
Mein Auto: 2011 E90 328i sedan
Quote:
Originally Posted by floydarogers View Post
As we tell everyone (and you would have found it if you had bothered to search): There are only several hundred things that could be wrong. Get the codes read then maybe we can help you.
A bit strong,wouldn't you say?
__________________
Life is a Journey,Enjoy your ride.

Last edited by 3two8iguy; 07-01-2013 at 10:16 AM.
Reply With Quote
  #5  
Old 07-01-2013, 10:24 AM
thekurgan's Avatar
thekurgan thekurgan is offline
Bad Lieutenant
Location: Sacramento, CA
 
Join Date: Jul 2007
Posts: 5,850
Mein Auto: S65B40 Powered
Quote:
Originally Posted by 3two8iguy View Post
A bit strong,wouldn't you say?
No.
__________________

08 E90M3 6MT Alpinweiss/Schwartz/BMW Pedals/Dinan Exhaust/BMW Alcantara wheel
Reply With Quote
  #6  
Old 07-01-2013, 10:43 AM
3two8iguy's Avatar
3two8iguy 3two8iguy is offline
Officially Welcomed to the 'Fest
Location: Somewhere between New York & Raleigh
 
Join Date: May 2013
Posts: 310
Mein Auto: 2011 E90 328i sedan
Quote:
Originally Posted by thekurgan View Post
no.
"No soup for you"....
__________________
Life is a Journey,Enjoy your ride.
Reply With Quote
  #7  
Old 07-01-2013, 10:45 AM
thekurgan's Avatar
thekurgan thekurgan is offline
Bad Lieutenant
Location: Sacramento, CA
 
Join Date: Jul 2007
Posts: 5,850
Mein Auto: S65B40 Powered
Quote:
Originally Posted by 3two8iguy View Post
"no soup for you"....
There is such a wealth of information here and searching WILL yield some results detailing what will actually BE helpful in self-diagnosing an issue. If there is a light, there is a code somewhere, it must be read. As floyd mentioned, there are so many variables to take into consideration when diagnosing these issues; the thread can become huge and really unhelpful.

Too hot for soup here anyway
__________________

08 E90M3 6MT Alpinweiss/Schwartz/BMW Pedals/Dinan Exhaust/BMW Alcantara wheel
Reply With Quote
  #8  
Old 07-02-2013, 11:24 PM
sptt144 sptt144 is offline
Officially Welcomed to the 'Fest
Location: Orange County, Ca.
 
Join Date: Aug 2012
Posts: 1,107
Mein Auto: 2009 335i
Bump

Last edited by sptt144; 07-03-2013 at 01:18 AM.
Reply With Quote
  #9  
Old 07-02-2013, 11:29 PM
sptt144 sptt144 is offline
Officially Welcomed to the 'Fest
Location: Orange County, Ca.
 
Join Date: Aug 2012
Posts: 1,107
Mein Auto: 2009 335i
The car is struggling under certain conditions...if it is, you have an ignition or fuel issue but my bet is on the coils (they are know to be defective) or injectors. My toss at you is a bad coil(s), or injector (because I had the same problem, especially when it got cold outside). This will cause the car to struggle with the limp mode kicking in. Stop and restart and you are good, right? I have a 94.37% "guess right" success ratio vs. code reading Please let me know if I'm right so I can adjust me Guess Rate Success % upwards again when you find out. Don't rely on silly old expensive code readers. Cal? Calwater? What is your input here sir?
Reply With Quote
  #10  
Old 07-03-2013, 12:04 PM
crose6994 crose6994 is offline
Registered User
Location: New Jersey
 
Join Date: Mar 2013
Posts: 14
Mein Auto: 2008 328xi
Quote:
Originally Posted by sptt144 View Post
The car is struggling under certain conditions...if it is, you have an ignition or fuel issue but my bet is on the coils (they are know to be defective) or injectors. My toss at you is a bad coil(s), or injector (because I had the same problem, especially when it got cold outside). This will cause the car to struggle with the limp mode kicking in. Stop and restart and you are good, right? I have a 94.37% "guess right" success ratio vs. code reading Please let me know if I'm right so I can adjust me Guess Rate Success % upwards again when you find out. Don't rely on silly old expensive code readers. Cal? Calwater? What is your input here sir?

thank you very much for your response. i was going back and fourth with bmw because the light went off so naturally they say nothing is wrong. day 3 and they are still trying to get it come back on.
Reply With Quote
  #11  
Old 07-03-2013, 12:14 PM
tturedraider's Avatar
tturedraider tturedraider is offline
Freedom isn't free!!
Location: Chicago, north shore (via Tennessee & Texas)
 
Join Date: Nov 2005
Posts: 15,324
Mein Auto: '06 Sonora/Beige 330i :-)
Quote:
Originally Posted by crose6994 View Post
2008 328xi

hello, vehicle has been good to me except for this past week. when i accelerate the vehicle starts vibrating and the check engine light will come on and it will act as if its in some kind of limp mode. i will shut the car off and back on and the light is gone and its normal again for a few days. any ideas where to start looking? thanks
Sounds a lot like a failing ignition coil. Pretty easy diy.
__________________

"People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf." -- Geo. Orwell

2006 330i Sonora w/ ActiveAutoWerke flash tune :-)
2004 330i ZHP Imola/NB - missed
2000 328i TiAg - gone but not forgotten

** Join the BMW CCA www.bmwcca.org
member #388003 - Use me as a referral & you could win a one day ///M Driving School!! **
Reply With Quote
  #12  
Old 07-03-2013, 12:20 PM
ladderman ladderman is offline
Registered User
Location: Boston,Ma.
 
Join Date: May 2012
Posts: 47
Mein Auto: 08 Acura TLS 03 Cic
Know it all's

Quote:
Originally Posted by crose6994 View Post
floydarogers, thank you for your reasonable response. i have been on this site for quite awhile with very few posts. all i do is search and read. just curious because its just seems odd how its an on and off again issue. figured someone might have a clue and or the same issues.

Don't you just love it when one of these know it all's scold you for asking a question?
Tell him to go into the men's room and get a hold of himself.
Ladderman

Last edited by ladderman; 07-03-2013 at 12:22 PM.
Reply With Quote
  #13  
Old 07-03-2013, 12:57 PM
thekurgan's Avatar
thekurgan thekurgan is offline
Bad Lieutenant
Location: Sacramento, CA
 
Join Date: Jul 2007
Posts: 5,850
Mein Auto: S65B40 Powered
Quote:
Originally Posted by ladderman View Post
Don't you just love it when one of these know it all's scold you for asking a question?
Tell him to go into the men's room and get a hold of himself.
Ladderman
Scolding?

I read the response as "don't throw away your money on parts until you get a definitive answer by getting the code read"; maybe you're a little too sensitive?
__________________

08 E90M3 6MT Alpinweiss/Schwartz/BMW Pedals/Dinan Exhaust/BMW Alcantara wheel

Last edited by thekurgan; 07-03-2013 at 01:03 PM. Reason: bad speller
Reply With Quote
  #14  
Old 07-03-2013, 03:25 PM
floydarogers's Avatar
floydarogers floydarogers is offline
Pedant and Curmudgeon
Location: Renton, WA
 
Join Date: Oct 2010
Posts: 3,700
Mein Auto: 335d, 328d, Toyota T100
Quote:
Originally Posted by crose6994 View Post
... just curious because its just seems odd how its an on and off again issue. figured someone might have a clue and or the same issues.
Quote:
Originally Posted by tturedraider View Post
Sounds a lot like a failing ignition coil. Pretty easy diy.
Ignition coil might be it, might be spark plug. More remotely, failing knock sensor, camshaft position sensor. Too bad no codes.

Back in early '90s, had a weird problem. Had to test drive with the tech in the car for them to figure it out, as no codes were set (back before OBD II). We're a little better off now, but only if codes are set and read. Hope you find it.
Reply With Quote
  #15  
Old 07-03-2013, 03:43 PM
ladderman ladderman is offline
Registered User
Location: Boston,Ma.
 
Join Date: May 2012
Posts: 47
Mein Auto: 08 Acura TLS 03 Cic
Too sensitive?

Quote:
Originally Posted by thekurgan View Post
Scolding?

I read the response as "don't throw away your money on parts until you get a definitive answer by getting the code read"; maybe you're a little too sensitive?
Too sensitive, I don't think so. I read the post as a condescending reply to a guy that had a legitimate problem. You could sense the exasperation in his answer. How about this? If it is such a major problem to answer a person civilly, then just refrain from typing out a reply.
You must own a BMW !
Reply With Quote
  #16  
Old 07-03-2013, 04:55 PM
thekurgan's Avatar
thekurgan thekurgan is offline
Bad Lieutenant
Location: Sacramento, CA
 
Join Date: Jul 2007
Posts: 5,850
Mein Auto: S65B40 Powered
Quote:
Originally Posted by ladderman View Post
Too sensitive, I don't think so. I read the post as a condescending reply to a guy that had a legitimate problem. You could sense the exasperation in his answer. How about this? If it is such a major problem to answer a person civilly, then just refrain from typing out a reply.
You must own a BMW !
.. but there is NO answer, that's the point. The reply was informative to get him the fastest answer and save the most money, while your post added nothing to the discussion and was meant to be negative.

I've owned many BMWs, I have participated for years ... because .... this is a bmw board.
__________________

08 E90M3 6MT Alpinweiss/Schwartz/BMW Pedals/Dinan Exhaust/BMW Alcantara wheel
Reply With Quote
  #17  
Old 07-03-2013, 05:49 PM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,007
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by sptt144 View Post
The car is struggling under certain conditions...if it is, you have an ignition or fuel issue but my bet is on the coils (they are know to be defective) or injectors. My toss at you is a bad coil(s), or injector (because I had the same problem, especially when it got cold outside). This will cause the car to struggle with the limp mode kicking in. Stop and restart and you are good, right? I have a 94.37% "guess right" success ratio vs. code reading Please let me know if I'm right so I can adjust me Guess Rate Success % upwards again when you find out. Don't rely on silly old expensive code readers. Cal? Calwater? What is your input here sir?

Common 328i issue: VANOS Solenoids

But is it the answer? Will it cure your ill?

Yup, ya gotta read yer codes t'see if you're homin' in. That means a code reader capable of reading all the codes BMW has to offer...and then some! I recommend: Bavarian Technic -- for extra goodness, insist on the Beowulf Edition.

Ah! You are King of Geats, but keep a sharp eye for dragons....
Reply With Quote
  #18  
Old 07-03-2013, 08:02 PM
Pilgrim Pilgrim is offline
Officially Welcomed to the 'Fest
Location: Fort Collins, CO
 
Join Date: Aug 2006
Posts: 475
Mein Auto: 2009 328iX Coupe
Read

the

codes.

Then report back.These doggone cars are so electronic that you need to use the information available to you via the codes.

Lots of guesses can be offered, but that's all they are until you get more information.
__________________
1983 Datsun 280ZX Turbo
2009 BMW 328iX Coupe
2007 Nissan Murano

Last edited by Pilgrim; 07-03-2013 at 08:04 PM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms