Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #51  
Old 08-09-2013, 01:00 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
Alrighty boys and girls.. need a little help here if anyone can..

I have two issues

1. USB drive is not showing up (the entire "external devices" menu is gone). I think it disappeared when I re-coded the CIC back to default settings (default for my FA/VO that is)

2. When I receive a call, the ringing sound comes through the speakers, but the caller info doesn't show up on the iDrive and there's no "answer / decline" option like there was on the MASK system

Any ideas on how to fix these? I noticed when I plugged my phone into the USB port, it charged.. so that makes me thin it's possible the cable is fine after all and it's just a coding issue.

HELP!

If anyone can provide a copy of their CIC FSW_PSW file and/or the file for their entire car if you have a CIC system (retrofit or not), I would be quite appreciative!
Reply With Quote
  #52  
Old 08-12-2013, 04:56 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
Quote:
Originally Posted by schpenxel View Post
Alrighty boys and girls.. need a little help here if anyone can..

I have two issues

1. USB drive is not showing up (the entire "external devices" menu is gone). I think it disappeared when I re-coded the CIC back to default settings (default for my FA/VO that is)

2. When I receive a call, the ringing sound comes through the speakers, but the caller info doesn't show up on the iDrive and there's no "answer / decline" option like there was on the MASK system

Any ideas on how to fix these? I noticed when I plugged my phone into the USB port, it charged.. so that makes me thin it's possible the cable is fine after all and it's just a coding issue.

HELP!

If anyone can provide a copy of their CIC FSW_PSW file and/or the file for their entire car if you have a CIC system (retrofit or not), I would be quite appreciative!

Figured it out

On #1 - I'm just an idiot, lol. The USB port in the glovebox just gives you an "import music" option, not a menu for external devices. So, it's working. In addition, the cable I'm using (still the video cable with sides shaved off to make it fit the USB port) actually works. I had previously reported it did not work.

On #2 - I'm not sure what I changed, but it's fixed. I'm going to post up all my CIC and TCU files later in case anyone ever needs them
Reply With Quote
  #53  
Old 08-12-2013, 04:59 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
More pictures from today.. My issue was that the unit was not getting a GPS signal. I knew the car had a GPS antenna because when I first installed a retrofit TCU, I found a menu where it was showing my GPS coordinates.

So, I pulled the CIC out and read the resistance through the GPS wire.. It was an open circuit. Tried using the "diode" test mode and also got nothing.

Next I pulled the cover off the TCU in the trunk and found a GPS wire connected to the TCU, but that's not the cool part.. the cool part is that there was another GPS wire, with the opposite ended connector, right beside the TCU. I traced that wire and it ran to the CIC!! I unplugged the GPS wire from the TCU and hooked it to the wire that goes to the CIC. Read out the resistance again and there was continuity!

Car is parked under a bunch of trees right now so not sure if that will fix it.. but maybe

Pics:

I had an aftermarket antenna, but ended up not using it


Routing aftermarket GPS wire (ended up removing it)


Routing aftermarket antenna (ended removing this after I found the wire in the trunk..)



Sitting on dash just trying to get a signal


I'm still in London, lol


Here's the TCU.. blue wire is GPS. other blue wire to the right of the TCU goes to the CIC


I've found NO mention of this wire before..



But they plug right in..



GPS wire up front




Here's the big connector on the TCU. I'm working on a TCU to Combox retrofit harness so wanted to take a picture of this. I'll make a DIY thread after I get all the parts in.

Last edited by schpenxel; 08-12-2013 at 05:02 PM.
Reply With Quote
  #54  
Old 08-13-2013, 02:17 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
tada! Everything is now working correctly (except I need to update my maps!)

Started driving this morning and a few miles down the road my position jumped from London to the most western point possible while using the European maps.. When I went into the mode where you can look around on the map, it showed the cursor thing in my actual location!

Reply With Quote
  #55  
Old 08-13-2013, 04:50 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
Here are my FSW_PSW files for everything involved in this retrofit in case anyone ever needs them.

In reality just the CIC file and maybe the TCU I THINK are all you need to change.. but attaching them all anyways.
Attached Files
File Type: pdf cas.pdf (22.8 KB, 186 views)
File Type: pdf cic.pdf (32.2 KB, 281 views)
File Type: pdf fas.pdf (14.2 KB, 97 views)
File Type: pdf ihka.pdf (14.0 KB, 109 views)
File Type: pdf kombi.pdf (20.4 KB, 105 views)
File Type: pdf tcum.pdf (14.3 KB, 96 views)

Last edited by schpenxel; 08-13-2013 at 04:55 PM.
Reply With Quote
  #56  
Old 08-17-2013, 06:39 AM
Carter650i Carter650i is offline
Officially Welcomed to the 'Fest
Location: Mia
 
Join Date: Feb 2013
Posts: 230
Mein Auto: 650i
dude you are awesome I did mine just yesterday I did the installed my self but I didn't do the coding a friend of mine did it for me. However I'm having some issues my cic front plate doesn't lid off no orange light from the buttons and stuff. I'm also having problem getting the fsc code for my car I don't know the donor cic vin number, someone said I can provide 1b files from cic so they could generate the fsc code I still don't know and my friends doesn't know how to do that. is there a way I can read the vin number from the cic? Lastly I tried to use the usb inside the glove box to update map. I know I don't have the code yet, but it doesn't automatically prompt me to update the map as it should, it looks as if there no power to the usb but then again I used it to import musics to the hdd already so I know it works and connected. any ideas?
Reply With Quote
  #57  
Old 08-17-2013, 06:41 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
Yeah I can answer all of those questions. But I'm driving right now so give me a few hours
Reply With Quote
  #58  
Old 08-17-2013, 06:42 AM
Carter650i Carter650i is offline
Officially Welcomed to the 'Fest
Location: Mia
 
Join Date: Feb 2013
Posts: 230
Mein Auto: 650i
oh Thank God!! I love you dude.. NO ****. lol
Reply With Quote
  #59  
Old 08-17-2013, 11:00 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
Quote:
Originally Posted by Carter650i View Post
dude you are awesome I did mine just yesterday I did the installed my self but I didn't do the coding a friend of mine did it for me. However I'm having some issues my cic front plate doesn't lid off no orange light from the buttons and stuff. I'm also having problem getting the fsc code for my car I don't know the donor cic vin number, someone said I can provide 1b files from cic so they could generate the fsc code I still don't know and my friends doesn't know how to do that. is there a way I can read the vin number from the cic? Lastly I tried to use the usb inside the glove box to update map. I know I don't have the code yet, but it doesn't automatically prompt me to update the map as it should, it looks as if there no power to the usb but then again I used it to import musics to the hdd already so I know it works and connected. any ideas?
To get the donor VIN, you'll need whoever did the coding to open tools 32. Then open the job "CICR". Somewhere in there you will see c_fg_lesen. Double click this (lesen means read, so you can more or less click on those without too much worry). This will give you the last 7 of the VIN the CIC came out of. C248467 in my case.

On the USB update--there's two "catches" with that. First one is there are actually two versions of the CIC, the earliest CIC units have 40GB hard drives and CANNOT be updated except by a dealer. The rest have an 80GB hard drive. On the 80GB hard drive models, having the option to update maps via USB is dependent on which version of software the CIC has on it. The software on mine was too old to update via USB, so I had to use 2012 DVD's instead.

I would recommend downloading a 2012 map update DVD and burning that (you'll need to get some dual layer DVD's) and put that in the drive and see if it tries to start updating.

PM me and I'll give you a link to download the DVD's. I can also give you a recommendation on where to get the FSC codes. It's ~ $50 for a one time use code, or $100 for a lifetime code (for that VIN/Region) if I remember correctly.

Also, on the lighting, there's a wire that some cars don't have that powers the lights on the CIC.. you'll have to buy the pins and run the wire off of the lights on the hazard/door lock button. Hold on and I'll find a post on it.


Last edited by schpenxel; 08-17-2013 at 11:07 AM.
Reply With Quote
  #60  
Old 08-17-2013, 11:09 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
http://www.bmwcoding.com/showthread....hlight=buttons for the wiring for lights on the buttons
Reply With Quote
  #61  
Old 08-17-2013, 11:10 AM
Carter650i Carter650i is offline
Officially Welcomed to the 'Fest
Location: Mia
 
Join Date: Feb 2013
Posts: 230
Mein Auto: 650i
thank you so much, the cic has an 80 gb hard drive could it be that because I use a 300gb external hdd to do it instead of the 16 or 32gb thumps drive as everyone else suggested, could that be the reason? also the front panel of the cic doesn't lid at night or anytime for that matter.
Reply With Quote
  #62  
Old 08-17-2013, 11:12 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
Yeah, just posted the link on how to fix the lights..

and yeah, I've heard varying results on trying to use an external drive like that.. I really doubt the CIC provides enough power to run a drive like that

The update should fit on a 32gb flash drive so give that a shot first
Reply With Quote
  #63  
Old 08-17-2013, 11:18 AM
Carter650i Carter650i is offline
Officially Welcomed to the 'Fest
Location: Mia
 
Join Date: Feb 2013
Posts: 230
Mein Auto: 650i
Yes I just saw the link sorry for the quickly replied I just wanted to catch you online before you log off again.. haha... the problem with the link you sent me its a bit confusing , I hate to be that guy but I rather be safe than sorry, could you please just explain it to me real quick? thank you.. as for the thump drive I will buy one today and try with as you suggested.
Reply With Quote
  #64  
Old 08-17-2013, 11:36 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
Basically on this plug.. the pin the yellow line points to needs to be hooked to something that has power on it when the lights are on. The door lock/hazard button is an easy place to use for this

Reply With Quote
  #65  
Old 08-17-2013, 11:46 AM
Carter650i Carter650i is offline
Officially Welcomed to the 'Fest
Location: Mia
 
Join Date: Feb 2013
Posts: 230
Mein Auto: 650i
oh ok, I got it.. Thank you so much very helpful....now I Have 2 cic head unit one US version the other one Europe. I ended up installing the Europe version because regardless of what I do with my install I could not get the US version to come up on the screen I can hear the hard drive going but no pictures or nothing. Now my question is can I use the US spec as a core and get a brand new cic would I be able to code it to my car? also you said something on one of your previous post about the 8 buttons on the EU specs after fully coded number 7 and 8 works as if they were AM/FM and MODE button in my car. so can I just swipe the front panel of the US to EU if possible how? or is it possible to remove the button from the US spec speaking of the AM/FM and MODE and put them on the EU front speaking of buttons 7 and 8.. I hope I make senses.. haha
Reply With Quote
  #66  
Old 08-17-2013, 11:50 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
Not sure about getting another one. Coding wise you can make either unit behave like either version (meaning you can make buttons 7/8 work as mode and am/fm if you want or like regular memory buttons). I'll have to find the code you have to change to do it when I get home. It's pretty obvious (it's says something about 6 or 8 buttons in NCS expert) though, just have to find it

No idea on switching out the fronts.. You probably can though
Reply With Quote
  #67  
Old 08-17-2013, 11:56 AM
Carter650i Carter650i is offline
Officially Welcomed to the 'Fest
Location: Mia
 
Join Date: Feb 2013
Posts: 230
Mein Auto: 650i
no I don't want it like regular memory, I like it that way I just want to change the plate or change the button to say am/fm and mode...YOU ARE VERY HELPFUL. I TRULLY APPRECIATE YOUR HELP SIR. Don't go to far I may come back later with some more questions. lol
Reply With Quote
  #68  
Old 08-17-2013, 11:57 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
lol no problem. Sorry to be so short, typing on phone.

I'm not sure how the faceplate is connected wiring wise, if it's easy to unhook the wiring it should be easy enough to swap out
Reply With Quote
  #69  
Old 08-17-2013, 12:30 PM
Carter650i Carter650i is offline
Officially Welcomed to the 'Fest
Location: Mia
 
Join Date: Feb 2013
Posts: 230
Mein Auto: 650i
I think so too, I will look into it my self and report back, although I'm making plan to sell the US specs so I don't know.
Reply With Quote
  #70  
Old 08-17-2013, 12:47 PM
Carter650i Carter650i is offline
Officially Welcomed to the 'Fest
Location: Mia
 
Join Date: Feb 2013
Posts: 230
Mein Auto: 650i
By the way how much your cic retrofit cost you? all together mine cost me $795.00 USD it took me 2 months to get that kind of deal..lol but i don't care. well worth it, under 1k compared to the other guys out here.
Reply With Quote
  #71  
Old 08-17-2013, 04:49 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
Ended up at $1300 total..

That us version cic is worth a lot if it works btw, they are fairly rare
Reply With Quote
  #72  
Old 08-17-2013, 05:17 PM
Carter650i Carter650i is offline
Officially Welcomed to the 'Fest
Location: Mia
 
Join Date: Feb 2013
Posts: 230
Mein Auto: 650i
yea i know.. hey man i need help again, me and my coder cant get my passenger ac to work independently like im missing some code or something can you help, the passenger side is grey out. unlike your picture
Reply With Quote
  #73  
Old 08-17-2013, 05:17 PM
Carter650i Carter650i is offline
Officially Welcomed to the 'Fest
Location: Mia
 
Join Date: Feb 2013
Posts: 230
Mein Auto: 650i
if you can call ill give you my number, we are trying to code it right now.
Reply With Quote
  #74  
Old 08-17-2013, 05:19 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
Mine doesn't work either I don't think. There something in ihka you can set to dual that might do it but I haven't tried it yet, so not much help on that one
Reply With Quote
  #75  
Old 08-17-2013, 05:21 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,208
Mein Auto: 2004 545i
See if it's set to nicht_aktiv and if so try changing it
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms