Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Closed Thread
 
Thread Tools Display Modes
  #101  
Old 08-30-2013, 08:53 PM
KingSilverback KingSilverback is offline
The Silverback
Location: Wisconsin
 
Join Date: Feb 2012
Posts: 448
Mein Auto: 2006 750Li
Re: BMW 90C Thermostat For N62, N63, N73 Engines

I don't mean to be a prick here but can you take this convo to private message please Ultimate_drivin? We're going a bit off track here.

Sent from BimmerApp mobile app
  #102  
Old 08-30-2013, 08:55 PM
Ultimate_drivin Ultimate_drivin is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Apr 2013
Posts: 111
Mein Auto: Bmw 645
I apologize to all of u that I'm doing this I'm trying to see how hot my car is running so after I change my tsat then I see difference so I can post here too
  #103  
Old 08-30-2013, 10:35 PM
SuperSnoop's Avatar
SuperSnoop SuperSnoop is offline
Officially Welcomed to the 'Fest
Location: Austin, Texas
 
Join Date: Aug 2012
Posts: 559
Mein Auto: 2007 760Li
BMW 90C Thermostat For N62, N63, N73 Engines

Quote:
Originally Posted by Ultimate_drivin View Post
I apologize to all of u that I'm doing this I'm trying to see how hot my car is running so after I change my tsat then I see difference so I can post here too
You should probably take this to a 6-series forum where people might actual know how to help you. The people here have given you some ideas, but your responses of "it didn't work" aren't helpful to get it figured out.


Sent from BimmerApp mobile app
  #104  
Old 09-02-2013, 05:10 AM
Thesatman Thesatman is offline
Officially Welcomed to the 'Fest
Location: Albuquerque, NM
 
Join Date: Mar 2013
Posts: 333
Mein Auto: 2008 750LI
Installed...not yet seeing the results I was hoping for. The car hovers around 99-100C when just idling with the a/c on. need to do some more driving. Also, anyone know the proper bleed procedure? I know the system is self-bleeding, but I also know there is a procedure. As of now I have just added more pure water and bmw coolant to the system by adding until the expansion tank was at the "max" level.
__________________

Sport Package, Rear Entertainment Package, Comfort Access, Cold Weather Package, Smoking Package, L7 High Def Audio
Mods = Powdercoated 149s, Black hood vent and kidneys, LED lighting update, BMW puddle lights (all doors), custom coding by "Triple_O_Coding" (including VIM), updated navi DVD from "PAPER", 90C hybrid thermostat.
  #105  
Old 09-02-2013, 08:15 AM
KingSilverback KingSilverback is offline
The Silverback
Location: Wisconsin
 
Join Date: Feb 2012
Posts: 448
Mein Auto: 2006 750Li
Re: BMW 90C Thermostat For N62, N63, N73 Engines

Quote:
Originally Posted by Thesatman View Post
Installed...not yet seeing the results I was hoping for. The car hovers around 99-100C when just idling with the a/c on. need to do some more driving. Also, anyone know the proper bleed procedure? I know the system is self-bleeding, but I also know there is a procedure. As of now I have just added more pure water and bmw coolant to the system by adding until the expansion tank was at the "max" level.
Read my first post. I posted the TIS instructions on how to bleed the radiator correctly, if you have air bubbles temp will get higher than it's supposed to. If you keep seeing high temps then you probably already have a leak somewhere most likely rear cover plate

Sent from BimmerApp mobile app
  #106  
Old 09-02-2013, 09:55 AM
First_745Li's Avatar
First_745Li First_745Li is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,433
Mein Auto: '03 745Li
Quote:
Originally Posted by Thesatman View Post
Installed...not yet seeing the results I was hoping for. The car hovers around 99-100C when just idling with the a/c on. need to do some more driving. Also, anyone know the proper bleed procedure? I know the system is self-bleeding, but I also know there is a procedure. As of now I have just added more pure water and bmw coolant to the system by adding until the expansion tank was at the "max" level.
Yea, I'm getting the same results. 99 at idle and 96-98 at highway speeds. I'm hoping its just air in the system. I totally missed KingSilverBack's updated thread on how to refill the system; so I have to go back and try to bleed the system. I noticed that the return stream into the coolant expansion tank is weak where as before it was a strong return back. Last night, I got air hissing out of the expansion tank when I opened the cap.

One other thing, I couldn't drain from the radiator b/c the stupid head of the plastic drain plug broken off and I couldn't get it out. So I lost what ever coolant when I disconnected the hose and tstat. There are no leaks , no leaks that I can see.
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold )
  #107  
Old 09-02-2013, 03:03 PM
PAPER's Avatar
PAPER PAPER is online now
CRISP & CLEAN
Location: on the moon
 
Join Date: Jul 2009
Posts: 3,004
Mein Auto: Ford Pinto
Quote:
Originally Posted by First_745Li View Post
Yea, I'm getting the same results. 99 at idle and 96-98 at highway speeds. I'm hoping its just air in the system. I totally missed KingSilverBack's updated thread on how to refill the system; so I have to go back and try to bleed the system. I noticed that the return stream into the coolant expansion tank is weak where as before it was a strong return back. Last night, I got air hissing out of the expansion tank when I opened the cap.

One other thing, I couldn't drain from the radiator b/c the stupid head of the plastic drain plug broken off and I couldn't get it out. So I lost what ever coolant when I disconnected the hose and tstat. There are no leaks , no leaks that I can see.


That's what my car runs at without this T-Sat in it .

FYI =
I installed 1 of these in someones car , followed TIS & bleed the system
& STILL NO CHANGE ...
Went with the owner to the dealer Saturday & had the Dealer Bleed the System
& STILL NO CHANGE ...
  #108  
Old 09-02-2013, 03:24 PM
First_745Li's Avatar
First_745Li First_745Li is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,433
Mein Auto: '03 745Li
Thanks for the feedback PAPER. Next Sunday's task was to drain the coolant and refill per TIS, Idk if I'll end up doing it if it doesn't help.
At this point, for $120 I'm down 6 degrees.
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold )
  #109  
Old 09-02-2013, 03:41 PM
KingSilverback KingSilverback is offline
The Silverback
Location: Wisconsin
 
Join Date: Feb 2012
Posts: 448
Mein Auto: 2006 750Li
Re: BMW 90C Thermostat For N62, N63, N73 Engines

Quote:
Originally Posted by PAPER View Post
That's what my car runs at without this T-Sat in it .

FYI =
I installed 1 of these in someones car , followed TIS & bleed the system
& STILL NO CHANGE ...
Went with the owner to the dealer Saturday & had the Dealer Bleed the System
& STILL NO CHANGE ...
You're forgetting to mention some people already have leaks. How is it possible my temp went from 103C to a high of 93C in city driving?
Obviously it works, but your system has to be sealed.

Sent from my SPH-L710 using BimmerApp mobile app
  #110  
Old 09-02-2013, 03:46 PM
PAPER's Avatar
PAPER PAPER is online now
CRISP & CLEAN
Location: on the moon
 
Join Date: Jul 2009
Posts: 3,004
Mein Auto: Ford Pinto
Quote:
Originally Posted by First_745Li View Post
Thanks for the feedback PAPER. Next Sunday's task was to drain the coolant and refill per TIS, Idk if I'll end up doing it if it doesn't help.
At this point, for $120 I'm down 6 degrees.


Not trying to kill your joy , But if it is a 90 degree T-Sat
then it is obviously not working if your still at 99 right ???


the owner of the car I installed it in is extremely Pissed & he thinks
that the T-Sat is just a stock T-Sat . I felt bad & still feel bad
cause I'm the person who told him about it . I personally don't
know if it is a custom made T-Sat or not , The only thing I know ,
is it is not performing the way it is suppose to according the the seller .

now before KingSilverback comes in here & say's he must have a
leak someplace , I can confirm he does not have any leaks , & he
just recently had his weep hole done along with the rear cover &
all hose's & anything to do with the coolant system including a new
water pump . I know this cause I went with him to All German Auto
dropped off his car , Then I drove back down with him to pick it up .

Last edited by PAPER; 09-02-2013 at 03:50 PM.
  #111  
Old 09-02-2013, 03:49 PM
PAPER's Avatar
PAPER PAPER is online now
CRISP & CLEAN
Location: on the moon
 
Join Date: Jul 2009
Posts: 3,004
Mein Auto: Ford Pinto
Quote:
Originally Posted by KingSilverback View Post
You're forgetting to mention some people already have leaks. How is it possible my temp went from 103C to a high of 93C in city driving?
Obviously it works, but your system has to be sealed.

Sent from my SPH-L710 using BimmerApp mobile app
SORRY but he has no leaks !!!

& also I can't speak for your car as I have not seen it for
myself , nor did I do the install . I can only speak On my
Bubby's car cause I personally drove it to check the TEMP
myself & saw no change when I bleed the system & again
after the dealer bleed the system .
  #112  
Old 09-02-2013, 03:52 PM
First_745Li's Avatar
First_745Li First_745Li is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,433
Mein Auto: '03 745Li
Quote:
Originally Posted by PAPER View Post
Not trying to kill your joy
There's no joy to kill, so no worries there.
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold )
  #113  
Old 09-02-2013, 04:31 PM
PAPER's Avatar
PAPER PAPER is online now
CRISP & CLEAN
Location: on the moon
 
Join Date: Jul 2009
Posts: 3,004
Mein Auto: Ford Pinto
Quote:
Originally Posted by KingSilverback View Post
You're forgetting to mention some people already have leaks. How is it possible my temp went from 103C to a high of 93C in city driving?
Obviously it works, but your system has to be sealed.

Sent from my SPH-L710 using BimmerApp mobile app


from my post above ...



now before KingSilverback comes in here & say's he must have a
leak someplace , I can confirm he does not have any leaks , & he
just recently had his weep hole done along with the rear cover &
all hose's & anything to do with the coolant system including a new
water pump . I know this cause I went with him to All German Auto
dropped off his car , Then I drove back down with him to pick it up .
  #114  
Old 09-02-2013, 04:45 PM
KingSilverback KingSilverback is offline
The Silverback
Location: Wisconsin
 
Join Date: Feb 2012
Posts: 448
Mein Auto: 2006 750Li
Re: BMW 90C Thermostat For N62, N63, N73 Engines

So let me get this straight, YOU the guy who was against my review of this thermostat recommended it to a good friend? Why would you recommend something you don't believe in to a good friend? And then you also pressure tested his system and you're sure there are no leaks? Cmon Bro First_745Li is down 6 degrees so quite obviously something changed.

Sent from BimmerApp mobile app
  #115  
Old 09-02-2013, 04:48 PM
GeoX750Li's Avatar
GeoX750Li GeoX750Li is offline
Officially Welcomed to the 'Fest
Location: Chicago, IL
 
Join Date: Apr 2013
Posts: 675
Mein Auto: 2010 750Li X-Drive
Has the Tstat been tested on the stove to see that it opens at 90C?
  #116  
Old 09-02-2013, 04:49 PM
KingSilverback KingSilverback is offline
The Silverback
Location: Wisconsin
 
Join Date: Feb 2012
Posts: 448
Mein Auto: 2006 750Li
Re: BMW 90C Thermostat For N62, N63, N73 Engines

Video of my temps with this thermostat.




Last edited by KingSilverback; 09-02-2013 at 06:56 PM.
  #117  
Old 09-02-2013, 05:11 PM
SuperSnoop's Avatar
SuperSnoop SuperSnoop is offline
Officially Welcomed to the 'Fest
Location: Austin, Texas
 
Join Date: Aug 2012
Posts: 559
Mein Auto: 2007 760Li
BMW 90C Thermostat For N62, N63, N73 Engines

Quote:
Originally Posted by GeoX750Li View Post
Has the Tstat been tested on the stove to see that it opens at 90C?
That's a great idea!

Based on the manufacture reviews, I can imagine there will be some variance in the quality and consistency of the thermostat.


Sent from BimmerApp mobile app
  #118  
Old 09-02-2013, 05:11 PM
kmatthews kmatthews is offline
Registered User
Location: Washington,DC
 
Join Date: Feb 2011
Posts: 72
Mein Auto: 750li
Quote:
Originally Posted by KingSilverback View Post
Video of my temps with this thermostat.





Sent from BimmerApp mobile app
No video...
  #119  
Old 09-02-2013, 05:13 PM
KingSilverback KingSilverback is offline
The Silverback
Location: Wisconsin
 
Join Date: Feb 2012
Posts: 448
Mein Auto: 2006 750Li
Re: BMW 90C Thermostat For N62, N63, N73 Engines

Quote:
Originally Posted by kmatthews View Post
No video...
I'll re check links when I get home, they work when I click em

Last edited by KingSilverback; 09-02-2013 at 05:54 PM.
  #120  
Old 09-02-2013, 05:14 PM
PAPER's Avatar
PAPER PAPER is online now
CRISP & CLEAN
Location: on the moon
 
Join Date: Jul 2009
Posts: 3,004
Mein Auto: Ford Pinto
Quote:
Originally Posted by KingSilverback View Post
So let me get this straight, YOU the guy who was against my review of this thermostat recommended it to a good friend? Why would you recommend something you don't believe in to a good friend? And then you also pressure tested his system and you're sure there are no leaks? Cmon Bro First_745Li is down 6 degrees so quite obviously something changed.

Sent from BimmerApp mobile app

never said I was against your review , I just wanted to inform
people of the company's feedback ( which is horrible ). I also
never said I recommended it to my friend , I said I was the 1
who told him about it . He made his own choice to purchase it
to try it out . In-fact I told him not to waste his money .
( the T-Sat just happen to come up in conversation )

As for pressure testing his system , After I bleed the system
according to TIS & we saw no change . I went with him to
a local radiator shop & was there with him when they pressure
tested it , & all was ok with no leaks . It not having any leaks
did not surprise me 1 bit considering he had the weephole ,
rear cover , water pump , & all hose's changed last month at
All German Auto when his coolant pipe went out .

As for First_745Li 6 degrees , I can't speak on it . As I stated before
all I can speak on is what I have personally seen or worked on myself .
It did not change in my Buddy's car & his car was running at 99 at idle
and 96-98 at highway speeds before we swapped out his T-Sat . Which
is the same Temp First_745Li say's his is running at after the swap .


EDIT =

Now if it is a 90 degree T-Sat , shouldn't it be
running a lot cooler than 99 degree's ???

Last edited by PAPER; 09-02-2013 at 05:21 PM.
  #121  
Old 09-02-2013, 05:15 PM
PAPER's Avatar
PAPER PAPER is online now
CRISP & CLEAN
Location: on the moon
 
Join Date: Jul 2009
Posts: 3,004
Mein Auto: Ford Pinto
Quote:
Originally Posted by KingSilverback View Post
Video of my temps with this thermostat.





Sent from BimmerApp mobile app

SORRY no video here ???
  #122  
Old 09-02-2013, 05:17 PM
PAPER's Avatar
PAPER PAPER is online now
CRISP & CLEAN
Location: on the moon
 
Join Date: Jul 2009
Posts: 3,004
Mein Auto: Ford Pinto
Quote:
Originally Posted by GeoX750Li View Post
Has the Tstat been tested on the stove to see that it opens at 90C?



Quote:
Originally Posted by SuperSnoop View Post
That's a great idea!

Based on the manufacture reviews, I can imagine there will be some variance in the quality and consistency of the thermostat.


Sent from BimmerApp mobile app

X2 that is a great idea ...
  #123  
Old 09-02-2013, 06:56 PM
KingSilverback KingSilverback is offline
The Silverback
Location: Wisconsin
 
Join Date: Feb 2012
Posts: 448
Mein Auto: 2006 750Li
Video of my temps with this thermostat.





Water boils at 100C, Thermostat looks very open to me


Last edited by KingSilverback; 09-02-2013 at 06:59 PM.
  #124  
Old 09-03-2013, 05:42 AM
Thesatman Thesatman is offline
Officially Welcomed to the 'Fest
Location: Albuquerque, NM
 
Join Date: Mar 2013
Posts: 333
Mein Auto: 2008 750LI
Alright...here is MY (unbiased) review. First off, let me say this is just what I have done and what I have experienced. The thermostat is installed in my 2008 750. Upon receipt of the thermostat I noticed that is looks pretty much the same as stock. I did notice that the connector on mine was 90 degrees counter-clockwise from where my stock one is. I opted to NOT modify my stock thermostat and just installed this new one. My initial indications were temperatures around 99-100C. Now after doing the proper bleed procedure the temperatures have come down a bit. If I do not use the air conditioner then I can typically get temps around 93-94C. Now with the A/C on it takes it up to around 96-98C. My biggest issue with the thermostat right now is that it is giving me a Check Engine Light. I read the errors with INPA and sure enough it shows thermostat. I reset it and it came back on the next drive. I have no leaks in my cooling system. I may have to do the hybrid mod in order to get rid of the CEL. Maybe mine is just a defective one and the seller will send me a replacement? I obviously still have some more testing to do but there IS some difference from stock.
__________________

Sport Package, Rear Entertainment Package, Comfort Access, Cold Weather Package, Smoking Package, L7 High Def Audio
Mods = Powdercoated 149s, Black hood vent and kidneys, LED lighting update, BMW puddle lights (all doors), custom coding by "Triple_O_Coding" (including VIM), updated navi DVD from "PAPER", 90C hybrid thermostat.
  #125  
Old 09-03-2013, 05:57 AM
dolfan13's Avatar
dolfan13 dolfan13 is offline
Officially Welcomed to the 'Fest
Location: lexington,ky usa
 
Join Date: Jan 2011
Posts: 938
Mein Auto: 545i
I've had two thermostat faults that were low temp with my self modded unit.Thats in 20k miles.Im basically running same temps as above.Interesting why the faults occur irregularly,maybe time to minimum temperature effects the fault?

Last edited by dolfan13; 09-03-2013 at 06:08 AM.
Closed Thread

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms