Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 11-11-2013, 06:54 PM
boodala boodala is offline
Registered User
Location: TORONTO
 
Join Date: Nov 2013
Posts: 6
Mein Auto: 2005 X5 3.0
Electrical issue

Hello all...this is my first post! I've read so much valuable information on this forum and now hope I can get some help on my issue.
2005 x5 3.0 The 4x4 warning light is on. It used to go off with the left, right, left sequence but not anymore.
bigger issue is...For the last two weeks my seatbelt and airbag warning lights would stay on even though I have my belt clipped in. The annoying chime would drive me nuts.
Today i noticed something very odd. Whenever I moved my sunlight visor the airbag light would go on and off. If i opened the mirror, all my lights would start flickering interior and headlights. The radio would go off. Wipers stopped working(it was raining)
I took out the visor and cleaned the wire connection with CRC spray. The problem went away but came back the same day.
Any help on this?
Reply With Quote
Ads by Google
  #2  
Old 11-11-2013, 07:39 PM
puddinboo puddinboo is offline
Officially Welcomed to the 'Fest
Location: on earth
 
Join Date: Jul 2013
Posts: 364
Mein Auto: 2003 BMW X5
did you check your battery voltage and do a load test on battery? whats the output of the alternator? i have ready alot on these forums about that a bad batery or alt can cause some weird electrical issues.
__________________
2003 X5 3.0i
Reply With Quote
  #3  
Old 11-11-2013, 08:36 PM
Zulu95's Avatar
Zulu95 Zulu95 is online now
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 844
Mein Auto: 2001 X5 3.0L
Might want to check the ignition switch as it can cause a host of problems.
Reply With Quote
  #4  
Old 11-12-2013, 07:27 AM
boodala boodala is offline
Registered User
Location: TORONTO
 
Join Date: Nov 2013
Posts: 6
Mein Auto: 2005 X5 3.0
Any idea why manipulating my visor and it's mirror would cause these issues??!!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms