Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 08-31-2013, 06:36 AM
Nebmwowner Nebmwowner is offline
Registered User
Location: Germany
 
Join Date: Aug 2013
Posts: 3
Mein Auto: 1995 BMW 520i
Overheating! Electric cooling fan in front of radiator not working.

Hello! I have a 1995 BMW 520i. It's been overheating for the last couple weeks now. I've replaced my fan clutch and my thermostat. My cooling fan in front of my radiator does not work. It works when i jump the wires but only on high. I've researched it and apparently i need a new resistor. Another thing the car oveheats to red but the car stays in the middle and below middle when the defrost is on. So i can drive my car no problem with defrost on but it gets pretty hot in the middle of the day when the defrost is blowing scolding heat. So i've ordered the resistor. I was just hoping someone can give me any other options for my problem. Thank you ahead of time! This is my first time owning a european car and also my first thread!
Reply With Quote
Advertisement
  #2  
Old 08-31-2013, 04:48 PM
travs750li travs750li is offline
Registered User
Location: CA
 
Join Date: Apr 2013
Posts: 19
Mein Auto: 750Li
You replaced the thermostat and water pump. Got to make sure you bleed the system. This is a very common problem for our series. I have dealt with the same thing. I replaced head gasket, thermostat, and water pump, and hoses. I never bled the system and it over heated again. Once I bled the system, good to go.
Reply With Quote
  #3  
Old 08-31-2013, 10:57 PM
Nebmwowner Nebmwowner is offline
Registered User
Location: Germany
 
Join Date: Aug 2013
Posts: 3
Mein Auto: 1995 BMW 520i
I didnt replace the water pump yet. I've been trying to bleed the system. This is the way i've been doing it. i top off the coolant and close the radiator cap go drive it around town get the temp up and bring it to my garage which has a bit of an incline and open the bleeder valve on it until i see no bubbles come out of it while the vehicle is running. Is that the best way or even the right way to bleed it? How many times should it take? i've heard of the water pumps having a plastic impellar inside them. You think i should take my water pump and take a look on the inside and see if it's destroyed?
Reply With Quote
  #4  
Old 09-01-2013, 07:34 PM
ThoreauHD ThoreauHD is offline
Officially Welcomed to the 'Fest
Location: Virginia
 
Join Date: Feb 2006
Posts: 682
Mein Auto: 02/1994 530i 8cylinder
Overheating! Electric cooling fan in front of radiator not working.

The aux fan resistor is $20 at bavauto. Easy to replace.


Sent from BimmerApp mobile app
Reply With Quote
  #5  
Old 09-03-2013, 02:07 PM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,423
Mein Auto: E23;E30;E38;E32;E34 +
Check the switch for the fan on the radiator as well. You dont have to drive to bleed. As long as it is hot (working temp) you can be stationary with the bleed valve open. Next thing would be radiator flow (blocked core) tests.
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #6  
Old 09-06-2013, 11:47 AM
Nebmwowner Nebmwowner is offline
Registered User
Location: Germany
 
Join Date: Aug 2013
Posts: 3
Mein Auto: 1995 BMW 520i
YESSSSSSSSSSSSSSSS!!!!!!!!!!!!!!!!!!!!! So finally!!!!!!!!!!!!!!!!!!!!!!!!!! The water pump!!!!!!!!!!!!!!!!!!!!!!!! The stupid plastic impellar wouldn't even come out! I had to use needle nose and my hands and a standard to get the thing out! But at least I know the water pump, fan clutch, and thermostat are 100% good still! =) Thank you so much for commenting on my thread! You guys rock!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms