Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 09-04-2013, 08:07 PM
makeshift525i makeshift525i is offline
Registered User
Location: Oregon
 
Join Date: Mar 2013
Posts: 24
Mein Auto: 525i
Car dies right after start-up/ engine died while driving

these problems suggested a fuel filter/injector issue, so I bought a new fuel filter and after replacing the old one, I now have a lower than normal idle speed (650-750 rpm) and the engine sort of chugs (for lack of a better word) here and there while in gear.

I am POSITIVE I installed the new filter the right way. Other than that, I'm not sure what else could it be. Any suggestions?

Thanks!
Reply With Quote
Advertisement
  #2  
Old 09-04-2013, 10:34 PM
denny m denny m is online now
denny m
Location: washington
 
Join Date: Aug 2013
Posts: 57
Send a message via AIM to denny m
Mein Auto: 1994 530i
Re: Car dies right after start-up/ engine died while driving

You might have a clogged fuel line. How bad were the filters you replaced?
Reply With Quote
  #3  
Old 09-05-2013, 11:01 AM
makeshift525i makeshift525i is offline
Registered User
Location: Oregon
 
Join Date: Mar 2013
Posts: 24
Mein Auto: 525i
I can't tell how bad the fuel filter was, gas was able to leak out both sides of it though. how would I remedy a clogged fuel line?
Reply With Quote
  #4  
Old 09-05-2013, 11:16 AM
denny m denny m is online now
denny m
Location: washington
 
Join Date: Aug 2013
Posts: 57
Send a message via AIM to denny m
Mein Auto: 1994 530i
Re: Car dies right after start-up/ engine died while driving

Disconnect both ends and blow it out with an air compressor.

When was the last time you changed the plugs and coil packs.
Reply With Quote
  #5  
Old 09-05-2013, 11:20 AM
denny m denny m is online now
denny m
Location: washington
 
Join Date: Aug 2013
Posts: 57
Send a message via AIM to denny m
Mein Auto: 1994 530i
Re: Car dies right after start-up/ engine died while driving

Could be your fuel pump. Might check that first.
Reply With Quote
  #6  
Old 09-05-2013, 12:45 PM
makeshift525i makeshift525i is offline
Registered User
Location: Oregon
 
Join Date: Mar 2013
Posts: 24
Mein Auto: 525i
Okay, so I might be an idiot, but I did some looking around online and came to the conclusion that I might have had the filter in backwards (I originally had the arrow pointing away from the gas cap) So I turned the filter around. probably a mistake, but I tried starting the car and nothing. tried again and there was a dead battery sounding clicking. tried again and it clicked for a second, tried to turnover, but didn't. I got a jump and was finally able to start it. Still ran just like it had before with the low idle speed and engine loping.

What is going on!? Is the filter on backwards now or was it backwards before?

The confusion came when removing the old filter: I took the entire bracket off and it fell to the ground. and found that the "in" and "out" ends are opposite from the new one. ( One end is rounded, one is pressed in on both filters, but labeled differently. )
Reply With Quote
  #7  
Old 09-05-2013, 12:51 PM
Monsignor's Avatar
Monsignor Monsignor is offline
BMW CCA Memeber #445389
Location: Pineapple Under the Sea
 
Join Date: Oct 2009
Posts: 3,199
Mein Auto: M50 Big Body
arrow points in direction of fuel.

Dont go confusing yourself with rounded and pressed ends and all that jazz.

As far as your $hit idle, check for vacuum leaks.
__________________


1995 525iA 250k mi
2006 325i/6 57k mi
2003 350Z 88k mi

Instagram: @Titan_E34
Snapchat: Titan_E34
Reply With Quote
  #8  
Old 09-05-2013, 01:13 PM
makeshift525i makeshift525i is offline
Registered User
Location: Oregon
 
Join Date: Mar 2013
Posts: 24
Mein Auto: 525i
Quote:
Originally Posted by Monsignor View Post
arrow points in direction of fuel.

Dont go confusing yourself with rounded and pressed ends and all that jazz.

As far as your $hit idle, check for vacuum leaks.
I get that the arrow points in direction of fuel, but since the filter is mounted left to right, not back to front, I can't tell which hose comes from the fuel tank and which one leads to the front of the car. Also, my fuel tank runs almost the entire width of the car, and both hoses look like they might be leading into it..

Should the arrow be point towards the passenger side or driver side?
Reply With Quote
  #9  
Old 09-05-2013, 01:18 PM
Monsignor's Avatar
Monsignor Monsignor is offline
BMW CCA Memeber #445389
Location: Pineapple Under the Sea
 
Join Date: Oct 2009
Posts: 3,199
Mein Auto: M50 Big Body
the extra line is fuel return. The line the filter is on is NOT the return line, obiously.

while it should be a bit more obvious which way fuel direction is ( ) i believe it points to the driver side. Fuel filter is on the passenger side of the tank.

You also havent told us year or model - Help us help you.
__________________


1995 525iA 250k mi
2006 325i/6 57k mi
2003 350Z 88k mi

Instagram: @Titan_E34
Snapchat: Titan_E34

Last edited by Monsignor; 09-05-2013 at 01:21 PM.
Reply With Quote
  #10  
Old 09-05-2013, 01:27 PM
makeshift525i makeshift525i is offline
Registered User
Location: Oregon
 
Join Date: Mar 2013
Posts: 24
Mein Auto: 525i
Quote:
Originally Posted by Monsignor View Post
the extra line is fuel return. The line th efilter is on is NOT the return line, obiously.

while it should be a bit more obvious which way fuel direction is ( ) i believe it points to the driver side. Fuel filter is on the passenger side of the tank.

You also havent told us year or model - Help us help you.
Alright, that's the way I had it before The initial change in performance had me second guess the direction, then after it didn't start after 4 or 5 tries and still ran poorly, had me question it again. I apologize, I'm still a rookie to the Beamer DIY's.

It's a 1990 525i.
Reply With Quote
  #11  
Old 09-05-2013, 01:34 PM
Monsignor's Avatar
Monsignor Monsignor is offline
BMW CCA Memeber #445389
Location: Pineapple Under the Sea
 
Join Date: Oct 2009
Posts: 3,199
Mein Auto: M50 Big Body
no worries. its why we're here lol.

Let us know how fixing it helps...
__________________


1995 525iA 250k mi
2006 325i/6 57k mi
2003 350Z 88k mi

Instagram: @Titan_E34
Snapchat: Titan_E34
Reply With Quote
  #12  
Old 09-05-2013, 01:40 PM
denny m denny m is online now
denny m
Location: washington
 
Join Date: Aug 2013
Posts: 57
Send a message via AIM to denny m
Mein Auto: 1994 530i
Re: Car dies right after start-up/ engine died while driving

Here's a picture of mine. Just changed it 2 weeks ago.

Click image for larger version

Name:	1378413588622.jpg
Views:	72
Size:	39.9 KB
ID:	395335
Reply With Quote
  #13  
Old 09-05-2013, 01:41 PM
denny m denny m is online now
denny m
Location: washington
 
Join Date: Aug 2013
Posts: 57
Send a message via AIM to denny m
Mein Auto: 1994 530i
Re: Car dies right after start-up/ engine died while driving

Top of the picture is the passenger side. If that helps you.
Reply With Quote
  #14  
Old 09-05-2013, 01:42 PM
Monsignor's Avatar
Monsignor Monsignor is offline
BMW CCA Memeber #445389
Location: Pineapple Under the Sea
 
Join Date: Oct 2009
Posts: 3,199
Mein Auto: M50 Big Body
Quote:
Originally Posted by denny m View Post
Top of the picture is the passenger side. If that helps you.
not to confuse the ever living fcuk out of OP but your car is different and thus has a different filter.
__________________


1995 525iA 250k mi
2006 325i/6 57k mi
2003 350Z 88k mi

Instagram: @Titan_E34
Snapchat: Titan_E34
Reply With Quote
  #15  
Old 09-05-2013, 01:59 PM
denny m denny m is online now
denny m
Location: washington
 
Join Date: Aug 2013
Posts: 57
Send a message via AIM to denny m
Mein Auto: 1994 530i
Re: Car dies right after start-up/ engine died while driving

Haha, I didn't see the post he did with the make and model.

It's clearly a gas issue though. Too just die in flight like that..
Reply With Quote
  #16  
Old 09-05-2013, 02:06 PM
Monsignor's Avatar
Monsignor Monsignor is offline
BMW CCA Memeber #445389
Location: Pineapple Under the Sea
 
Join Date: Oct 2009
Posts: 3,199
Mein Auto: M50 Big Body
not at all. Could very easily be a severe vacuum leak.

To be a fuel issue, it would have to be a dead pump, or blown relay. both of which would pretty much just stop and wouldnt be able to fire back over.
__________________


1995 525iA 250k mi
2006 325i/6 57k mi
2003 350Z 88k mi

Instagram: @Titan_E34
Snapchat: Titan_E34
Reply With Quote
  #17  
Old 09-05-2013, 02:13 PM
makeshift525i makeshift525i is offline
Registered User
Location: Oregon
 
Join Date: Mar 2013
Posts: 24
Mein Auto: 525i
So I swapped the filter so that it's facing the correct direction again, and the battery is dead again. Once I get it jumped I'll check for any vacuum leaks and let you guys know. At this point I'm beginning to doubt whether or not the fuel filter was the culprit in the first place.

Thanks for the advice though!
Reply With Quote
  #18  
Old 09-05-2013, 02:14 PM
denny m denny m is online now
denny m
Location: washington
 
Join Date: Aug 2013
Posts: 57
Send a message via AIM to denny m
Mein Auto: 1994 530i
Re: Car dies right after start-up/ engine died while driving

Holy, I learned something new.
Reply With Quote
  #19  
Old 09-06-2013, 06:50 AM
Monsignor's Avatar
Monsignor Monsignor is offline
BMW CCA Memeber #445389
Location: Pineapple Under the Sea
 
Join Date: Oct 2009
Posts: 3,199
Mein Auto: M50 Big Body
Quote:
Originally Posted by makeshift525i View Post
So I swapped the filter so that it's facing the correct direction again, and the battery is dead again. Once I get it jumped I'll check for any vacuum leaks and let you guys know. At this point I'm beginning to doubt whether or not the fuel filter was the culprit in the first place.

Thanks for the advice though!
let us know how it goes
__________________


1995 525iA 250k mi
2006 325i/6 57k mi
2003 350Z 88k mi

Instagram: @Titan_E34
Snapchat: Titan_E34
Reply With Quote
  #20  
Old 09-08-2013, 07:12 AM
makeshift525i makeshift525i is offline
Registered User
Location: Oregon
 
Join Date: Mar 2013
Posts: 24
Mein Auto: 525i
Got the car running finally. Turned out the battery was bad (I suppose it was just a coincidence that it stopped holding a charge while I was working on the car.) and for the roughness, that "chugging" I described earlier, was smoothed out by adjusting a long nut on the throttle body linkage ( I had taken the throttle body off about month ago, So I assume I may have unknowingly adjusted it when messing with the linkage cables?)
I'd like to believe the fuel filter helped as well, the car no longer (as of yet) starts then immediately dies.

Thanks again for the suggestions, I'd be lost without the great people on BF!
Reply With Quote
Reply

Bookmarks

Tags
fuel filter, low idle, replacement


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms