Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 09-10-2013, 09:43 PM
mdep335 mdep335 is offline
igotsit
Location: new jersey, US
 
Join Date: Dec 2011
Posts: 7
Mein Auto: 335i sedan
limp mode issue

Hello everyone,
I'm somewhat new to forums I apologize if this is too lengthy and too many questions at once. First let me say I searched and couldn't find any issues with my similar details, so anyway a few days ago i was driving somewhat spirited, nothing crazy and i got that engine malfunction light on my odometer and idrive (half shaded engine icon) which I'm guessing is limp mode, but no check engine light or anything else.

So I pull over turn the car off then start again and the icon was gone and the system check stated all systems Okay. Then a couple days later the same thing happened. I have an AFE intake and a turbo tuner. I'm going in for service on monday so I took the turbo tuner out and haven't experienced any issues since, even during wide open throttle??

Sooo, could this have to do with the chip, and pushing the dated engine parts too much? I can't get any codes because I only have access to the scanner from advance auto ( the one where the check engine light has to be on to read any fault codes ). I have a mac and can someone help me and tell me what scanner would be able to read limp mode fault codes maybe something $200-300 for future issues, The BT cable requires a PC.

I know the dealer can probably still tell I had the chip in but i just feel better not having it in when going there. Is limp mode saying theres a permanent issue although it's not there after restarting. Or it could be anything and I won't know until the service dept.

BTW it's an 07 335 e90 74k mi. and the HPFP recall was done

Any advice would be great, Thanks in advance

Last edited by mdep335; 09-10-2013 at 09:53 PM. Reason: added info
Reply With Quote
Ads by Google
  #2  
Old 09-10-2013, 10:52 PM
SilverX3's Avatar
SilverX3 SilverX3 is offline
Officially Welcomed to the 'Fest
Location: Australia
 
Join Date: Sep 2005
Posts: 2,892
Mein Auto: 130i & E92 325i, E90 SOLD
could be Vanos issues
__________________
Residence - StarTrek Enterprise
Job - Captain
Current Starship Fleet:
06 130i - ROCK SOLID Performer
07 320i - SOLD
08 E92 325i - Blue SOLD
Bicycles: Giant TCR Advanced Zero SOLD, Argon 18 Krypton, Argon 18E114, Trek Madone COMING
BOUGHT : MY11.5 X1 Xdrive25i

New car... Estoril Blue Car
Reply With Quote
  #3  
Old 09-10-2013, 11:19 PM
mdep335 mdep335 is offline
igotsit
Location: new jersey, US
 
Join Date: Dec 2011
Posts: 7
Mein Auto: 335i sedan
okay thanks I don't know what that is but I'll do some research and that at least gives me a starting point. I appreciate it. If it's not too general any Idea on the range of the repair cost at the dealership? I'm just taking a quick guess it could be many different issues- too many too even estimate a range? Also, is that something that I could look up DIY threads and do myself. I do minor maintenance repairs myself.
Reply With Quote
  #4  
Old 09-11-2013, 04:10 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,009
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by mdep335 View Post
So I pull over turn the car off then start again and the icon was gone and the system check stated all systems Okay. Then a couple days later the same thing happened. I have an AFE intake and a turbo tuner. I'm going in for service on monday so I took the turbo tuner out and haven't experienced any issues since, even during wide open throttle??

Icon's gone, but thrown code's not. Read all.....

Which tune?
Reply With Quote
  #5  
Old 09-11-2013, 10:46 AM
mdep335 mdep335 is offline
igotsit
Location: new jersey, US
 
Join Date: Dec 2011
Posts: 7
Mein Auto: 335i sedan
Hey thanks for the response but I'm sorry but don't understand the "Icon's gone, but thrown code's not." I guess you're saying even though the icon is gone, there are hidden (BMW specific) fault codes thrown. Lol, i guess your English and grammar is a bit above me I don't have a BT tool/cable because I have an "apple MAC" and their software only works with "pc based systems". I don't have access to those type of scan tools but I'm researching

As for the tuner the actual name of the tune is " Split Second- turbo tuner" it's the kind where you unplug the MAF sensor- plug the turbo tuner in- and then plug the original MAF sensor cable into the back of the turbo tuner. It actually does make the car noticeably quicker. I don't know if thats a "piggyback" type or a "re-flash" As I said I'm somewhat new to this and not sure of the actual name of it.

I hope this answered your question to my question..
Thanks a Lot
Reply With Quote
  #6  
Old 09-11-2013, 11:02 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,009
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by mdep335 View Post
Hey thanks for the response but I'm sorry but don't understand the "Icon's gone, but thrown code's not." I guess you're saying even though the icon is gone, there are hidden (BMW specific) fault codes thrown. Lol, i guess your English and grammar is a bit above me I don't have a BT tool/cable because I have an "apple MAC" and their software only works with "pc based systems". I don't have access to those type of scan tools but I'm researching

As for the tuner the actual name of the tune is " Split Second- turbo tuner" it's the kind where you unplug the MAF sensor- plug the turbo tuner in- and then plug the original MAF sensor cable into the back of the turbo tuner. It actually does make the car noticeably quicker. I don't know if thats a "piggyback" type or a "re-flash" As I said I'm somewhat new to this and not sure of the actual name of it.

I hope this answered your question to my question..
Thanks a Lot

Code was stored in memory - that won't disappear. But the icon may if the error condition isn't detected again after a start or two.

BT cable or GT1'll reveal all, and then some....
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms