Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #1  
Old 09-13-2013, 02:39 PM
dallen9494 dallen9494 is offline
Registered User
Location: Auburn WA
 
Join Date: Jul 2013
Posts: 5
Mein Auto: 2001 740il Sport
DSC/ABS issues?

Hi,

I recently purchased a 2001 740iL Sport w/129,000 mi from a friend with what turned out to be LCM issues for $1200. The car sat for almost a year before I purchased it, after installing a new (used) LCM and having it coded to my car, it ran great and everything was working fine, but had a shimmy at about 50-60 mph. I thought maybe the tires had a flat spot, took it to a tire shop to have it checked out, and found it had a sticky left front caliper. Had the brakes done, was driving the car home on a long stretch of road and figured I would bed the brakes. I performed about 5 or 6 near stops from about 50 mph, then drove the car for a few miles to cool the brakes, then went home. The next day on the way to work I noticed the DSC light on after driving on the freeway for about 10 miles. When I was heading home the car went into trans fail safe mode, the gauges started to work intermittently, the service engine light came on, ABS, brake light, and the AC stopped blowing cold. I took it back to the shop and they checked the codes and this is what they had:
82 Rotation Rate Sensor
58 CAN: open circuit to AGS
P1747 & P600
130 CAN Time out AVS/ASC/DSC
128 CAN Bus Mon
221 CAN Timeout ABS/ASC/DSC
220 CAM Timeout BBS/ASC/DSC

They recommend replacing the ABS Module, does this sound correct? Or is there something else i should be looking at. The car ran great before the brake job, I didn't have any issues other than the LCM stuff when I first purchased it.

Thanks,
Dennis
Reply With Quote
Ads by Google
  #2  
Old 09-14-2013, 12:06 PM
gsxrfxr gsxrfxr is offline
Registered User
Location: plainfield, il
 
Join Date: Mar 2013
Posts: 28
Mein Auto: 97 528i, 99 740i, 00 740i
i had the similar issue and the first thing i did was swap the ABS sensors from the front wheels! front left to front right and the right one into the left and its been almost a year dont know why but it worked for me. also did the battery died on your car ? some times if the battery dies dsc has to be reset.
Reply With Quote
  #3  
Old 09-14-2013, 06:34 PM
ebida3's Avatar
ebida3 ebida3 is offline
Society of the 7's East
Location: High Point, NC
 
Join Date: May 2010
Posts: 548
Mein Auto: 2001 740iL
If the lights come on at or about 30mph it is most likely the pre-charge pump. follow this......
http://www.meeknet.co.uk/e38/BMW_E38...ure_Lights.htm

http://www.meeknet.co.uk/e38/ABS/Index.htm

I had tthe same problem and got a pump from the boneyard.
Reply With Quote
  #4  
Old 10-03-2013, 06:03 PM
Podmore Podmore is offline
Officially Welcomed to the 'Fest
Location: Adelaide South Australia
 
Join Date: Feb 2008
Posts: 140
Mein Auto: 2001 BMW 735i
When you say "had the brakes done", do you mean you had the pads changed, or did the shop also replace the brake fluid (which should be done every two years, but rarely is)? If so, maybe the brakes were not bled properly (any spongy feel to them?).
If the brake fluid was not replaced, then keep in mind the installation of new pads causes some of the brake fluid wich has been lower down in the system filling the extended caliper piston bores, to be pushed back up and maybe this has dislodged some goop or as ebida3 has indicated, maybe messed with the precharge pump (air bubble or something).
Reply With Quote
  #5  
Old 10-03-2013, 06:36 PM
Mayorchuck Mayorchuck is offline
Officially Welcomed to the 'Fest
Location: Farley, MO
 
Join Date: May 2013
Posts: 619
Mein Auto: '96 740iL
Been a few weeks. Any resolution OP? How is your battery?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 10:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms