Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 09-13-2013, 10:59 PM
AnJing408 AnJing408 is offline
Officially Welcomed to the 'Fest
Location: Bay Area CA
 
Join Date: Jul 2013
Posts: 147
Mein Auto: 2007 335i
engine malfunction on

I knew this was going to happen sooner or later. Anyways, so I was driving and suddenly the engine malfunction light came on, no other warning lights. Made a stop to get something and when i turn the car back on the warning light was gone and didn't come back on even after a 1 hr. drive back home. Any clues what could this be? I don't think it's the waterpump since it was replaced less than 10k miles ago. I hope it's the turbo going out since it is covered under warranty. i don't have an obd scanner and don't want to go to the dealers and pay $200 for a check, I don't have bmw indy either. Will drive the car the next few days and see if it will come back on. I will be selling the car in the near future, i knew BMW's are not reliable but gave it one last chance and it failed me. Never again.

http://i1090.photobucket.com/albums/...ps9bf07be1.jpg
__________________
2007 335i coupe/M-aero front lip spoiler/M3 trunk lip spoiler.....SOLD

Last edited by AnJing408; 09-13-2013 at 11:03 PM.
Reply With Quote
Advertisement
  #2  
Old 09-13-2013, 11:37 PM
SilverX3's Avatar
SilverX3 SilverX3 is offline
Officially Welcomed to the 'Fest
Location: Australia
 
Join Date: Sep 2005
Posts: 3,096
Mein Auto: 130i & E92 325i, E90 SOLD
Dont blame you

That is it for me

Switching brands as i type this
__________________
Residence - StarTrek Enterprise
Job - Captain
Current Starship Fleet:
06 130i - ROCK SOLID Performer
MY11.5 X1 Xdrive25i
2013 VW Golf R - Rising Metallic Blue
07 320i - SOLD
08 E92 325i - Blue SOLD
Bicycles: Giant TCR Advanced Zero SOLD, Argon 18 Krypton, Argon 18E114, Trek Madone COMING
Reply With Quote
  #3  
Old 09-13-2013, 11:42 PM
AnJing408 AnJing408 is offline
Officially Welcomed to the 'Fest
Location: Bay Area CA
 
Join Date: Jul 2013
Posts: 147
Mein Auto: 2007 335i
Quote:
Originally Posted by SilverX3 View Post
Dont blame you

That is it for me

Switching brands as i type this
which lexus are you planning to get? post pics when you do
__________________
2007 335i coupe/M-aero front lip spoiler/M3 trunk lip spoiler.....SOLD
Reply With Quote
  #4  
Old 09-14-2013, 01:47 AM
aleks001 aleks001 is offline
Aleks
Location: Brisbane, Australia
 
Join Date: Nov 2011
Posts: 491
Mein Auto: 2006 BMW 325i
Quote:
Originally Posted by AnJing408 View Post
I knew this was going to happen sooner or later. Anyways, so I was driving and suddenly the engine malfunction light came on, no other warning lights. Made a stop to get something and when i turn the car back on the warning light was gone and didn't come back on even after a 1 hr. drive back home. Any clues what could this be? I don't think it's the waterpump since it was replaced less than 10k miles ago. I hope it's the turbo going out since it is covered under warranty. i don't have an obd scanner and don't want to go to the dealers and pay $200 for a check, I don't have bmw indy either. Will drive the car the next few days and see if it will come back on. I will be selling the car in the near future, i knew BMW's are not reliable but gave it one last chance and it failed me. Never again.

http://i1090.photobucket.com/albums/...ps9bf07be1.jpg
Impossible to tell from your post, there could be a million things. Get yourself a bmw obd cable:
http://www.ebay.com.au/itm/BMW-OBD-D...item3f17d6b808
There's heaps of them and they ship everywhere, so find the best one for your location, it's not expensive.

Then find inpa on the internet and set it up on laptop:
http://bmwcoders.com/forum/1-post1.html

Really not hard to setup INPA.

Get some codes and then people will be able to help you and it will only cost you a couple of bucks.

I'm going to have a guess at your problem and say maybe vanos solenoids need cleaning, but it literally is a mega guess, so do yourself a favor and get the cable and software, it's really pocket change and will pay itself of the first time you use it.
Reply With Quote
  #5  
Old 09-14-2013, 01:49 AM
aleks001 aleks001 is offline
Aleks
Location: Brisbane, Australia
 
Join Date: Nov 2011
Posts: 491
Mein Auto: 2006 BMW 325i
Quote:
Originally Posted by AnJing408 View Post
which lexus are you planning to get? post pics when you do
Joke all you want but I saw the new IS today, very hot car. I think BMW and Merc are going to feel this one.
Reply With Quote
  #6  
Old 09-14-2013, 01:50 AM
SilverX3's Avatar
SilverX3 SilverX3 is offline
Officially Welcomed to the 'Fest
Location: Australia
 
Join Date: Sep 2005
Posts: 3,096
Mein Auto: 130i & E92 325i, E90 SOLD
New is250

Possibly in 2 weeks
__________________
Residence - StarTrek Enterprise
Job - Captain
Current Starship Fleet:
06 130i - ROCK SOLID Performer
MY11.5 X1 Xdrive25i
2013 VW Golf R - Rising Metallic Blue
07 320i - SOLD
08 E92 325i - Blue SOLD
Bicycles: Giant TCR Advanced Zero SOLD, Argon 18 Krypton, Argon 18E114, Trek Madone COMING
Reply With Quote
  #7  
Old 09-14-2013, 01:52 AM
aleks001 aleks001 is offline
Aleks
Location: Brisbane, Australia
 
Join Date: Nov 2011
Posts: 491
Mein Auto: 2006 BMW 325i
Quote:
Originally Posted by SilverX3 View Post
New is250

Possibly in 2 weeks
Lucky you I love it.
Reply With Quote
  #8  
Old 09-14-2013, 04:46 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,007
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by AnJing408 View Post
I knew this was going to happen sooner or later. Anyways, so I was driving and suddenly the engine malfunction light came on, no other warning lights. Made a stop to get something and when i turn the car back on the warning light was gone and didn't come back on even after a 1 hr. drive back home. Any clues what could this be? I don't think it's the waterpump since it was replaced less than 10k miles ago. I hope it's the turbo going out since it is covered under warranty. i don't have an obd scanner and don't want to go to the dealers and pay $200 for a check, I don't have bmw indy either. Will drive the car the next few days and see if it will come back on. I will be selling the car in the near future, i knew BMW's are not reliable but gave it one last chance and it failed me. Never again.

From your data, I'm able to give you a pretty good idea: Something is wrong with your car! The good news is, even more detail is available. Simply, read codes and search the Net for same - you're sure to find others have had that issue and, perhaps, a good DIY resolution.

A good place to start might be to find out what warning light that was. Did you happen to notice?


Name:  Think 04.gif
Views: 142
Size:  4.9 KB
Reply With Quote
  #9  
Old 09-14-2013, 06:12 AM
AnJing408 AnJing408 is offline
Officially Welcomed to the 'Fest
Location: Bay Area CA
 
Join Date: Jul 2013
Posts: 147
Mein Auto: 2007 335i
Quote:
Originally Posted by CALWATERBOY View Post
From your data, I'm able to give you a pretty good idea: Something is wrong with your car! The good news is, even more detail is available. Simply, read codes and search the Net for same - you're sure to find others have had that issue and, perhaps, a good DIY resolution.

A good place to start might be to find out what warning light that was. Did you happen to notice?


Attachment 396814
Here is a photo I took right when it turned on:
http://i1090.photobucket.com/albums/...ps9bf07be1.jpg

The only light that came on was the triangle with the exclamation point on the dash. After I restarted the car, both the triangle on the dash and malfunction on the screen went away.
__________________
2007 335i coupe/M-aero front lip spoiler/M3 trunk lip spoiler.....SOLD

Last edited by AnJing408; 09-14-2013 at 06:19 AM.
Reply With Quote
  #10  
Old 09-14-2013, 06:14 AM
AnJing408 AnJing408 is offline
Officially Welcomed to the 'Fest
Location: Bay Area CA
 
Join Date: Jul 2013
Posts: 147
Mein Auto: 2007 335i
Quote:
Originally Posted by SilverX3 View Post
New is250

Possibly in 2 weeks
sweet!!! I saw a few white ones on the road and it looks awesome.
__________________
2007 335i coupe/M-aero front lip spoiler/M3 trunk lip spoiler.....SOLD
Reply With Quote
  #11  
Old 09-14-2013, 06:56 AM
need4speed's Avatar
need4speed need4speed is offline
Officially Welcomed to the 'Fest
Location: South Carolina
 
Join Date: May 2006
Posts: 2,377
Mein Auto: 09 335Cabrio zsp/11 335d
Quote:
Originally Posted by CALWATERBOY View Post
From your data, I'm able to give you a pretty good idea: Something is wrong with your car! The good news is, even more detail is available. Simply, read codes and search the Net for same - you're sure to find others have had that issue and, perhaps, a good DIY resolution.

A good place to start might be to find out what warning light that was. Did you happen to notice?


Attachment 396814
+1 Codes are your friend. N4S
Reply With Quote
  #12  
Old 09-14-2013, 09:46 AM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,007
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by AnJing408 View Post
Here is a photo I took right when it turned on:
http://i1090.photobucket.com/albums/...ps9bf07be1.jpg

The only light that came on was the triangle with the exclamation point on the dash. After I restarted the car, both the triangle on the dash and malfunction on the screen went away.

Possibilities
Reply With Quote
  #13  
Old 09-14-2013, 03:21 PM
SilverX3's Avatar
SilverX3 SilverX3 is offline
Officially Welcomed to the 'Fest
Location: Australia
 
Join Date: Sep 2005
Posts: 3,096
Mein Auto: 130i & E92 325i, E90 SOLD
Great looking IS






Local car magazine tested the new Lexus IS250, F30 320i, Audi A4 1.8 Turbo and C Class C200

In order

1. Lexus
2. C200
3. F30
4. Audi

Lexus is way in front ....
__________________
Residence - StarTrek Enterprise
Job - Captain
Current Starship Fleet:
06 130i - ROCK SOLID Performer
MY11.5 X1 Xdrive25i
2013 VW Golf R - Rising Metallic Blue
07 320i - SOLD
08 E92 325i - Blue SOLD
Bicycles: Giant TCR Advanced Zero SOLD, Argon 18 Krypton, Argon 18E114, Trek Madone COMING
Reply With Quote
  #14  
Old 09-14-2013, 05:11 PM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,007
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by SilverX3 View Post
Local car magazine tested the new Lexus IS250, F30 320i, Audi A4 1.8 Turbo and C Class C200

In order

1. Lexus
2. C200
3. F30
4. Audi

Lexus is way in front ....

Wait for it....M
Reply With Quote
  #15  
Old 09-15-2013, 07:03 AM
jburke4689 jburke4689 is offline
Officially Welcomed to the 'Fest
Location: Ellicott City, MD
 
Join Date: Apr 2008
Posts: 570
Mein Auto: 2007 335i
I think I know the problem. No indy, don't want to go the the dealer, don't have a scanner and the car is 6 years old. My guess is this car sees no maintenance. Stuff wears out and breaks in all cars. A little TLC will and investment in maintenance and you can aviod most problems. Lexus is nice though, just not for me.
__________________
Reply With Quote
  #16  
Old 09-15-2013, 09:18 AM
johnc_22's Avatar
johnc_22 johnc_22 is offline
Squeal like a BMW
Location: Atlanta, GA
 
Join Date: Sep 2004
Posts: 6,586
Mein Auto: 2013 Audi A4
Before I sold my 2007 335i, after walnut shell blast, replaced HPFP and other things had already been done, spurious CELs were diagnosed as VANOS solenoids - replaced under extended warranty. If you love the car, take it to an indy for a fix. If you're over the non-stop repairs do what I did and sell/trade it. Sadly BMW doesn't make a car that feels much like a 3 Series any more yet still charges a premium in their segment so I moved on.

I test drove the new IS a couple of times but found the interior confining and I'm not a large person. It does feel like a driver's cockpit but not sure how comfortable it would be for long trips/daily commutes.
__________________
2013 Audi A4 - Premium+/Sport/MMI/B+O Audio
2007 BMW E90 335i (retired)
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms