Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 10-20-2013, 07:59 AM
manzoorz5001 manzoorz5001 is offline
Registered User
Location: Oshawa, Ontario
 
Join Date: Mar 2013
Posts: 16
Mein Auto: 1999 BMW 528i
1999 528i EML light, Cranks but not starting

I had a broken vacuum hose (from the dip stick to the CCV). had a mechanic put the hose in. After replacing the hose, the car isn't starting but cranks. I have checked the following things so far:

1- Spark--OK
2- Fuel Pump/Lines -OK
3-Battery-OK

I scanned the car and get the following code(s):
170-AA Control-Unit Self-Test, Internal Fault, Throttle Body.
Reply With Quote
Advertisement
  #2  
Old 10-20-2013, 09:51 AM
johnstern's Avatar
johnstern johnstern is offline
Officially Welcomed to the 'Fest
Location: Cape Neddick, Maine
 
Join Date: Mar 2007
Posts: 1,039
Mein Auto: 2000 BMW 528iT/5, S/C
An EML light usually is for a throttle body problem and that's exactly what the code says. You can try cleaning it but you'll probably have to replace it. I'd also inspect the Bowden cable and clean the connector.

Last edited by johnstern; 10-20-2013 at 09:57 AM.
Reply With Quote
  #3  
Old 10-20-2013, 12:50 PM
manzoorz5001 manzoorz5001 is offline
Registered User
Location: Oshawa, Ontario
 
Join Date: Mar 2013
Posts: 16
Mein Auto: 1999 BMW 528i
The cable is intact. I try replacing the throttle body.
thanks
Reply With Quote
  #4  
Old 10-21-2013, 12:58 PM
manzoorz5001 manzoorz5001 is offline
Registered User
Location: Oshawa, Ontario
 
Join Date: Mar 2013
Posts: 16
Mein Auto: 1999 BMW 528i
whats the best way to clean the throttle body and the electrical connector.
Reply With Quote
  #5  
Old 10-21-2013, 09:06 PM
johnstern's Avatar
johnstern johnstern is offline
Officially Welcomed to the 'Fest
Location: Cape Neddick, Maine
 
Join Date: Mar 2007
Posts: 1,039
Mein Auto: 2000 BMW 528iT/5, S/C
Electrical spray and carb cleaner.
Reply With Quote
Reply

Bookmarks

Tags
eml light, mdk, no start, throttle body


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms