Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 10-31-2013, 11:46 AM
CeruleanCoyote CeruleanCoyote is offline
Registered User
Location: MN
 
Join Date: Feb 2013
Posts: 37
Mein Auto: A BMW...or two.
Question 1994 540i Not Starting Help!

So I have a 1994 540i with 179k miles on it. (Long story short ) One day I was driving it, smooth as ever, then I turn a corner, it flashes TRANS PROGRAM twice, then it dies. I pull over to the side of the road, let it sit for a minute, start it up and drive home with no problems except the CEL flashes every now and again. After a day or so I go to start it, nothing. Replace the battery, try to start it and it starts cranking but doesn't fire. Get pissed off, leave for business, come back a week later, new battery is dead...I charge it, still cranks but doesn't fire. Let it sit for two weeks, get it towed to a shop. I bought a fuel pump thinking that's what was wrong, they told me it was the Crank Position Sensor. So they replaced it, it started up but was running rough, and when I got the car back none of the power accessories were working (windows, locks, radio etc). Drove home, parked it, started it up a few times just because. Still pissed about the electronics, and left for business again. A week later I go to try to start it, nothing. Charge the battery because it was dead again, and it starts up, still running rough and I back it up 50ft to my garage then drive back forward 50 ft shut it off, and it never starts again.. Anybody know what's going on here?
Reply With Quote
Advertisement
  #2  
Old 10-31-2013, 01:07 PM
gmnmsclM540i's Avatar
gmnmsclM540i gmnmsclM540i is online now
545i pilot
Location: a dusty hole
 
Join Date: Apr 2010
Posts: 533
Mein Auto: e60 545i e34 540 e32 740
Re: 1994 540i Not Starting Help!

Have you checked your alternator?

Sent from BimmerApp mobile app
Reply With Quote
  #3  
Old 10-31-2013, 01:09 PM
CeruleanCoyote CeruleanCoyote is offline
Registered User
Location: MN
 
Join Date: Feb 2013
Posts: 37
Mein Auto: A BMW...or two.
I have not, but would that cause it to run rough?
Reply With Quote
  #4  
Old 10-31-2013, 03:35 PM
gmnmsclM540i's Avatar
gmnmsclM540i gmnmsclM540i is online now
545i pilot
Location: a dusty hole
 
Join Date: Apr 2010
Posts: 533
Mein Auto: e60 545i e34 540 e32 740
Re: 1994 540i Not Starting Help!

Quote:
Originally Posted by CeruleanCoyote View Post
I have not, but would that cause it to run rough?
Dont think so, but did it run rough before changing your CPS? Other than that I've read many threads where a bad alternator will give bad warning messages, especially TRANS PROG. a bad alternator in my e32 did this. A bad battery in my e60 had a similar effect. Try checking your alt. It cant hurt.
Edit: in both of my m60 cars the fusible link under the back seat being loose caused probs with the door locks, windows etc....
Sent from BimmerApp mobile app

Last edited by gmnmsclM540i; 10-31-2013 at 03:39 PM.
Reply With Quote
  #5  
Old 10-31-2013, 09:49 PM
CeruleanCoyote CeruleanCoyote is offline
Registered User
Location: MN
 
Join Date: Feb 2013
Posts: 37
Mein Auto: A BMW...or two.
I definitely will. That would explain why the battery is dead, but the running rough part would mean something else is wrong. It was running rough after the CPS replacement. And maybe somewhere along the line of charging the battery about five times I could've knocked that link off under the seat? Where exactly is that?
Reply With Quote
  #6  
Old 11-01-2013, 08:54 AM
CeruleanCoyote CeruleanCoyote is offline
Registered User
Location: MN
 
Join Date: Feb 2013
Posts: 37
Mein Auto: A BMW...or two.
I have it at a shop and they just called me to tell me that the immobilizer is activated and they can't get around it, so I have to bring it to a dealership... Why would the immobilizer be activated? A bad key?
Reply With Quote
  #7  
Old 11-01-2013, 10:42 AM
gmnmsclM540i's Avatar
gmnmsclM540i gmnmsclM540i is online now
545i pilot
Location: a dusty hole
 
Join Date: Apr 2010
Posts: 533
Mein Auto: e60 545i e34 540 e32 740
Re: 1994 540i Not Starting Help!

Quote:
Originally Posted by CeruleanCoyote View Post
I definitely will. That would explain why the battery is dead, but the running rough part would mean something else is wrong. It was running rough after the CPS replacement. And maybe somewhere along the line of charging the battery about five times I could've knocked that link off under the seat? Where exactly is that?
I suggest reading through some of the stickies at the top of the board. Downloading a Bentley manual would be the best way to find the fusible link, as I would have to go pull my seat out to properly describe it to you. You can do that from anyone of several links provided in the above mentioned stickies.

Sent from BimmerApp mobile app
Reply With Quote
  #8  
Old 11-01-2013, 11:16 AM
gmnmsclM540i's Avatar
gmnmsclM540i gmnmsclM540i is online now
545i pilot
Location: a dusty hole
 
Join Date: Apr 2010
Posts: 533
Mein Auto: e60 545i e34 540 e32 740
Re: 1994 540i Not Starting Help!

Quote:
Originally Posted by CeruleanCoyote View Post
I have it at a shop and they just called me to tell me that the immobilizer is activated and they can't get around it, so I have to bring it to a dealership... Why would the immobilizer be activated? A bad key?
I would take that as "we dont have a clue about BMW" leave them alone. That being said, I would read ALL the stickies at the top of the E34 forum. I think that without the perspective you will gain from the crucial info there as a primer, there's not much advice I could give you other than check your alternator. I definitely wouldn't throw any other random parts (such as fuel pump or CPS) at the problem without READING THE STICKIES first! Hope this helps.

Sent from my DROID RAZR using BimmerApp mobile app
Reply With Quote
  #9  
Old 11-01-2013, 11:24 AM
CeruleanCoyote CeruleanCoyote is offline
Registered User
Location: MN
 
Join Date: Feb 2013
Posts: 37
Mein Auto: A BMW...or two.
Thanks for your advice!
Reply With Quote
  #10  
Old 11-01-2013, 11:44 AM
gmnmsclM540i's Avatar
gmnmsclM540i gmnmsclM540i is online now
545i pilot
Location: a dusty hole
 
Join Date: Apr 2010
Posts: 533
Mein Auto: e60 545i e34 540 e32 740
Re: 1994 540i Not Starting Help!

Quote:
Originally Posted by CeruleanCoyote View Post
Thanks for your advice!
No prob, wish I had more answers.

Sent from my DROID RAZR using BimmerApp mobile app
Reply With Quote
  #11  
Old 11-01-2013, 12:33 PM
pavel246 pavel246 is offline
Registered User
Location: USA
 
Join Date: Oct 2013
Posts: 13
Mein Auto: 2001 325i touring
1994 540i Not Starting Help!

That could be your ECU . Open it and inspect for any damage like crack or overhit . I have 2001 e46 , couple days ago I try start my car and it won't start I use diagnostic tool to find what wrong with it . For some reason I can't connect to ECU It show me code D1 anti-tampering protection EWS so EWS unit not recognize any of my key's . I start check my ECU and find problem which an a pictures Click image for larger version

Name:	ImageUploadedByBimmerApp1383334364.167386.jpg
Views:	84
Size:	203.1 KB
ID:	405252Click image for larger version

Name:	ImageUploadedByBimmerApp1383334382.743118.jpg
Views:	69
Size:	222.0 KB
ID:	405253Click image for larger version

Name:	ImageUploadedByBimmerApp1383334395.431500.jpg
Views:	62
Size:	141.3 KB
ID:	405254


Sent from BimmerApp mobile app
Reply With Quote
  #12  
Old 11-01-2013, 01:26 PM
gmnmsclM540i's Avatar
gmnmsclM540i gmnmsclM540i is online now
545i pilot
Location: a dusty hole
 
Join Date: Apr 2010
Posts: 533
Mein Auto: e60 545i e34 540 e32 740
Re: 1994 540i Not Starting Help!

Quote:
Originally Posted by pavel246 View Post
That could be your ECU . Open it and inspect for any damage like crack or overhit . I have 2001 e46 , couple days ago I try start my car and it won't start I use diagnostic tool to find what wrong with it . For some reason I can't connect to ECU It show me code D1 anti-tampering protection EWS so EWS unit not recognize any of my key's . I start check my ECU and find problem which an a pictures Attachment 405252Attachment 405253Attachment 405254


Sent from BimmerApp mobile app
E46 is definitely a vastly different animal from an e34

Sent from BimmerApp mobile app
Reply With Quote
  #13  
Old 11-01-2013, 03:06 PM
pavel246 pavel246 is offline
Registered User
Location: USA
 
Join Date: Oct 2013
Posts: 13
Mein Auto: 2001 325i touring
1994 540i Not Starting Help!

I know My cousin has one


Sent from BimmerApp mobile app
Reply With Quote
Reply

Bookmarks

Tags
540i, e34, help advice needed, not starting


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms