Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 11-17-2013, 05:08 AM
dmcle91139@aol. dmcle91139@aol. is offline
Registered User
Location: UK
 
Join Date: Nov 2013
Posts: 3
Mein Auto: BMW X5
Water in the boot.

Just an observation really, but it could save people a bit of cash.My Mrs had the sat nav screen and indicator lights on the dash conk out, the indicators were working. In the boot, under the cd player on my 2002 X5 is a well which had about 4" of water in that seemed to be shorting out a lot of electrics. I cleaned out the plug and pulled out the grommet to drain out the water, replaced them and then left a hairdryer in there to dry it out. seems to have sorted it out. So I would suggest that its definitely worth a look.

Fred Mc.
Reply With Quote
Ads by Google
  #2  
Old 11-17-2013, 08:47 AM
puddinboo puddinboo is offline
Officially Welcomed to the 'Fest
Location: on earth
 
Join Date: Jul 2013
Posts: 357
Mein Auto: 2003 BMW X5
thats a good heads up and will help some people out there ,can you tell how water got into the boot or into the sav?
__________________
2003 X5 3.0i
Reply With Quote
  #3  
Old 11-17-2013, 10:13 AM
dmcle91139@aol. dmcle91139@aol. is offline
Registered User
Location: UK
 
Join Date: Nov 2013
Posts: 3
Mein Auto: BMW X5
Looks like it could have come in through a gap at the top of the indicator lens on the boot side
Reply With Quote
  #4  
Old 11-17-2013, 12:17 PM
puddinboo puddinboo is offline
Officially Welcomed to the 'Fest
Location: on earth
 
Join Date: Jul 2013
Posts: 357
Mein Auto: 2003 BMW X5
did you fix that situation so it doesn`t happen again?
__________________
2003 X5 3.0i
Reply With Quote
  #5  
Old 11-17-2013, 12:27 PM
dmcle91139@aol. dmcle91139@aol. is offline
Registered User
Location: UK
 
Join Date: Nov 2013
Posts: 3
Mein Auto: BMW X5
It seems to have sorted it, I'll post again if I find anything else
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms