Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-11-2013, 09:05 AM
twiz88 twiz88 is offline
Registered User
Location: Baltimore
 
Join Date: Nov 2013
Posts: 41
Mein Auto: 2007 BMW 328xi Coupe
CEL Code P2570 328xi coupe help?

Got my car washed this past weekend when I got inside the vehicle to start it the CEL came on. I got the code pulled and it was P-2570 Direct Ozone Reduction Catalyst Temperature Sensor Circuit High. Did some research and seem I may have to get my radiator replaced. is this true and also will it affect anything if I wait to get it fixed? Any help would be great.
Reply With Quote
Ads by Google
  #2  
Old 11-11-2013, 01:23 PM
mr_bean mr_bean is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Mar 2009
Posts: 654
Mein Auto: 2000 328i
It may be as simple as a little bit of water getting into the electrical connector for the sensor. Unplug it after driving the car (while it's still warm) to help dry it out, then reset the error code. If that doesn't fix it, then I believe this repair should be covered under the federal SULEV emissions warranty of 15yr/150K miles.
Reply With Quote
  #3  
Old 11-11-2013, 01:30 PM
fdriller9 fdriller9 is offline
Officially Welcomed to the 'Fest
Location: NJ/Philly
 
Join Date: Oct 2006
Posts: 1,923
Mein Auto: '06 AW 330xi
You'll be fine waiting to repair it. It's for stricter CA emissions testing. Other states do not require this sensor and you do not need it for the operation of the car, however that annoying light will be there.

The sensor is welded into the radiator, which is dumb, which requires the whole radiator to be replaced.
__________________

| LCI Msport Conversion | Custom Kevlar/Carbon Fiber Wind Splitter | H&R Coilovers | L7 | Hand-Made LED Angel Eyes | Breyton GTS-R | Michelin Pilot Super Sports | CarPC with Centrafuse Front End | Alpine Type-R 1242D | JL 500/1 | Alpine MRP-M500 | Custom LED Reverse Lights | OEM Blacklines | BMW Performance Trunk Spoiler |
Reply With Quote
  #4  
Old 11-11-2013, 03:15 PM
twiz88 twiz88 is offline
Registered User
Location: Baltimore
 
Join Date: Nov 2013
Posts: 41
Mein Auto: 2007 BMW 328xi Coupe
Quote:
Originally Posted by mr_bean View Post
It may be as simple as a little bit of water getting into the electrical connector for the sensor. Unplug it after driving the car (while it's still warm) to help dry it out, then reset the error code. If that doesn't fix it, then I believe this repair should be covered under the federal SULEV emissions warranty of 15yr/150K miles.
I called the dealer and they stated that its not covered under the SULEV warranty is that true?
Reply With Quote
  #5  
Old 11-11-2013, 03:16 PM
twiz88 twiz88 is offline
Registered User
Location: Baltimore
 
Join Date: Nov 2013
Posts: 41
Mein Auto: 2007 BMW 328xi Coupe
Quote:
Originally Posted by fdriller9 View Post
You'll be fine waiting to repair it. It's for stricter CA emissions testing. Other states do not require this sensor and you do not need it for the operation of the car, however that annoying light will be there.

The sensor is welded into the radiator, which is dumb, which requires the whole radiator to be replaced.
I know this is crazy I may wait until my extended warranty coverage starts and have them replace it. the CEL went out for a second yesterday and came back on.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms