Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-13-2013, 05:15 AM
svre46 svre46 is offline
Registered User
Location: Itasca
 
Join Date: Jul 2013
Posts: 38
Mein Auto: 08 Z06//04 545i
Help with SOS error and Bluetooh coding.

My 04 545i came with a CIC retrofit and the original TCU from 03. Bluetooth was never enabled but I knew my TCU had it when I pulled my trunk liner. I decided to try and enable it. I have a few issues.

1) I enabled the bluetooth features in the TCU (TCUM) and successfully can connect, make calls, receive calls, voice commands work in NAV and for dialing ect. The mic however in the call does not work. All of the Trace files I see online are from the newer TCUs and look different than mine. Mine specifically is missing the line "USED_MICROPHONES wert_01" for example. Online with newer TCUs I see that this is there. I tried to add it and I get coding faulty error(I expected that). I figured coding would be different on a newer TCU.

2) I also now get the SOS error now. I did not have this before getting bluetooth 99% working. I have disabled everything I could find related in the TCU (TCUM) module. It is still there.
Ok I fixed the SOS error. Under SGM I changed verbau_telefon to night_verbaut and also uberwach_telephone to nicht_aktiv.

SOS button still works.



Any ideas? I will try to post my TRC file later today.

I was looking through NCS dummy and think there are a few things I will try to change tonight. I will post back results also.
__________________


04 545i ll Cold Weather ll Premium ll Sport ll Logic7 ll Mtech ll CIC Navigation ll LCI Headlights ll LCI Taillights

08 z06 ll 2LZ ll TSP LS7S Cam ll PRC Springs ll Airaide ll Too much to list

Last edited by svre46; 11-19-2013 at 11:40 AM.
Reply With Quote
Advertisement
  #2  
Old 11-14-2013, 04:45 AM
svre46 svre46 is offline
Registered User
Location: Itasca
 
Join Date: Jul 2013
Posts: 38
Mein Auto: 08 Z06//04 545i
Well,

I messed with the VO and re coded the modules below. Still have the warning. The SOS button itself works. I am thinking of maybe adding +TELD to the VO and re-coding KOMBI. I read that might work. I tried -TELD before but I am running out of options. Maybe I did it wrong and did not code that VO to KOMBI. As far as the speaker issue goes I will figure that out after the annoying SOS message.

Here are my Trace files if anyone can take a look.
Attached Files
File Type: pdf tcum.pdf (6.5 KB, 30 views)
File Type: pdf kombi.pdf (12.5 KB, 39 views)
File Type: pdf cas.pdf (14.8 KB, 48 views)
__________________


04 545i ll Cold Weather ll Premium ll Sport ll Logic7 ll Mtech ll CIC Navigation ll LCI Headlights ll LCI Taillights

08 z06 ll 2LZ ll TSP LS7S Cam ll PRC Springs ll Airaide ll Too much to list

Last edited by svre46; 11-14-2013 at 04:46 AM.
Reply With Quote
  #3  
Old 11-14-2013, 07:16 AM
fdriller9 fdriller9 is offline
Officially Welcomed to the 'Fest
Location: NJ/Philly
 
Join Date: Oct 2006
Posts: 3,076
Mein Auto: '06 AW 330xi
Yes you code +teld to VO and code lma and cas as well as tcu, cappl, CIC etc. any systems related to BMW assist.

Are you sure there is a mic installed? If the car didn't have bluetooth to begin with, there will be no mic installed.
__________________

| LCI Msport Conversion | Custom Kevlar/Carbon Fiber Wind Splitter | Exotic Tuning Front Lip | H&R Coilovers | M3 Subframe Bushings | E93 M3 23.6mm Rear Sway Bar | Whiteline 27mm Front Sway Bar | Ground Control Camber Kit | L7 | Hand-Made LED Angel Eyes | Breyton GTS-R | Bridgestone Pole Position S-04 | CarPC with Centrafuse Front End | Alpine MRP-M500 | Custom LED Reverse Lights | OEM Blacklines | BMW Performance Trunk Spoiler |
Reply With Quote
  #4  
Old 11-14-2013, 07:35 AM
svre46 svre46 is offline
Registered User
Location: Itasca
 
Join Date: Jul 2013
Posts: 38
Mein Auto: 08 Z06//04 545i
Quote:
Originally Posted by fdriller9 View Post
Yes you code +teld to VO and code lma and cas as well as tcu, cappl, CIC etc. any systems related to BMW assist.

Are you sure there is a mic installed? If the car didn't have bluetooth to begin with, there will be no mic installed.
Thanks,

There might not be a mic if there is more than one. Since assist worked, and all of the voice commands worked I thought it would be the same mic used. I followed the thread below and others have had success.

http://forums.5series.net/bluetooth-...ing-no-121586/

My main concern is the SOS error. I could really care less about Bluetooth at this point.
__________________


04 545i ll Cold Weather ll Premium ll Sport ll Logic7 ll Mtech ll CIC Navigation ll LCI Headlights ll LCI Taillights

08 z06 ll 2LZ ll TSP LS7S Cam ll PRC Springs ll Airaide ll Too much to list
Reply With Quote
  #5  
Old 11-14-2013, 12:59 PM
vadimr vadimr is offline
Registered User
Location: NNJ
 
Join Date: Feb 2012
Posts: 56
Mein Auto: car
Quote:
Originally Posted by svre46 View Post
Thanks,

There might not be a mic if there is more than one. Since assist worked, and all of the voice commands worked I thought it would be the same mic used. I followed the thread below and others have had success.

http://forums.5series.net/bluetooth-...ing-no-121586/

My main concern is the SOS error. I could really care less about Bluetooth at this point.
Pull the codes with INPA, what is it complaining about?
Reply With Quote
  #6  
Old 11-14-2013, 03:12 PM
svre46 svre46 is offline
Registered User
Location: Itasca
 
Join Date: Jul 2013
Posts: 38
Mein Auto: 08 Z06//04 545i
I am getting error 93f4 under the sgm. No communication with telefon.
__________________


04 545i ll Cold Weather ll Premium ll Sport ll Logic7 ll Mtech ll CIC Navigation ll LCI Headlights ll LCI Taillights

08 z06 ll 2LZ ll TSP LS7S Cam ll PRC Springs ll Airaide ll Too much to list
Reply With Quote
  #7  
Old 11-14-2013, 03:27 PM
svre46 svre46 is offline
Registered User
Location: Itasca
 
Join Date: Jul 2013
Posts: 38
Mein Auto: 08 Z06//04 545i
Ok I fixed the SOS error. Under SGM I changed verbau_telefon to night_verbaut and also uberwach_telephone to nicht_aktiv.

SOS button still works.

Now just to get Bluetooth Mic working.
__________________


04 545i ll Cold Weather ll Premium ll Sport ll Logic7 ll Mtech ll CIC Navigation ll LCI Headlights ll LCI Taillights

08 z06 ll 2LZ ll TSP LS7S Cam ll PRC Springs ll Airaide ll Too much to list

Last edited by svre46; 11-14-2013 at 05:21 PM.
Reply With Quote
  #8  
Old 11-19-2013, 11:30 AM
svre46 svre46 is offline
Registered User
Location: Itasca
 
Join Date: Jul 2013
Posts: 38
Mein Auto: 08 Z06//04 545i
So guys with Bluetooth. Is the mic near the sunroof switch? Do you have two mics? One for SOS/Assist/Voice commands and one just for Bluetooth? I see no other coding I can do and from what I can read on one thread the car uses two Microphones for Bluetooth and Assist. Just want someone to confirm this. Either way I will tear into the sunroof panel after work and take a look. Hopefully I'm missing a mic and there is a plug. I can swap the two out and resolve my issues.
__________________


04 545i ll Cold Weather ll Premium ll Sport ll Logic7 ll Mtech ll CIC Navigation ll LCI Headlights ll LCI Taillights

08 z06 ll 2LZ ll TSP LS7S Cam ll PRC Springs ll Airaide ll Too much to list

Last edited by svre46; 11-19-2013 at 11:38 AM.
Reply With Quote
  #9  
Old 11-19-2013, 11:52 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,295
Mein Auto: 2004 545i
Quote:
Originally Posted by fdriller9 View Post
Yes you code +teld to VO and code lma and cas as well as tcu, cappl, CIC etc. any systems related to BMW assist.

Are you sure there is a mic installed? If the car didn't have bluetooth to begin with, there will be no mic installed.

This is NOT correct for all E60's. My car did NOT come with bluetooth but still had two mics installed

Mine is a late 2003 545i that had assist & "telematics prep". It did not come with bluetooth from the factory.
Reply With Quote
  #10  
Old 11-19-2013, 11:53 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,295
Mein Auto: 2004 545i
Quote:
Originally Posted by svre46 View Post
So guys with Bluetooth. Is the mic near the sunroof switch? Do you have two mics? One for SOS/Assist/Voice commands and one just for Bluetooth? I see no other coding I can do and from what I can read on one thread the car uses two Microphones for Bluetooth and Assist. Just want someone to confirm this. Either way I will tear into the sunroof panel after work and take a look. Hopefully I'm missing a mic and there is a plug. I can swap the two out and resolve my issues.
There should be two mics. I can't remember which is which, but I THINK the mic for bluetooth is to the right side of the car. I remember thinking that it didn't make a whole lot of sense.. I can look it if up if you really need to know

I can confirm the bluetooth & Sos/assist use separate mics
Reply With Quote
  #11  
Old 11-19-2013, 12:00 PM
svre46 svre46 is offline
Registered User
Location: Itasca
 
Join Date: Jul 2013
Posts: 38
Mein Auto: 08 Z06//04 545i
Quote:
Originally Posted by schpenxel View Post
There should be two mics. I can't remember which is which, but I THINK the mic for bluetooth is to the right side of the car. I remember thinking that it didn't make a whole lot of sense.. I can look it if up if you really need to know

I can confirm the bluetooth & Sos/assist use separate mics
No, no need. I appreciate the added info. I'm going to check to make sure it is there. Swap them to test functionality. Like I said everything works except no one can hear me when making calls. VR and everything else works perfect. So I could have a bad mic , a missing mic, or a faulty TCU. I had prep but for whatever reason car has a TCU from 03.
__________________


04 545i ll Cold Weather ll Premium ll Sport ll Logic7 ll Mtech ll CIC Navigation ll LCI Headlights ll LCI Taillights

08 z06 ll 2LZ ll TSP LS7S Cam ll PRC Springs ll Airaide ll Too much to list

Last edited by svre46; 11-19-2013 at 12:09 PM.
Reply With Quote
  #12  
Old 11-19-2013, 12:01 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,295
Mein Auto: 2004 545i
Quote:
Originally Posted by svre46 View Post
No, no need. I appreciate the added info. I'm going to check to make sure it is there. Swap them to test functionality. Like I said everything works except no one can hear me when making calls. VR and everything else works perfect. So I could have a bad mic , a missing mic, or a faulty TCU.
I bet it's a missing mic personally--should be easy enough to check at least
Reply With Quote
  #13  
Old 11-19-2013, 12:08 PM
svre46 svre46 is offline
Registered User
Location: Itasca
 
Join Date: Jul 2013
Posts: 38
Mein Auto: 08 Z06//04 545i
Quote:
Originally Posted by schpenxel View Post
I bet it's a missing mic personally--should be easy enough to check at least
Yup! Thanks for the help.
__________________


04 545i ll Cold Weather ll Premium ll Sport ll Logic7 ll Mtech ll CIC Navigation ll LCI Headlights ll LCI Taillights

08 z06 ll 2LZ ll TSP LS7S Cam ll PRC Springs ll Airaide ll Too much to list
Reply With Quote
  #14  
Old 11-19-2013, 03:51 PM
svre46 svre46 is offline
Registered User
Location: Itasca
 
Join Date: Jul 2013
Posts: 38
Mein Auto: 08 Z06//04 545i
Well definitely had a Bluetooth mic. Swapped it with the VR mic and the mic worked for VR still. Has to be tcu, wiring, or coding.
__________________


04 545i ll Cold Weather ll Premium ll Sport ll Logic7 ll Mtech ll CIC Navigation ll LCI Headlights ll LCI Taillights

08 z06 ll 2LZ ll TSP LS7S Cam ll PRC Springs ll Airaide ll Too much to list
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms