Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 01-21-2014, 01:18 PM
mr_persuasion mr_persuasion is offline
Registered User
Location: College Park, MD
 
Join Date: Jan 2014
Posts: 3
Mein Auto: 2005 X5 3.0
Exclamation 2005 x5 3.0 Radio Not Working

can anyone help me here please, i just bought a 2005 3.0 x5 2 weeks ago n the only bad thing is the radio doesn't work n ni bought it "As Is" from the dealer...there is power to the nag system but when the car is started the radio doesn't turn on n i cannot power it on even when pressing the power button...what could I do to get this fixed on my own..?
Reply With Quote
Ads by Google
  #2  
Old 01-21-2014, 02:28 PM
chatcher chatcher is offline
Registered User
Location: pa
 
Join Date: Dec 2013
Posts: 75
Mein Auto: e46 m3
Have you checked fuses yet?
__________________
03 E46 M3
06 E90 330i
02 E53 X5 3.0
03 dodge ram
05 ford expedition
03 rc51
RUNNING OUT OF GARAGE SPACE!!
Reply With Quote
  #3  
Old 01-30-2014, 02:10 PM
mr_persuasion mr_persuasion is offline
Registered User
Location: College Park, MD
 
Join Date: Jan 2014
Posts: 3
Mein Auto: 2005 X5 3.0
Yes I have n still it doesn't work...
Reply With Quote
  #4  
Old 02-06-2014, 06:06 AM
clare78 clare78 is offline
Registered User
 
Join Date: Feb 2014
Posts: 1
Mein Auto:
Disconnect the battery leave it 5 mins and reconnect the battery worked with mine


Sent from BimmerApp mobile app
Reply With Quote
  #5  
Old 02-06-2014, 05:28 PM
puddinboo puddinboo is offline
Officially Welcomed to the 'Fest
Location: on earth
 
Join Date: Jul 2013
Posts: 350
Mein Auto: 2003 BMW X5
could need to be programmed to work if it was disconnected and vehicle was. started
__________________
2003 X5 3.0i
Reply With Quote
  #6  
Old 02-07-2014, 07:03 AM
grussell grussell is offline
02 X5 4.4
Location: Longmont, CO
 
Join Date: Feb 2014
Posts: 14
Mein Auto: 02 X5 4.4
Look inside the trim panels in the cargo compartment and look for electronic box that is part of the radio/nav system. The look for a colored fuse. Red I think.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms