Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 10-14-2004, 09:11 AM
pjo1966 pjo1966 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles
 
Join Date: Jul 2004
Posts: 102
Mein Auto: 2005 325i
anyone with brake problems?

I was talking with someone who just got the X3. He was complaining of a grinding noise when he applied brakes. Has anyone else experienced this? I've had this problem with my Infiniti FX35 for the past year and it's one of the factors leading me back to BMW (last car was a Z3). If this is going to be a problem with the X3 I'm going to have to start researching other vehicles.
Reply With Quote
Advertisement
  #2  
Old 10-14-2004, 09:24 AM
LeucX3 LeucX3 is offline
~~~~~~~~~~
Location: San Francisco
 
Join Date: Dec 2001
Posts: 4,408
Send a message via AIM to LeucX3
Mein Auto: 06 VW Jetta GLI
No problems after 7000 miles.
__________________
Reply With Quote
  #3  
Old 10-14-2004, 09:28 AM
pjo1966 pjo1966 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles
 
Join Date: Jul 2004
Posts: 102
Mein Auto: 2005 325i
Quote:
Originally Posted by LeucX3
No problems after 7000 miles.
I'm relieved to hear that. This guy's credibility was questionable... he didn't even know what year his X3 was. He definitely was not a car enthusiast.
Reply With Quote
  #4  
Old 10-14-2004, 09:30 AM
LeucX3 LeucX3 is offline
~~~~~~~~~~
Location: San Francisco
 
Join Date: Dec 2001
Posts: 4,408
Send a message via AIM to LeucX3
Mein Auto: 06 VW Jetta GLI
Quote:
Originally Posted by pjo1966
I'm relieved to hear that. This guy's credibility was questionable... he didn't even know what year his X3 was. He definitely was not a car enthusiast.
Maybe he has a 2003.
__________________
Reply With Quote
  #5  
Old 10-14-2004, 09:38 AM
pjo1966 pjo1966 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles
 
Join Date: Jul 2004
Posts: 102
Mein Auto: 2005 325i
He said he assumed it was an '05. I told him he was wrong. I didn't tell him that the sunroof and automatic were no charge options on the '05 or that they were supposed to upgrade the interior.
Reply With Quote
  #6  
Old 10-19-2004, 07:34 PM
moonlite moonlite is offline
Registered User
Location: Las Vegas
 
Join Date: Sep 2004
Posts: 17
Mein Auto: X3
I have 1,500 miles on mine and my brakes sqeek a little, but not grinding.....
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Having trouble with brake fade and pedal feel (long) JonW Motorsports, Racing & Track 22 08-03-2004 08:26 AM
Do you really need to change your brake fluid???? wavewuver 3 Series / 4 Series 63 07-29-2004 06:44 PM
Brake issue TC330Ci 3 Series / 4 Series 0 02-04-2002 01:02 PM
Problems with new 7-series SchwartzBlack General BMW 3 01-14-2002 07:13 PM


All times are GMT -7. The time now is 07:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms