Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 07-15-2014, 05:30 AM
Tbear112 Tbear112 is offline
Registered User
Location: Anchorage
 
Join Date: Jul 2014
Posts: 2
Mein Auto: 2008 bmw 328xi
Question Speaker problems

I have a 2008 bmw 328xi and the speakers pop like a heart beat. While driving the radio has a mind of its own, turning on and off by its own. Plus my usb port, aux, bluetooth and sos isn't working. I went to the dealership and they don't have a clue. Can someone please tell me what is wrong with my car ???

Last edited by Tbear112; 07-15-2014 at 05:53 AM.
Reply With Quote
Ads by Google
  #2  
Old 07-15-2014, 06:30 AM
fdriller9 fdriller9 is offline
Officially Welcomed to the 'Fest
Location: NJ/Philly
 
Join Date: Oct 2006
Posts: 2,591
Mein Auto: '06 AW 330xi
If BMW Assist (SOS) is not working, there is a break in the MOST loop or the TCU is failing.

When a module on the MOST loop fails, it brings down the entire network.

So when you resolve your issue with this bus, it should resolve all the other issue since they are all on the MOST bus.

My guess is your TCU or head unit.
__________________

| LCI Msport Conversion | Custom Kevlar/Carbon Fiber Wind Splitter | Exotic Tuning Front Lip | H&R Coilovers | M3 Subframe Bushings | E93 M3 Rear Sway Bar | Ground Control Camber Kit | L7 | Hand-Made LED Angel Eyes | Breyton GTS-R | Bridgestone Pole Position S-04 | CarPC with Centrafuse Front End | Alpine MRP-M500 | Custom LED Reverse Lights | OEM Blacklines | BMW Performance Trunk Spoiler |
Reply With Quote
  #3  
Old 07-15-2014, 07:12 AM
Tbear112 Tbear112 is offline
Registered User
Location: Anchorage
 
Join Date: Jul 2014
Posts: 2
Mein Auto: 2008 bmw 328xi
Where can I locate the tcu or head unit ?
Reply With Quote
  #4  
Old 07-15-2014, 09:53 AM
ctuna ctuna is offline
Officially Welcomed to the 'Fest
Location: usa
 
Join Date: Jan 2010
Posts: 2,208
Mein Auto: 325xi wagon
FYI note these are old documents

Head Unit =idrive or pro radio.

FYI note these are old documents and apply mostly to 06 and 07 cars with small changes
up to 09 and some larger ones after.

http://www.e90post.com/forums/attach...2&d=1260829447

http://www.e90post.com/forums/attach...2&d=1266451970

Most loop description in the following

http://www.google.com/url?sa=t&rct=j...,d.cGU&cad=rja

Also since its and 08 have you checked the battery or changed it ?
The IBS system is described in the above document, it can do strange stuff when going bad ?
Have you had the battery cable recall and if you did maybe they messed it up?
To eliminate modules you could put a most jumper on the radio or nav/idrive and see if the
sound or problem goes away. Then work through taking out each module in the same manner
to see if its the cause. But the battery and electrical system must function normally with just
the radio or idrive first.

Last edited by ctuna; 07-15-2014 at 10:04 AM.
Reply With Quote
  #5  
Old 07-15-2014, 10:28 AM
wardlowk wardlowk is offline
Officially Welcomed to the 'Fest
Location: Arkansas
 
Join Date: Oct 2006
Posts: 183
Mein Auto: BMW 325i
Ironic I was just searching for a solution to my daughters '07 328i similar radio problem. She called last night to describe that her speakers starting popping and kept popping for a few minutes after the car was turned off and the key removed. When she started it back up later the radio did not work at all and the LCD display on the radio would not even light up. In the past on my '11 335i and her 328i when it has been real hot on a summer day after a long drive the radio has done something similar, spreakers start popping then the sound goes off but will start playing again after the car cools off (and the display never goes dark). My first thought is a blown fuse since the display is also dark - or could it be something more serious. The problem is she is 225 miles away and I can't get into it to see. Any thoughts before I send her to the shop$$? Thanks
Reply With Quote
  #6  
Old 07-15-2014, 04:29 PM
ctuna ctuna is offline
Officially Welcomed to the 'Fest
Location: usa
 
Join Date: Jan 2010
Posts: 2,208
Mein Auto: 325xi wagon
Electronics in car do not power down right away.

Electronics in car do not power down right away.
And since some of the warning sounds can come through the
speakers the amp is not off even off when the radio is.
The Radio is never really off its just in do not play music mode.
If you lock the car it will cause it to go into sleep mode within a few
minutes turning off the amp. If you don't it can stay on as much as and hour if its
paired to a cell phone that's in range.
See the description in the last link for IBS system and Power distribution
and bus systems.

In an 06 or 07 that hasn't had a battery change its always a good idea
to check the battery first as 6 years is about all they last in a car that's regularly
driven moderate to long distances.

Last edited by ctuna; 07-15-2014 at 04:32 PM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms