Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #26  
Old 07-25-2014, 11:20 PM
serge1's Avatar
serge1 serge1 is offline
Officially Welcomed to the 'Fest
Location: seattle
 
Join Date: Jan 2012
Posts: 676
Mein Auto: 2011 BMW X5 35D
So it is normal to briefly have the dsc error after doing the cables thing? Interesting..
Reply With Quote
  #27  
Old 07-26-2014, 12:12 AM
HT417's Avatar
HT417 HT417 is offline
Officially Welcomed to the 'Fest
Location: Oberpfalz, Germany
 
Join Date: Dec 2007
Posts: 721
Mein Auto: 2008 BMW X5 3.0si
Yeah, that's what I've read and also what my colleague experienced when he replaced his X3(E83) battery a couple of years ago.
Reply With Quote
  #28  
Old 07-28-2014, 01:11 AM
serge1's Avatar
serge1 serge1 is offline
Officially Welcomed to the 'Fest
Location: seattle
 
Join Date: Jan 2012
Posts: 676
Mein Auto: 2011 BMW X5 35D
OP, any update?
Reply With Quote
  #29  
Old 07-28-2014, 07:07 AM
alextoqiang alextoqiang is offline
Registered User
Location: Baton Rouge
 
Join Date: Jan 2014
Posts: 39
Mein Auto: BMW 08 X5 4.8i
Quote:
Originally Posted by serge1 View Post
OP, any update?
The problem hasn't happened again after I disconnected and connected the battery. I'll try a few more days to see.
Reply With Quote
  #30  
Old 07-28-2014, 10:33 PM
serge1's Avatar
serge1 serge1 is offline
Officially Welcomed to the 'Fest
Location: seattle
 
Join Date: Jan 2012
Posts: 676
Mein Auto: 2011 BMW X5 35D
Man, I would be afraid to drive a winding road for the fear of braking hard(er) before a turn then loosing engine power and power steering. You have got to get down to root cause somehow..
Reply With Quote
  #31  
Old 08-11-2014, 01:10 PM
alextoqiang alextoqiang is offline
Registered User
Location: Baton Rouge
 
Join Date: Jan 2014
Posts: 39
Mein Auto: BMW 08 X5 4.8i
Some updates:

The stall frequency seems significantly decline after I reconnecting battery, from once every 2 days to once every 2 weeks. But it does happen.
Given up reproducing the error, as it is too difficult. I tried half an hour and braked to stop for 50 times in an empty lot, but could not reproduce even once the problem. Continuing testing would only wear out my tires and brake pads.

I don't think dealer can help anything as no error code can be read and no way to reproduce stalling.

I'll just let it be, until I notice the stall frequency increases.

Anyway, thanks for all your information and suggestions.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms