Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 08-10-2014, 08:47 PM
Sweet16FirstCar Sweet16FirstCar is offline
Registered User
Location: Fort Walton Beach, Florida
 
Join Date: May 2011
Posts: 2
Mein Auto: 1989 BMW 525I
Exclamation 1989 525I Electrical Shut Down

I was driving the BMW home tonight, slowed for a stop light and all the electricity just went away to include the engine simply quit immediately. Everything just shut down instantly, Lights, Engine, all of it so coasted into a parking lot and had the car towed to the house. I have tested the Battery and it is fine, replaced it and the alternator about a year ago. This was without any warning, all electrical is simply just gone with no signs of life. Any help is appreciated. I checked the small fuses and all are fine.
Reply With Quote
Advertisement
  #2  
Old 08-10-2014, 10:14 PM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,319
Mein Auto: E23;E30;E38;E32;E34 +
Check all battery cables, terminations and connections. Then move on to major feed wires.
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #3  
Old 08-12-2014, 03:11 PM
Sweet16FirstCar Sweet16FirstCar is offline
Registered User
Location: Fort Walton Beach, Florida
 
Join Date: May 2011
Posts: 2
Mein Auto: 1989 BMW 525I
Red face Problem Solved

Thanks for the advice. I was a bit nervous when I saw the complex wiring but found the problem. There is a smaller positive lead coming directly off the positive battery terminal connected by a small bolt. It runs to what I will refer to as a fusible link. One wire goes into the small black case located just behind the battery on the passenger side of the car. Two wires come out and inside there is a piece of thin metal used as a fuse. That piece of metal had broke and when I connected the wires directly, PRESTO, the car had full electricity. It appears that one link controls electricity to the whole car. I really hope this find helps others. Very simple fix and I will order a new component so I can have the fuse back in place. Take care all.
Reply With Quote
  #4  
Old 08-12-2014, 07:44 PM
south26 south26 is offline
Officially Welcomed to the 'Fest
Location: Dayton, OH
 
Join Date: May 2009
Posts: 768
Mein Auto: 535i 1989
http://www.bmwe34.net/E34main/Mainte...sible_link.htm


Yep that is the fusible link.

Andy
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms