Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 08-11-2014, 10:29 PM
sle39lvr sle39lvr is offline
Officially Welcomed to the 'Fest
Location: South Florida
 
Join Date: Dec 2012
Posts: 126
Mein Auto: 08 E90
Checking Ignition Coils

I am getting a harsh vibration on the startups. It's worse when its's the first time in the morning and cold outside. It's like a somewhat harsh rock on the engine on the very first point of the engine starting, then it's smooth right afterwards.

I changed my plugs about 30K a go and engine has no error codes. I do have new engine mounts. So the main thing I can point at is ignition coils so far.

I own a BT Tool and wondering if I can check the ignition coils to see if any of them are on the way out?
Reply With Quote
Advertisement
  #2  
Old 08-11-2014, 11:03 PM
sptt144 sptt144 is offline
Officially Welcomed to the 'Fest
Location: Orange County, Ca.
 
Join Date: Aug 2012
Posts: 1,097
Mein Auto: 2009 335i
I am getting that again as well and last time I changed my plugs it improved substantially. Car rumbles back and forth a little then smooths out when I start it in the morning. I'm going to throw some new plugs in there again.
Reply With Quote
  #3  
Old 08-11-2014, 11:08 PM
Abeachb73 Abeachb73 is offline
Semper Fidelis
Location: Northern California soon SoCal
 
Join Date: Aug 2014
Posts: 21
Mein Auto: 2007 335XI; 73 Camaro RS
I had that problem a few months ago and the reader said i had a missfire, I replaced the coil pack and everything was back to normal,

Now Im getting it again but no code at all, and i have tried a few different code reader. I just bought plugs and coil packs and will replace the rest, will let you know how it turns out.
__________________


2007 335xi
Reply With Quote
  #4  
Old 08-12-2014, 06:19 AM
fdriller9 fdriller9 is offline
Officially Welcomed to the 'Fest
Location: NJ/Philly
 
Join Date: Oct 2006
Posts: 3,165
Mein Auto: '06 AW 330xi
There's no way I know of, to check the performance of an ignition coil through a diagnostic tool.

You either check and verify the resistance of the coil pack. Or you remove the coil pack and spark plug from the spark plug well, then ground the spark plug and have some one attempt to start the engine. You should see a blue spark across the "gap."

Have you guys checked your injectors? Try a fuel injector cleaner. I run one every couple oil changes. My oil change intervals are 6-7k miles though, not 10-15k as recommend.

If either a spark plug, coil pack, or injector is bad, you will have a misfire.

A scan tool will tell you which cylinder the misfire is occurring on. Swap the coil pack from the misfiring cylinder to one that is not misfiring. Do the same for the spark plug, in a different non-misfiring cylinder. If the code follows, you know which part is bad. If it doesn't, then it leaves the injector.

But you could also have a vacuum leak or bad cylinder compression (in which case you will need to run a compression test on the affected cylinder to verify).
__________________

| LCI Msport Conversion | Custom Kevlar/Carbon Fiber Wind Splitter | Exotic Tuning Front Lip | H&R Coilovers | M3 Subframe Bushings | E93 M3 23.6mm Rear Sway Bar | Whiteline 27mm Front Sway Bar | Ground Control Camber Kit | L7 | Hand-Made LED Angel Eyes | Breyton GTS-R | Bridgestone Pole Position S-04 | CarPC with Centrafuse Front End | Alpine MRP-M500 | Custom LED Reverse Lights | OEM Blacklines | BMW Performance Trunk Spoiler |

Last edited by fdriller9; 08-12-2014 at 06:23 AM.
Reply With Quote
  #5  
Old 08-13-2014, 07:39 PM
sle39lvr sle39lvr is offline
Officially Welcomed to the 'Fest
Location: South Florida
 
Join Date: Dec 2012
Posts: 126
Mein Auto: 08 E90
I DO have a BT Tool that I can use to scan it. However I am confident that there are no misfires.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms