Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 08-12-2014, 04:54 AM
Dawnmagee Dawnmagee is offline
Registered User
Location: North Carolina
 
Join Date: Aug 2011
Posts: 3
Mein Auto: 325i
335xi battery effecting water pump

So, I had my water pump replaced two weeks ago. The next day I shut my car off, pull the key and can here the pump continuing to run, stupidly I walk away. The next day I try to start my car and the battery is dead. I went away for a week, came back, charged the battery and brought the car to the dealership. They tell me my battery was/is bad and that's what messed up the water pump they just installed. They want to change my battery at $400 and tell me that that will fix the problem. Now I am a woman and I know I know **** about **** when it comes to cars however logic tells me that it's the other way around; the pump ran and drained my battery. However the dealership is insisting that I'm wrong. I have insisted that they take another look and that I will not be paying for a new battery if the running pump is still an issue.

Can someone PLEASE tell me if I am either correct or not correct in my assumption!
Reply With Quote
Advertisement
  #2  
Old 08-12-2014, 07:09 AM
fdriller9 fdriller9 is offline
Officially Welcomed to the 'Fest
Location: NJ/Philly
 
Join Date: Oct 2006
Posts: 3,040
Mein Auto: '06 AW 330xi
I've heard of the pump failing and running continuously, draining the battery but never the battery causing the pump to fail.

It's very rare for a battery to fail.

I would get an opinion else where and if they find it's not the battery, then contact BMW NA to dispute the dealership's claim.

You can find certified indy shops in your area here: www.bimmershops.com
__________________

| LCI Msport Conversion | Custom Kevlar/Carbon Fiber Wind Splitter | Exotic Tuning Front Lip | H&R Coilovers | M3 Subframe Bushings | E93 M3 23.6mm Rear Sway Bar | Whiteline 27mm Front Sway Bar | Ground Control Camber Kit | L7 | Hand-Made LED Angel Eyes | Breyton GTS-R | Bridgestone Pole Position S-04 | CarPC with Centrafuse Front End | Alpine MRP-M500 | Custom LED Reverse Lights | OEM Blacklines | BMW Performance Trunk Spoiler |
Reply With Quote
  #3  
Old 08-12-2014, 07:18 AM
Dawnmagee Dawnmagee is offline
Registered User
Location: North Carolina
 
Join Date: Aug 2011
Posts: 3
Mein Auto: 325i
You're awsome, thanks! I knew I wasn't completely crazy
Reply With Quote
  #4  
Old 08-12-2014, 07:33 AM
DSXMachina's Avatar
DSXMachina DSXMachina is offline
Non compos Mentos
Location: New Hampshire
 
Join Date: Dec 2007
Posts: 10,507
Mein Auto: 335i E92 TiAg 6MT ED
First, go back to the dealership. Have them put in writing precisely what they told you; that a defective battery caused the water pump to run until the battery went bad. I'll bet that there is no such statement on your work order from the previous visit.
Reply With Quote
  #5  
Old 08-12-2014, 09:57 AM
Dawnmagee Dawnmagee is offline
Registered User
Location: North Carolina
 
Join Date: Aug 2011
Posts: 3
Mein Auto: 325i
THANKS DSX! Since they still have my car I asked them to put it on the invoice somewhere, they're now taking another look at the 'problem'...go figure


Sent from BimmerApp mobile app
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms