Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 08-12-2014, 09:29 PM
bjincali bjincali is offline
BJINCALI_94530i
Location: California
 
Join Date: Jun 2012
Posts: 23
Mein Auto: 1994 530i
94 530iA transmission issues

Two days ago I noticed that I had full power when I tried to pass on the freeway going around 55 mph. No hesitation, nothing. It just surged forward. It was a thrill. Then, once I calmed down and settled at speed, I noticed my RPMs were high. It usually settles around 2000 RPMs cruising at 70 or more. It just has never worked hard while at a cruising speed. Now, I notice that it can be at 3500 or 4000 going 65mph. That's crazy and this is going to ruin my already abismal MPG. I assume it's because my car isn't downshifting. What would cause this? ECU issue? Transmission failing (automatic)?

Help? I love this car and want it to live!

Thanks,
BJ
Reply With Quote
Advertisement
  #2  
Old 08-12-2014, 09:34 PM
sea6speed's Avatar
sea6speed sea6speed is offline
Officially Welcomed to the 'Fest
Location: Seattle WA
 
Join Date: Jun 2010
Posts: 402
Mein Auto: 2011 135i 6MT
I think you mean it isn't up shifting...


Sent from BimmerApp mobile app
__________________
Reply With Quote
  #3  
Old 08-12-2014, 10:05 PM
bjincali bjincali is offline
BJINCALI_94530i
Location: California
 
Join Date: Jun 2012
Posts: 23
Mein Auto: 1994 530i
You're right...it isn't upshifting to bring those RPMs down. I was typing too fast and thinking too slow. What would cause this?
Reply With Quote
  #4  
Old 08-13-2014, 01:51 PM
Mr._Graybeard Mr._Graybeard is offline
Officially Welcomed to the 'Fest
Location: Wisconsin
 
Join Date: Oct 2011
Posts: 227
Mein Auto: '95 540i, '87 325ic
I believe you have a kickdown switch under the accelerator pedal. I'd check to make sure it isn't stuck in kickdown mode.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms