Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 12-29-2004, 09:13 AM
rtkane rtkane is offline
Registered User
Location: NJ
 
Join Date: Oct 2004
Posts: 8
Mein Auto: BMW X5
Anyone have this problem? ABS, DSC & xDrive fail?

About 2 weeks ago, my DSC, ABS, and Brake lights came on (manual says that ABS, DSC, & xDrive have failed). Next day, the lights were out and vehicle operated normally. Last week, they all came back on, and subsequently went out after the vehicle was parked briefly. Now the SES light is on.

So, I took it to the dealer on Monday--they said that they couldn't fix it that day and that I'd have it back yesterday. When it was just about complete, the dealer said they brought it out of the service bay to only have the lights come on again.

They still have my car and are saying that I have a bad DME module, which is not available in the US, but has to be shipped in from Germany and they won't have it until Friday or Monday. They'll provide a rental car for me, but does that seem right...that there's no DME module here in the states, or are they feeding me a line of BS????

Sorry for the duplicate post from Roadfly... just seems like most of the experts are here now.
Reply With Quote
Ads by Google
  #2  
Old 12-29-2004, 02:25 PM
beowulf777 beowulf777 is offline
Registered User
Location: Atlanta
 
Join Date: Oct 2004
Posts: 53
Mein Auto: 2004 X5 4.4i
Quote:
Originally Posted by rtkane
About 2 weeks ago, my DSC, ABS, and Brake lights came on (manual says that ABS, DSC, & xDrive have failed). Next day, the lights were out and vehicle operated normally. Last week, they all came back on, and subsequently went out after the vehicle was parked briefly. Now the SES light is on.

So, I took it to the dealer on Monday--they said that they couldn't fix it that day and that I'd have it back yesterday. When it was just about complete, the dealer said they brought it out of the service bay to only have the lights come on again.

They still have my car and are saying that I have a bad DME module, which is not available in the US, but has to be shipped in from Germany and they won't have it until Friday or Monday. They'll provide a rental car for me, but does that seem right...that there's no DME module here in the states, or are they feeding me a line of BS????

Sorry for the duplicate post from Roadfly... just seems like most of the experts are here now.
It is rather hard to believe there are no modules in the states since the cars are assembled in South Carolina.
__________________
Reply With Quote
  #3  
Old 12-29-2004, 05:48 PM
SNaray8442 SNaray8442 is offline
Registered User
Location: Austin, Texas
 
Join Date: Dec 2004
Posts: 38
Mein Auto: 1992 BMW M5
This happened to me when it was snowing, I'm not sure if its a major problem, there was only about 2 inches of snow on the ground, but its naver happened before, and once after; again in snow
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
This Is The Official Hijack Thread... Sabrina Off-Topic 146 05-21-2009 06:38 PM
t Nick T. The Test Board 5 07-05-2003 09:25 AM
DSC, ABS and Brake lights on after getting stuck in snow gek330i 3 Series / 4 Series 0 02-18-2003 10:57 AM
jon...need help...big problem (m) bimmerboy Regional Forums 6 10-28-2002 06:17 PM
ABS Failure Part III Ack 3 Series / 4 Series 28 06-14-2002 07:26 AM


All times are GMT -7. The time now is 05:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms