Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > 5 Series DIY

5 Series DIY
Knowledge Is Power! ~ The place for do-it-yourself threads on a variety of topics. Start a thread describing a particular job (oil change, cooling system overhaul, brakes, shocks and springs, etc.) or search for one you need help with!

Reply
 
Thread Tools Display Modes
  #526  
Old 12-08-2008, 05:54 AM
Waveho Waveho is offline
Officially Welcomed to the 'Fest
Location: Shenandoah Valley, Virginia
 
Join Date: Jul 2006
Posts: 3,362
Mein Auto: '07 335xi 6MT 4door
Quote:
Originally Posted by emilyb View Post
What exactly is a "goodwill warranty replacement"?
A goodwill replacement occurs where, as here, BMW has not issued a recall or bulletin but recognizes that there is a problem with a certain part and offers either to replace it or offer a discount for replacement.
__________________

'07 335xi 6-spd 4dr, Montego blue
'98 540i 6-spd Sport, Jet Black II(sold)
'92 325i 5-spd 4dr, burgundy(sold)
Reply With Quote
  #527  
Old 01-08-2009, 09:57 AM
ben753 ben753 is offline
Officially Welcomed to the 'Fest
Location: Seattle
 
Join Date: Jan 2007
Posts: 146
Mein Auto: 2003 530iA, Sp, Pre, Cold
Just called BMWNA to get the ball rolling on replacing my now completely failed radio display - no dice. They are only helping owners with failed pixels in the odometer display.

VERY frustrating. I'd love to know if anyone has an idea on how I might appeal this.

Thanks,

Ben
Reply With Quote
  #528  
Old 02-18-2009, 12:22 PM
nutterdog nutterdog is offline
Registered User
Location: Boston
 
Join Date: Feb 2009
Posts: 31
Mein Auto: 525i
BTW - For those with CPO I had no issues getting the MID replaced at the dealer for just the $50 deductible. About 90 minutes in and out.
__________________

2003 525i 5spd/PP/SP/CWP/Xenons/Sapphire/Black
CDV Delete
Dice Silverline
TCU Bluetooth
Reply With Quote
  #529  
Old 02-19-2009, 06:55 PM
kh1vtt kh1vtt is offline
Registered User
Location: New York
 
Join Date: Feb 2009
Posts: 16
Mein Auto: BMW 540i
how long did it takes before you get a response from Ms. Vlaovich?
Reply With Quote
  #530  
Old 02-24-2009, 08:25 PM
rock_head rock_head is offline
Registered User
Location: Edenton, North Carolina
 
Join Date: Feb 2009
Posts: 19
Mein Auto: 2003 540i M Sport 6
Me Too

I also just bought an '03 540i M Sport w/6 speed. The odometer is fine it's the radio (premier audio w/DSP) that's missing pixels. It's in the shop right now for diagnosis of the "Service Engine Soon" light which came on as I was driving it home from the dealership!! That doesn't seem to be too big a deal, just a plug coil that's being replaced under warranty. I'm very glad that I took it to the redline in 2nd gear when I did because that's when the light came on. The original warranty is only in effect for 9 more days. If I hadn't stressed the motor like I did the problem may not have showed up until it was too late to be covered. But I digress...... At any rate the dealer has already told me that the display would run me over $800 to replace. I could install a complete sound system for less than that using the existing speakers. Then I found this thread and immediately dashed off an e-mail to Leonora. Then I saw the date on this thread. Then I went to the end of the thread. Then I saw that Leonora is no longer involved with this issue. Then I took down the 800 number and will give BMWNA a call during business hours tomorrow. I'll let you know what they say. I see that many of you have had your odometer displays replaced. Has anyone had any luck with getting them to pop for the radio display?

Tim rock_head
1995 530i, 5 speed, black/black, 265k sharked, bilsteined
2003 540i, M Sport, 6 speed, silver/grey 65k
Reply With Quote
  #531  
Old 03-09-2009, 08:49 AM
ARX3 ARX3 is offline
Officially Welcomed to the 'Fest
Location: Reston VA
 
Join Date: Dec 2008
Posts: 229
Mein Auto: E60 '08 535xi, E83 '07 X3
any luck anyone?

Anyone else had any luck with BMWNA resolving this issue? I have called 800 number, and someone was supposed to get back to me. That was like 2 months ago.
__________________
BMWCCA #135536
Reply With Quote
  #532  
Old 03-18-2009, 07:22 PM
gunship911 gunship911 is offline
Officially Welcomed to the 'Fest
Location: northeast
 
Join Date: May 2008
Posts: 116
Mein Auto: 2003 530i 2011 550xi
According to BMW na the MID display is an accessory. They will not cover "accessory" failure. If you have better luck, let me know.
Reply With Quote
  #533  
Old 04-10-2009, 10:03 AM
pattynole pattynole is offline
Officially Welcomed to the 'Fest
Location: Neptune Beach
 
Join Date: Apr 2009
Posts: 176
Mein Auto: 2002 525i Wagon
i can't get the email to go through.
Reply With Quote
  #534  
Old 04-10-2009, 11:26 AM
pattynole pattynole is offline
Officially Welcomed to the 'Fest
Location: Neptune Beach
 
Join Date: Apr 2009
Posts: 176
Mein Auto: 2002 525i Wagon
just for info - i called 1-800-831-1117 and gave them my info. they are "researching" the issue and promise to call back in the next half-hour.
Reply With Quote
  #535  
Old 04-10-2009, 11:53 AM
pattynole pattynole is offline
Officially Welcomed to the 'Fest
Location: Neptune Beach
 
Join Date: Apr 2009
Posts: 176
Mein Auto: 2002 525i Wagon
Here's what I got from calling the 800 number:

Dear : Mr.
Thank you for contacting BMW of North America, LLC regarding your 2002 BMW 525i Sport Wagon. I was sorry to read of the concerns you have with the pixels on your vehicle's display.

So that we may assist with your inquiry, please provide us the following information:
-Name & address on the vehicle's registration
-Best phone numbers to reach you
-VIN#
-Mileage on vehicle
-Description of the problem on your vehicle
-Name of your BMW service center
-Has your BMW center diagnosed this problem?
-Are you the original owner?
-If not the original owner, is this the proper information to update you as the owner in our BMW system: customerrelations@bmwusa.com or FAX: 614-789-1992

If you have any further questions, please reply to this e-mail or contact the Customer Relations and Services Department at 1-800-831-1117, Monday through Friday from 9:00 A.M. to 9:00 P.M., Eastern Standard Time. Again, thank you for contacting BMW.

Sincerely,
Customer Relations and Services
Representative

Bryan.Rabell@bmwfs.com
Reply With Quote
  #536  
Old 04-10-2009, 03:29 PM
535idriver 535idriver is offline
Registered User
Location: Pa.
 
Join Date: Apr 2009
Posts: 1
Mein Auto: 1990 535i
Get missing dash pixels repaired by BMWNA

Think they will replace them on a 1990 535 i ?
Reply With Quote
  #537  
Old 04-11-2009, 01:56 PM
pattynole pattynole is offline
Officially Welcomed to the 'Fest
Location: Neptune Beach
 
Join Date: Apr 2009
Posts: 176
Mein Auto: 2002 525i Wagon
send them your info. all they can do is say no.
Reply With Quote
  #538  
Old 04-21-2009, 04:00 PM
ChasM ChasM is offline
Registered User
Location: Spain
 
Join Date: Apr 2009
Posts: 2
Mein Auto: BMW 328i
Wonder if BMW Spain will do the same thing, although there is the language problem to overcome , i.e I speak English and they dont, they speak Spanish and I dont. Is there a do it yourself fix at all, if so where do I look. Sorry new to this
Reply With Quote
  #539  
Old 04-22-2009, 09:22 AM
pattynole pattynole is offline
Officially Welcomed to the 'Fest
Location: Neptune Beach
 
Join Date: Apr 2009
Posts: 176
Mein Auto: 2002 525i Wagon
i got a call back after a couple of weeks. bmwna said they would set up the appointment with my local dealer and would cover 50% of the part's cost. so it would end up costing me about $400. the pixels aren't that bad. no thanks.
__________________
2002 525i Sport Touring
Reply With Quote
  #540  
Old 05-24-2009, 08:15 AM
okeah okeah is offline
Registered User
Location: oakville
 
Join Date: May 2009
Posts: 3
Mein Auto: x5
Quote:
Originally Posted by pattynole View Post
i got a call back after a couple of weeks. bmwna said they would set up the appointment with my local dealer and would cover 50% of the part's cost. so it would end up costing me about $400. the pixels aren't that bad. no thanks.
I just recently fixed my X5 2001 cluster display and MID display in Toronto for 250cad per display. I found them on eBay, you can type in ebay search "bmw instrument display pixels repair" it seems they always have opened auctions. Before that I was trying to fix it myself but it helped for 3 weeks only then pixels started to dim again. They replaced flex ribbon inside units. Now is about 3 months and everything runs as new, they claim it to be perfect for another 5-7 years. At least BMW Canada didn't help me out as you guys in USA. Let's see!
Reply With Quote
  #541  
Old 05-28-2009, 03:12 PM
shenecke's Avatar
shenecke shenecke is offline
Officially Welcomed to the 'Fest
Location: Lodi, ca.
 
Join Date: Oct 2005
Posts: 228
Mein Auto: 2000 540IA Sport
Called the 800 number yesterday and talked with Brian. Gave him the usual information, vin, 2000 540IAS, 90,500 miles, 2nd owner CPO, and faxed in my registration. At first he wanted my registration, insurance and a bill of sale, but then said just needed the registration. He said to book an appointment with the dealer and he would contact them after researching my claim with the amount of coverage.
Reply With Quote
  #542  
Old 05-29-2009, 09:07 PM
paul325740 paul325740 is offline
Registered User
Location: USA
 
Join Date: Jul 2006
Posts: 98
Mein Auto: 325it, 540it,740il, 330i
emailed them and fax registeration to them. got a call from them...will cover only 50% on parts not labor...
__________________
Reply With Quote
  #543  
Old 06-02-2009, 10:27 AM
shenecke's Avatar
shenecke shenecke is offline
Officially Welcomed to the 'Fest
Location: Lodi, ca.
 
Join Date: Oct 2005
Posts: 228
Mein Auto: 2000 540IA Sport
Update: got a call today from BMWNA new person who is researching my claim. he asked which pixels were bad and what percentage of the display was out. I told him 66%. He also asked again about ownership, I told him I was the second owner and bought it as a CPO. He told me I would here back in a couple of days.





Quote:
Originally Posted by shenecke View Post
Called the 800 number yesterday and talked with Brian. Gave him the usual information, vin, 2000 540IAS, 90,500 miles, 2nd owner CPO, and faxed in my registration. At first he wanted my registration, insurance and a bill of sale, but then said just needed the registration. He said to book an appointment with the dealer and he would contact them after researching my claim with the amount of coverage.
Reply With Quote
  #544  
Old 06-02-2009, 12:49 PM
kingbled kingbled is offline
Officially Welcomed to the 'Fest
Location: Washington DC
 
Join Date: Feb 2009
Posts: 154
Mein Auto: 1999 540i 6speed
They said same thing for me.

Quote:
Originally Posted by pattynole View Post
i got a call back after a couple of weeks. bmwna said they would set up the appointment with my local dealer and would cover 50% of the part's cost. so it would end up costing me about $400. the pixels aren't that bad. no thanks.
They said the same thing to me. I thought that was not good enough how about they just get me the part and I will handle the install myself. I thought they would do a little better....well at the same time it is better then nothing so beggers can't be choosy....
Reply With Quote
  #545  
Old 06-16-2009, 03:51 PM
shenecke's Avatar
shenecke shenecke is offline
Officially Welcomed to the 'Fest
Location: Lodi, ca.
 
Join Date: Oct 2005
Posts: 228
Mein Auto: 2000 540IA Sport
Dealer did the job parts and labor out the door for $396.




Quote:
Originally Posted by shenecke View Post
Update: got a call today from BMWNA new person who is researching my claim. he asked which pixels were bad and what percentage of the display was out. I told him 66%. He also asked again about ownership, I told him I was the second owner and bought it as a CPO. He told me I would here back in a couple of days.
Reply With Quote
  #546  
Old 06-19-2009, 05:14 PM
dubis dubis is offline
Officially Welcomed to the 'Fest
Location: Burlingame, CA
 
Join Date: Dec 2006
Posts: 281
Mein Auto: 325Ci
Just got my Nav screen replaced (2004 325) by the dealer for $165. I followed the earlier recommendations - called BMWNA, they referred me to the dealer, the SA took a look at it, called me back and said they would supply the part if I paid the labor.
Reply With Quote
  #547  
Old 07-17-2009, 08:54 AM
wonderstorm wonderstorm is offline
Registered User
Location: Philadelphia
 
Join Date: Jul 2009
Posts: 20
Mein Auto: 2002 530i
The order that you go through this process matters!!!

Having just scheduled the service visit to have the instrument cluster replaced on my 530i, I learned a few things that will hopefully help others going through this process. As of July 2009, BMWNA is still helping owners with the replacement of the instrument cluster pixel issue. As others have suggested, always remain courteous during the process, and if their offer is "less" than what you've read others have received, counter their offer, the worst they can say is no.

Here's where the process goes screwy for me. In the initial contact to BMWNA, I specified a dealership that is convenient to my home that I have had no contact with before as I recently purchased the car. After (eventually) being offered 100% on the part, I contacted the dealership for an estimate for the install. I was quoted $300+ for the install. Feeling that this was a bit steep based on other posts, I contacted 4 other "area" dealerships and got 4 different install costs (ranging from $120 - $190). Of course the one I specified is the most expensive...

I got back in touch with the BMWNA representative that I had been dealing with and asked to have the dealership changed to another one. As it turns out, (which my rep was unaware as well) apparently the goodwill replacement is more linked to the specific dealership than either of us thought. To have the location changed I would have needed to close the original case and open a new one that would be subject to "the market team @ BMWNA".

To save some money, contact several area dealerships and get an estimate for the install FIRST!!! Select the location and price that works for you and specify that location when asked by BMWNA.

I hope this helps somebody save some $$'s
Reply With Quote
  #548  
Old 07-24-2009, 07:16 PM
wonderstorm wonderstorm is offline
Registered User
Location: Philadelphia
 
Join Date: Jul 2009
Posts: 20
Mein Auto: 2002 530i
A quick follow up to my previous post.

The cost to have the new cluster installed ended up being approx $220, down from the original $300+. There was no complaining on my end (but there was going to be). When I arrived for the service appointment I was informed that the price was lower than the original estimate... your guess is as good as mine exactly why.

While it was certainly nice to save $80 on the repair, it would have been nicer to have only paid $120, so do your research BEFORE contacting BMWNA.
Reply With Quote
  #549  
Old 08-04-2009, 06:55 AM
drklausmeyer drklausmeyer is offline
Registered User
Location: Roswell, GA
 
Join Date: Jul 2009
Posts: 6
Mein Auto: 2002 525 i Sport Wagon
The email is defunct (well it is a few years old)
Reply With Quote
  #550  
Old 08-04-2009, 07:03 AM
wonderstorm wonderstorm is offline
Registered User
Location: Philadelphia
 
Join Date: Jul 2009
Posts: 20
Mein Auto: 2002 530i
What e-mail are you referring to? I used the "contact us" link on the bottom of www.bmwusa.com.

Here is the direct link to the online contact form.

It took a day or 2 for them to get back to me, but they did and were helpful through the process.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > 5 Series DIY
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
BMWNA: Do you have paint chips (hood, bumper) from driving? If so please READ THIS! jaisonline General BMW 87 11-10-2010 07:13 PM
Disappearing dash pixels - DIY fix? TXE38 7 Series / 8 Series 15 01-18-2010 04:39 PM
Dash pixels have been repaired Cabriolet E39 (1997 - 2003) 30 03-16-2009 12:41 AM
91 850i Heater Core Removal Instructions Wanted nicko 7 Series / 8 Series 1 10-18-2004 10:56 PM
Keep on nocking but you can't come in TeamM3 Off-Topic 4 10-17-2003 06:27 AM


All times are GMT -7. The time now is 08:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms